Old 21st December 2009, 22:03   #1
ChodaBoy
Junior Member
 
Join Date: Jul 2008
Posts: 5
libxml2.dll is missing?

Every time I start Winamp, I receive this error:

Quote:
The program can't start because libxml2.dll is missing from your computer. Try reinstalling the program to fix this problem.
Reinstalling does not resolve the problem. Curiously, when the installer launches Winamp at the end of installation, I do NOT receive the error. However, every launch after that does.

I have checked and there is no libxml2.dll in the Winamp directory. I do have copies of the DLL in the directories of other applications. Each copy seems to be a different version.

Clean install of Windows 7 Ultimate 64 bit, Version 6.1 (Build 7600)
Winamp v5.56 (x86) - Jul 1 2009

Anyone have any ideas?

UPDATE:
I have been able to make the error stop by downloading the following DLLs and placing them in the Winamp directory.
1) libxml2.dll
2) iconv.dll
3) zlib1.dll

You can get all three here:
xmlsoft.org - Windows port maintained by Igor Zlatkovic
ftp://ftp.zlatkovic.com/libxml/

My question is this, why were these DLLs not installed by the Winamp installer?

Last edited by ChodaBoy; 21st December 2009 at 22:28.
ChodaBoy is offline   Reply With Quote
Old 21st December 2009, 22:39   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
is because they're not used by any of the native parts of the Winamp distribution. the need for those files would be due to a 3rd party plugin / application which needs them. a plugin list should make it easier to see if you've any 3rd party plugins installed

-daz
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump