Old 28th January 2022, 11:28   #1
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
BogProg AterKast is now available!!!

Streaming/source plugin for Winamp.

Download

Supports:
  • MP3
  • AAC LC (no Main or HE)
  • Vorbis
  • Opus
  • FLAC
  • SHOUTcast v2/Ultravox Protocol
  • SHOUTcast v1 Protocol
  • Icecast Protocol

Unlike the official SHOUTcast DSP, this one supports Intro and Backup files on SCv2 servers.

SSL support is currently tentative.

Sound card support is also tentative but working.

The reason why I made this was because I got sick and ******* tired of the official one crashing every 3 to 4 days of continuous streaming. It drove me insane.

Just so you know, at one point I had this crazy thing continuously streaming for 3 months straight with no crashes.

Screenshots:




I do plan to add more streaming protocols and metadata sources later on. I wanted to get this out there working as soon as possible because I figure I can't be the only person having crashing problems with the official SHOUTcast DSP.
Attached Thumbnails
Click image for larger version

Name:	AterKastSS1.png
Views:	1092
Size:	10.6 KB
ID:	54856   Click image for larger version

Name:	AterKastSS2.png
Views:	633
Size:	21.8 KB
ID:	54857   Click image for larger version

Name:	AterKastSS3.png
Views:	628
Size:	18.1 KB
ID:	54858   Click image for larger version

Name:	AterKastSS4.png
Views:	629
Size:	13.6 KB
ID:	54859   Click image for larger version

Name:	AterKastSS5.png
Views:	636
Size:	21.8 KB
ID:	54860  

thinktink is offline   Reply With Quote
Old 6th February 2022, 08:45   #2
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
This is in response to an email I received about Intro and Backup files for the SHOUTcast v2 Ultravox Protocol support.

You do not need to pre-transcode your Intro and Backup files like you had to with an earlier version of the now defunct sc_trans, the plugin literally makes an exact internal duplicate of the associated encoder and transcodes your files before sending them to the server. It caches the files so that the next time you connect it reuses the cache instead of re-transcoding the file every time you connect/reconnect but only as long as you don't change the selected source files or change your encoder configuration.
thinktink is offline   Reply With Quote
Old 14th March 2022, 04:56   #3
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
Version 1.0.0.2 is now available.

Changes:
  • Internal UI fix of skinned popup windows. This bug didn't effect AterKast but was fixed when I fixed the UI framework shared with another plugin.
  • Added a plugin-wide configuration window.
  • Added plugin-wide configuration to adjust TCP/IP connection timeouts.
  • Added a proper about box.
thinktink is offline   Reply With Quote
Old 15th March 2022, 19:25   #4
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,814
Send a message via AIM to MrSinatra
wow, this is very cool...

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 27th September 2022, 17:48   #5
WowMachine
Member
 
WowMachine's Avatar
 
Join Date: Jun 2016
Location: Santa Isabel, Ecuador
Posts: 67
Hi! Longtime since we communicated last!

I LOVE your livewire mixin dsp....so I'm looking forward to trying this out to replace sc_dsp2.3.5...how does this one stack with it? Any peculiarities with the output or dsp that needs to be taken into account?

I'll report back my final setup when it is all working if I don't hear back in the meantime.

Wow Machine Radio -- Where You Never Know What You'll Hear Next!
code:
Streaming Radio | Podcast Production | Processing Labs
Listen Live

WowMachine is offline   Reply With Quote
Old 27th September 2022, 18:10   #6
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
Quote:
Originally Posted by WowMachine View Post
Hi! Longtime since we communicated last!

I LOVE your livewire mixin dsp....so I'm looking forward to trying this out to replace sc_dsp2.3.5...how does this one stack with it? Any peculiarities with the output or dsp that needs to be taken into account?

I'll report back my final setup when it is all working if I don't hear back in the meantime.
Thank you!

There are some. There's no HE AAC+ as I have to use the Microsoft Media Foundation Transform API to provide AAC support and HE+ is not licensed through that. The minimum AAC LC kbps is 96k and max is 192k (from off the top of my head). Depending on the number of end points it can be slow to start due to the way I've setup the dynamic UI. There's no manual title updates yet. For SCv2 streams if you're sending album art the artwork will be transformed and resized if necessary to keep the art data overhead to a sane maximum (which I actually consider a feature.)

Other than those five things it should be superior to the official SC DSP with Intro and Backup file support for SCv2 streams, FLAC, Vorbis, and Opus streaming to Icecast, more than 5 endpoints (as many as you'd like as long as your computer can handle it), no crashes in the middle of streaming, password encryption through Microsoft APIs, TLS (SSL) support through Winamp's JNetLib, and the UI is skinned. There may be more features but I'm not at my development machine at the moment, at work, so this list is off the top of my head.
thinktink is offline   Reply With Quote
Old 28th September 2022, 02:49   #7
WowMachineRadio
Junior Member
 
Join Date: Sep 2022
Posts: 1
OMG what a frustrating day!

This is WowMachine ... I had to create a new account because after our exchange earlier, I tried to update the email on this account and it said it was going to send a confirmation email before I can continue using the forum. After waiting for hours, I just made this account and the activation email came within minutes....so I don't know what happened, but I think I may have lost access to change it.

Anyway.... the day experimenting with winamp 5.9+livewire+alterkast didn't go very well.
It may have been an easy fix at the time, but like I said, I couldn't post and didn't have another way of reaching you for advice.

After installing the plugins, I changed to the livewire dsp and then configured it to stack the alterkast dsp... but after winamp restarted, the outputs stopped showing the soundcard at all. I tried several different attempts with different attributes set, but in the end, I kept getting an error message telling me to install sound drivers.

Like I said, it may be an easy fix, but I didn't find it.

I also wanted to experiment with your xfade plugin as well, but since I never got both a playing track and a stream at the same time.
WowMachineRadio is offline   Reply With Quote
Old 28th September 2022, 14:47   #8
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
Quote:
Originally Posted by WowMachineRadio View Post
...

Like I said, it may be an easy fix, but I didn't find it.

...
Doesn't look like it will be an easy fix. After installing 5.9 on top of 5.8 I kept getting exceptions from JNetLib whenever I tried to start any of the Endpoints. After reinstalling 5.8 on top of 5.9 I kept getting the same exceptions. I had to delete all of the 5.9 files and dlls and then install 5.8 before I could get AterKast working again. Looks like I will have to try a clean install of 5.9 before I will be able to see your symptoms.

When you said "the outputs stopped showing the soundcard at all." did you mean from within AterKast's built-in "Microsoft Waveform Audio" soundcard support or from somewhere else?
thinktink is offline   Reply With Quote
Old 28th September 2022, 15:37   #9
WowMachine
Member
 
WowMachine's Avatar
 
Join Date: Jun 2016
Location: Santa Isabel, Ecuador
Posts: 67
Quote:
Originally Posted by thinktink View Post
Doesn't look like it will be an easy fix. After installing 5.9 on top of 5.8 I kept getting exceptions from JNetLib whenever I tried to start any of the Endpoints. After reinstalling 5.8 on top of 5.9 I kept getting the same exceptions. I had to delete all of the 5.9 files and dlls and then install 5.8 before I could get AterKast working again. Looks like I will have to try a clean install of 5.9 before I will be able to see your symptoms.

When you said "the outputs stopped showing the soundcard at all." did you mean from within AterKast's built-in "Microsoft Waveform Audio" soundcard support or from somewhere else?
I certainly don't have to use 5.9, I was experimenting afterall... I had an old copy of 5.666 still around and tried it, but pretty much the same results with 5.666 weirdness on top of it.

Both the aterKast's built-in said "not present" and winamp's own outputs direct and wavey both threw up messages that a soundcard needed to be installed.

Don't bother trying to replicate 5.9 on my behalf.... if it worked with 5.8, then I should try that first.

The other question I might as well add in here is if you think xfade plugin in would work with these other two? As I understand how xfade is supposed to work, it is doing the crossfading of the tracks before it sends the output to the dsp, right? (along with a noflush that will still make an audible output for the local speakers).

So, assuming I were to get 5.8+livewire+atercast all working together, then would xfade still work with livewire as the active dsp that stacked atercast?

I know these are separate issues, so first thing at hand would be for me to get 5.8 and reinstall the plugins and see what I get from there.

Wow Machine Radio -- Where You Never Know What You'll Hear Next!
code:
Streaming Radio | Podcast Production | Processing Labs
Listen Live

WowMachine is offline   Reply With Quote
Old 28th September 2022, 15:51   #10
NJK
FRISIAN
 
NJK's Avatar
 
Join Date: Sep 2003
Location: in a house
Posts: 16,407
Quote:
Originally Posted by thinktink View Post
After reinstalling 5.8 on top of 5.9 I kept getting the same exceptions. I had to delete all of the 5.9 files and dlls and then install 5.8 before I could get AterKast working again. Looks like I will have to try a clean install of 5.9 before I will be able to see your symptoms.
Correct, don't upgrade , see--> http://forums.winamp.com/showthread.php?t=458828
NJK is offline   Reply With Quote
Old 28th September 2022, 16:01   #11
WowMachine
Member
 
WowMachine's Avatar
 
Join Date: Jun 2016
Location: Santa Isabel, Ecuador
Posts: 67


Okay...here we go... this is with 5.8.

My order of operation was to install winamp.
Install atercast.
Install livewire.
Install dequeuer.

Open winamp.exe and navigate first to dsp and set livewire as active, bringing up the livewire window.
I click on config for livewire and set "always load dsps to stack" and restart.
Upon reopening, then I return to livewire's dsp and turn on atercast.
Winamp crashes.
When it starts back up.... I hit play without having set anything else, and this window popped up immediatly.

Wow Machine Radio -- Where You Never Know What You'll Hear Next!
code:
Streaming Radio | Podcast Production | Processing Labs
Listen Live

WowMachine is offline   Reply With Quote
Old 28th September 2022, 16:42   #12
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
At work at the moment so I can't test out the other issues until after.

However...

Quote:
Originally Posted by WowMachine View Post
...
The other question I might as well add in here is if you think xfade plugin in would work with these other two? As I understand how xfade is supposed to work, it is doing the crossfading of the tracks before it sends the output to the dsp, right? (along with a noflush that will still make an audible output for the local speakers).

So, assuming I were to get 5.8+livewire+atercast all working together, then would xfade still work with livewire as the active dsp that stacked atercast?

...
X-Fade completely takes over the audio processing chain starting from the input plugins. It crossfades the music before it reaches either the selected DSP plugin and the selected output plugin. AterKast and LiveWire have both been tested and do work with X-Fade installed with either NoFlush or ZeroPointer (preferred) as the active output plugin. It also smooths out the audio processing chain so that you don't get audio hiccups in your stream when broadcasting from Winamp without having to use soundcard support. That's with either AterKast or the official SHOUTcast DSP.
thinktink is offline   Reply With Quote
Old 28th September 2022, 20:30   #13
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
There's only one thing I can think of to try with that DirectSound driver error before I am able to get back home to test things out. Find Win7AAC.dll inside of C:\Program Files (x86)\Winamp\Plugins\bpaterkast\ and either rename it or move it out of the install path completely and see if it still gives you the same DirectSound error.
thinktink is offline   Reply With Quote
Old 29th September 2022, 03:27   #14
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
Clean install of 5.9 but still the same issue with JNetLib. I may have to dump SSL support through JNetLib and wait for the new Winamp SDK to come out to try again.
thinktink is offline   Reply With Quote
Old 29th September 2022, 04:33   #15
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
After a clean install of 5.9 and removing all JNetLib support in an internal build now I can't get lame_enc.dll to load in AterKast. Frustrating.
thinktink is offline   Reply With Quote
Old 29th September 2022, 04:46   #16
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
Quote:
Originally Posted by thinktink View Post
After a clean install of 5.9 and removing all JNetLib support in an internal build now I can't get lame_enc.dll to load in AterKast. Frustrating.
...

nvm

...

oops

...

thinktink is offline   Reply With Quote
Old 29th September 2022, 05:02   #17
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
Version 1.0.2.5 is now available.

Changes:
  • Removed JNetLib support (including SSL support) for compatibility with Winamp 5.9
  • Fixed lame_enc.dll search and load pathing.

Download
thinktink is offline   Reply With Quote
Old 29th September 2022, 05:08   #18
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
Quote:
Originally Posted by WowMachine View Post
...

Okay...here we go... this is with 5.8.

...
Unfortunately I was unable to replicate your error with neither 5.8 nor 5.9, with or without X-Fade installed. However, I don't have Win 11, just Win 10 and Win XP.

5.9 won't install on WinXP so I had no way of testing it in a development environment.
thinktink is offline   Reply With Quote
Old 8th October 2022, 03:54   #19
jhbmusic
Junior Member
 
Join Date: Oct 2022
Posts: 6
I'm getting the error "encoder library missing" on one of my Win 7 machines when trying to use the AAC encoder.

Win 7 SP1
Winamp 5.666
AterKast 1.0.2.5

Works fine on two other machines with the same specs as above. On those machines I have the encoder set to...

encoder: AAC
sample rate: 44.1
channels: stereo
bitrate: 128k
profile: default
payload: default
jhbmusic is offline   Reply With Quote
Old 10th October 2022, 14:01   #20
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
Quote:
Originally Posted by jhbmusic View Post
I'm getting the error "encoder library missing" on one of my Win 7 machines when trying to use the AAC encoder.

Win 7 SP1
Winamp 5.666
AterKast 1.0.2.5

Works fine on two other machines with the same specs as above. On those machines I have the encoder set to...

encoder: AAC
sample rate: 44.1
channels: stereo
bitrate: 128k
profile: default
payload: default
Just letting you know, I'm still looking into this. While you wait, can you double check if you have all updates installed?
thinktink is offline   Reply With Quote
Old 10th October 2022, 15:09   #21
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
Quote:
Originally Posted by jhbmusic View Post
I'm getting the error "encoder library missing" on one of my Win 7 machines when trying to use the AAC encoder.

Win 7 SP1
Winamp 5.666
AterKast 1.0.2.5

Works fine on two other machines with the same specs as above. On those machines I have the encoder set to...

encoder: AAC
sample rate: 44.1
channels: stereo
bitrate: 128k
profile: default
payload: default
I just discovered that Win7Aac.dll is dependent on MSVC 2010 MFC.

Try installing the 32bit image (vcredist_x86.exe) from https://www.microsoft.com/en-us/down....aspx?id=26999
thinktink is offline   Reply With Quote
Old 10th October 2022, 15:26   #22
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
Version 1.0.3.9 now available

Download

Changes:
  • Updated path search and loading for AAC MFT Encoder library.
thinktink is offline   Reply With Quote
Old 10th October 2022, 17:23   #23
jhbmusic
Junior Member
 
Join Date: Oct 2022
Posts: 6
That did the trick. Thanks! I did compare the Windows updates on all three machines, but somehow didn't notice that the problem machine didn't have MSVC 2010!
jhbmusic is offline   Reply With Quote
Old 10th October 2022, 19:57   #24
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
Quote:
Originally Posted by jhbmusic View Post
That did the trick. Thanks! I did compare the Windows updates on all three machines, but somehow didn't notice that the problem machine didn't have MSVC 2010!
Thank you for letting me know. I should probably pack the vcredist install with my installer.
thinktink is offline   Reply With Quote
Old 23rd October 2022, 04:26   #25
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
Version 1.1.4.13 now available.

Download

Changes:
  • Fixed an intermittent Access Violation on file transcodes for SCv2 intro and backup files. Most with moderately fast machines would not have seen this, just on slower machines.
  • Enabled DirectSound (The DirectX Audio API/Library) support for soundcard mode. I finally found the dumb error that was preventing me from enabling it. Don't ask, nevermind...
  • Tweaked threading model of Win7Aac AAC encoder library. Hopefully this gets rid of DirectSound driver errors for Win 11 users.

Installer changes:
  • Installer no longer kills all Winamp instances, just the ones targeted.
  • Installer now includes the required vcredist package. If not already installed, the VC 2010 Redistributable will be installed, required for Win7Aac.dll
thinktink is offline   Reply With Quote
Old 23rd October 2022, 21:10   #26
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
Quote:
Originally Posted by WowMachine View Post
...

Okay...here we go... this is with 5.8.

My order of operation was to install winamp.
Install atercast.
Install livewire.
Install dequeuer.

Open winamp.exe and navigate first to dsp and set livewire as active, bringing up the livewire window.
I click on config for livewire and set "always load dsps to stack" and restart.
Upon reopening, then I return to livewire's dsp and turn on atercast.
Winamp crashes.
When it starts back up.... I hit play without having set anything else, and this window popped up immediatly.
Windows 11 is a headache...

Installed Windows 11 and I was able to replicate your symptoms up until version 1.0.0.1 of Win7Aac.dll, which first came out with AterKast v1.0.2.5 and with v1.0.3.9. The latest version of AterKast (v1.1.4.13) comes with Win7Aac v1.0.1.2, which also works fine.

Try it now.
thinktink is offline   Reply With Quote
Old 6th November 2022, 05:39   #27
jhbmusic
Junior Member
 
Join Date: Oct 2022
Posts: 6
I've been running AterKast 1.0.2.5 on Winamp 5.9.0 Final Build 9999 for 4 weeks with no crashes or errors.

There were a couple of odd disconnects on 11-02-22, but AterKast reconnected and the stream continued just fine.

From the 11-02-22 log:

2022-11-02 03:00:44 INFO [SRC 192.168.1.15:51146 sid=1] Title update [Evile - Long Live New Flesh]
2022-11-02 03:02:25 WARN [SRC 192.168.1.15:51146 sid=1] Timeout waiting for data
2022-11-02 03:02:25 INFO [SRC 192.168.1.15:51146 sid=1] Shoutcast 2 source disconnected.
2022-11-02 03:02:29 INFO [SRC 192.168.1.15:58008] Shoutcast 2 source connection starting.
2022-11-02 03:02:29 WARN [SRC 192.168.1.15:58008 sid=1] Listener Auth - not supported
2022-11-02 03:02:30 INFO [SRC 192.168.1.15:58008 sid=1] Flush cached metadata
2022-11-02 03:02:30 INFO [SRC 192.168.1.15:58008 sid=1] Title update [Evile - Long Live New Flesh]
2022-11-02 03:02:30 INFO [SRC 192.168.1.15:58008 sid=1] stream detected AACv2, LC (2), 44100hz, estimated 128 kbps

--------------------

2022-11-02 18:01:20 INFO [SRC 192.168.1.15:58008 sid=1] Title update [Enslaved - Ruun II - The Epitaph]
2022-11-02 18:05:09 WARN [SRC 192.168.1.15:58008 sid=1] Timeout waiting for data
2022-11-02 18:05:09 INFO [SRC 192.168.1.15:58008 sid=1] Shoutcast 2 source disconnected.
2022-11-02 18:05:15 INFO [SRC 192.168.1.15:58202] Shoutcast 2 source connection starting.
2022-11-02 18:05:16 WARN [SRC 192.168.1.15:58202 sid=1] Listener Auth - not supported
2022-11-02 18:05:16 INFO [SRC 192.168.1.15:58202 sid=1] Flush cached metadata
2022-11-02 18:05:16 INFO [SRC 192.168.1.15:58202 sid=1] Title update [Enslaved - Ruun II - The Epitaph]
2022-11-02 18:05:16 INFO [SRC 192.168.1.15:58202 sid=1] stream detected AACv2, LC (2), 44100hz, estimated 128 kbps
jhbmusic is offline   Reply With Quote
Old 6th November 2022, 17:23   #28
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
Quote:
Originally Posted by jhbmusic View Post
...

There were a couple of odd disconnects on 11-02-22, but AterKast reconnected and the stream continued just fine.

From the 11-02-22 log:

2022-11-02 03:00:44 INFO [SRC 192.168.1.15:51146 sid=1] Title update [Evile - Long Live New Flesh]
2022-11-02 03:02:25 WARN [SRC 192.168.1.15:51146 sid=1] Timeout waiting for data...
Thank you for the report!

It could have been a network interruption or it could have been AterKast's fault, I can't tell from the log. Are you sourcing over a WiFi connection? Sometimes my WiFi does the same thing, it won't just be AterKast that have dropped connections, VNC will kick out at the same time and I have to wait about 5-6 seconds before it will reconnect.
thinktink is offline   Reply With Quote
Old 6th November 2022, 19:20   #29
jhbmusic
Junior Member
 
Join Date: Oct 2022
Posts: 6
No, not over WiFi, wired ethernet. I figured it might have been some networking glitch. I do listen over WiFi though when outside the house.

Winamp/AterKast is running on a 12 year old Win7 Home Dell laptop. That's all that laptop is used for.

Shoutcast Server 2.6.1.777 is running as a daemon in an Ubuntu VM on an 11 year old Win7 Pro Dell laptop. That's all that laptop is used for as well.

This combo is working very well now. I was getting random weird errors and disconnects and crashes when using the Shoutcast DSP's, so this is awesome.

I just use this setup for myself only.

Big thanks!
jhbmusic is offline   Reply With Quote
Old 6th November 2022, 21:57   #30
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
Quote:
Originally Posted by jhbmusic View Post
...

I just use this setup for myself only.

Big thanks!
Same here.

With AterKast you may also be interested in the following plugins:
  • LiveWire (I mostly use it just for DSP stacking now but others still use it as intended)
  • 250 band eq by nevi (dsp_neq.dll)
  • LoudMax v1.13 (dsp_LoudMax.dll)
  • X-Fade w/NoFlush or w/ZeroPointer instead (null output). X-Fade does more than just crossfade music, it also resamples the audio and prevents the playback rate timing from getting jacked up. This is the most recommended for anybody stream sourcing from Winamp; whether using AterKast, the official SHOUTcast DSP, or any other plugin.
  • BogProg support for Opus (I use it for the "advertisements" with X-Fade).
  • WebJockey (I use it for managing the "playlist" remotely mostly) Don't try it without saving your playlist first.
thinktink is offline   Reply With Quote
Old 8th November 2022, 01:50   #31
jhbmusic
Junior Member
 
Join Date: Oct 2022
Posts: 6
Cool, thanks for the suggestions.
jhbmusic is offline   Reply With Quote
Old 8th November 2022, 03:28   #32
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,186
Version 1.1.5.18 now available.

Download

Changes:
  • Fixed crash issue when turning off the DSP (from within a stacker or by selecting a different DSP from Winamp preferences) while one or more EndPoints were in the middle of trying to establish a connection to the distributer (aka DNAS, Icecast Server, etc...).
  • Fixed a crash issue on plugin quit.
  • Fixed multiple crash issues on plugin unload (whether by shutting down Winamp or unloading the plugin in a stacker).
None of the above crashes affected normal streaming, just during shutdown/quit/de-init.
thinktink is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Discussions

Tags
aterkast, bogprog, icecast, shoutcast, source

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump