Old 9th March 2012, 16:11   #1
helios399
Junior Member
 
Join Date: Jan 2011
Posts: 34
2 sc_serv crach

Hi all,

I have 7 instances of sc_serv and 30 instances of sc_trans on one server (Linux) and today 2 instances of sc_serv stops and I didn't find any reason for the moment.
this is the first time in eight months...

I have got no errors in the sc_serv.log

Here my sc_serv.conf (for logging)
---------------------------------
code:

log=1
logfile=/var/www/logss/sc_serv_8000.log
screenlog=0
w3cenable=1
w3clog=/var/www/logss/sc_w3.log
logclients=1
shoutcastsourcedebug=1



How can I modify sc_serv.conf for trying log erros, better than today in my configuration.
Where can I find errors when sc_serv crach because I found no errors in /var/log/syslog

Does a MP3 title can stops an instance of sc_serv (may be wrong encoding etc) ???

Thanks for help
helios399 is offline   Reply With Quote
Old 9th March 2012, 17:07   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
http://wiki.winamp.com/wiki/SHOUTcas...er_2#Debugging has all of the debug logging options which can be enabled.

as for crashing, it could be anything from invalid handling of metadata (on the public linkux builds that can cause a segfault) or too many listeners (is an issue going from 500-1000 clients with the current non-windows builds) or is due to incorrectly handled client connections.

is all covered in the known issues part of http://forums.winamp.com/showthread.php?t=332841

-daz
DrO is offline   Reply With Quote
Old 9th March 2012, 17:30   #3
helios399
Junior Member
 
Join Date: Jan 2011
Posts: 34
Thanks DrO
Do you know a method, or a tool for checking MP3 title to prevent invalid handling ?
Windows version (sc_serv) is more stable in this case ?
helios399 is offline   Reply With Quote
Old 9th March 2012, 19:06   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
not off hand, though it would be obvious if the crash is due to a title update issue. is only characters from 128-159 from what i remember which would cause the issue. plus it all depends on the version of sc_trans being used as build 54 pre-filters out the invalid characters.

-daz
DrO is offline   Reply With Quote
Old 12th March 2012, 12:10   #5
helios399
Junior Member
 
Join Date: Jan 2011
Posts: 34
Thanks again DrO

After many tests, I found this message on the Linux Console :

" terminate called after throwing an instance of 'std::runtime_error'
what(): XML parser error: not well-formed (invalid token) at line 15 "

Does this message can confirm your response about invalid handling of metadata ?

I use lastest releases : sc_trans build 54 / sc_serv V2 build 29
helios399 is offline   Reply With Quote
Old 12th March 2012, 12:43   #6
DrO
 
Join Date: Sep 2003
Posts: 27,873
that would be the known metadata handling issue in the v2 DNAS.

you should be able to determine the file which caused it from the sc_trans logs. if so then can you email me (address is on my site from my signature) and i'll try to replicate the issue since that build of sc_trans should be correctly filtering out invalid characters to prevent sc_serv2 getting to the point where it triggers the incorrect handling which leads to the crash with the non-windows builds.

-daz
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump