Old 17th September 2012, 18:07   #1
Bonsaai
Junior Member
 
Join Date: Sep 2012
Posts: 2
Connection Closed after added me succesfully

Hi There,
I try the hole day to make connection without closing of the connection.
I change the settings of the router and the port is open, so it must working.
This a print of my screen:

<09/17/12@19:48:26> [yp_add] yp.shoutcast.com added me successfully
<09/17/12@19:48:32> [dest: 64.12.243.206] connection closed (27 seconds) (UID: 3)[L: 1]{Bytes: 8192}(P: 0)
<09/17/12@19:48:38> [source] source dropped connection. disconnecting.
<09/17/12@19:48:39> [main] connecting to yp.shoutcast.com to remove myself [no source]
<09/17/12@19:48:39> [yp_rem] yp.shoutcast.com removed me!
<09/17/12@19:48:49> [dest: 64.12.243.204] connection closed (24 seconds) (UID: 4)[L: 0]{Bytes: 8192}(P: 1)
<09/17/12@19:55:38> [source] connected from 127.0.0.1
<09/17/12@19:55:38> [source] icy-nameutch house radio ; icy-genre:House
<09/17/12@19:55:38> [source] icy-pub:1 ; icy-br:40 ; icy-url:http://www.saiwin.com
<09/17/12@19:55:38> [source] icy-irc:#shoutcast. ; icy-icq:0 ; icy-aim:N/A
<09/17/12@19:55:39> [dest: 64.12.243.203] starting stream (UID: 5)[L: 1]{A: SHOUTcast Directory Tester}(P: 0)
<09/17/12@19:55:40> [yp_add] yp.shoutcast.com added me successfully
<09/17/12@19:56:03> [dest: 64.12.243.203] connection closed (26 seconds) (UID: 5)[L: 0]{Bytes: 8192}(P: 0)

Can somebody tell me, why he closed the connection many Times
Bonsaai is offline   Reply With Quote
Old 18th September 2012, 03:37   #2
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,289
Quote:
<09/17/12@19:48:38> [source] source dropped connection. disconnecting.
you can't listen with no source

"If you don't like DNAS, write your own damn system"

So I did
jaromanda is offline   Reply With Quote
Old 18th September 2012, 08:04   #3
Bonsaai
Junior Member
 
Join Date: Sep 2012
Posts: 2
That's right, I did it by myself to try again !

But the system, closed the connection everytime when I connect, after about 25 sec ...

So, he wont Touched it !
Bonsaai is offline   Reply With Quote
Old 18th September 2012, 10:21   #4
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,289
DNAS 1? DNAS 2? what source (shoutcast DSP for example) are you using - the more details you provide, the more likely someone will have an answer

"If you don't like DNAS, write your own damn system"

So I did
jaromanda is offline   Reply With Quote
Old 18th September 2012, 10:30   #5
DrO
 
Join Date: Sep 2003
Posts: 27,873
that's a log from a v1 DNAS. most likely it's a network or source issue causing it (which should have been mentioned in the starting post) as things seem to be ok when the source is connected. though a 25-30sec timeout on the client makes me wonder if there is a lack of audio being fed by the source. also would need to know what client is being used.

-daz
DrO is offline   Reply With Quote
Old 18th September 2012, 17:30   #6
idobi
Senior Member
 
idobi's Avatar
 
Join Date: Feb 2003
Location: Washington DC
Posts: 119
Send a message via AIM to idobi
From the logs, it appears to be AOL/Shoutcast directory tester that's disconnecting. That's normal. I don't see any actual clients connecting to the server.

idobi Network - http://idobi.com/
idobi Radio - http://idobiradio.com/
idobi App now available for iOS, Android and Windows Phone (http://idobi.com/app/)
idobi is offline   Reply With Quote
Old 18th September 2012, 17:40   #7
DrO
 
Join Date: Sep 2003
Posts: 27,873
only on #5, is hard to tell if #4 is the same or not though the test connection shouldn't be lasting for that long (is set to timeout after a few seconds). is all conjecture anyway with a partial log snippet and a lack of details from the OP.

-daz
DrO is offline   Reply With Quote
Old 18th September 2012, 18:28   #8
idobi
Senior Member
 
idobi's Avatar
 
Join Date: Feb 2003
Location: Washington DC
Posts: 119
Send a message via AIM to idobi
They're all directory tester IPs

idobi Network - http://idobi.com/
idobi Radio - http://idobiradio.com/
idobi App now available for iOS, Android and Windows Phone (http://idobi.com/app/)
idobi is offline   Reply With Quote
Old 18th September 2012, 18:38   #9
DrO
 
Join Date: Sep 2003
Posts: 27,873
after a look again at things and some older posts, it's pretty much got to be the source at fault and the Directory Tester connections are the white elephant in the room (and yes i probably should have noticed they're YP IPs but as i deal with DNS internally, i've never bothered to learn those IPs - got too much junk in the ol' grey cell as it is).

-daz
DrO is offline   Reply With Quote
Old 20th September 2012, 07:12   #10
idobi
Senior Member
 
idobi's Avatar
 
Join Date: Feb 2003
Location: Washington DC
Posts: 119
Send a message via AIM to idobi
I also wanted to add, if you're consistently getting disconnected after a couple seconds and you use an intro file, you should check your intro file's encoding. If the encoding does not match your source encoding, the v1 will disconnect you. Not sure about v2.

idobi Network - http://idobi.com/
idobi Radio - http://idobiradio.com/
idobi App now available for iOS, Android and Windows Phone (http://idobi.com/app/)
idobi is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Discussions

Tags
closed, connection, failed

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump