Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Reply
Thread Tools Search this Thread Display Modes
Old 14th September 2012, 15:05   #1
Angrry
Junior Member
 
Join Date: Aug 2012
Posts: 10
Error: [DJPROTOCOLSHOUTCAST] Received password is in wrong format

Hello there , i have a problem configuring sc_trans
It is the latest sc_trans , and i don't know how i can set multiple dj's to connect to him.(at least one).
I use Sam Broadcaster (4.9.0 ), and there have no dj login , i mean , just password and stream id , i don't know how to log in with dj:djpassword in sc_trans with sam broadcaster.
And with DSP plugin in winamp , have no AAC encoder.. so , here is sc_trans and sc_serv config's , and say to me if is somethink wrong , and how i can log in with Sam broadcaster.
If I use v1, sc_trans say: [DJPROTOCOLSHOUTCAST] Received password is in wrong format.
And If I use v2 , on sam brodcaster , still connecting , and that's all.
I conected once (idk how) and it said that i am encoding , and when i was listening , it played sc_trans songs.. what to do?
Attached Files
File Type: zip settings.zip (7.0 KB, 137 views)
Angrry is offline   Reply With Quote
Old 14th September 2012, 15:17   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
the Source DSP does have an AAC encoder so i'm not sure why you're saying it doesn't (unless you didn't install it when you installed Winamp).

as for the SAM issue, my understanding is things were changed to make it easier to enter the details in the most current version (4.9.7 i believe, though i think it was added in 4.9.5 or 4.9.6).

if you cannot use it, then other than making sure you're forming things with the correct details to make a djassword formatted string, make sure you're connecting on the correct port as unfortunately sc_trans's dj port setup is somewhat counter-intuitive and it could be (at least in v2 mode) you have been entering the wrong port as to connect in v2 mode currently needs to be you enter djport2 and not djport (though i'm hoping for whenever the next sc_trans update happens to simplify the djport + djport2 setup so you just set one and then enter the same port irrespective of the protocol version i.e. like what happens when connecting to a v2 DNAS in v1 or v2 mode).


the error itself is due to no : (colon) being found in the string received from SAM which is why i think you need to first update SAM (or use the Source DSP) and see if that works for you.

-daz
DrO is offline   Reply With Quote
Old 14th September 2012, 15:23   #3
DrO
 
Join Date: Sep 2003
Posts: 27,873
ok, i've just seen the edits to your post and the first thing that jumps out from sc_trans_basic.conf is:
djlogin_1=

you've not set a name which is why sc_trans is having issues. or have you removed that?


yet looking in sc_serv.conf you've got details in there so second thing that comes to mind is you've put the settings in the wrong configuration file (which would also explain the failure).

the third thing is to make sure that you've added the DJ to the calendar.xml so that sc_trans will allow it once you've resolved the login configuration issue.

-daz
DrO is offline   Reply With Quote
Old 15th September 2012, 06:32   #4
Angrry
Junior Member
 
Join Date: Aug 2012
Posts: 10
Can you help me with the configuration which are put in wrong configuration file , and how i can edit calendar.xml to add the dj , because i don't know.

and djlogin_1= is nothing because i belived that if is empty it maybe log in whith sam broadcaster.

And about the DPS plugin for winamp , i have Winamp 5.63 and i downloaded the last version of this plugin ,and there is no AAC encoder, i make a video with this: http://youtu.be/oJ5vBdrGKU8
Angrry is offline   Reply With Quote
Old 15th September 2012, 07:17   #5
DrO
 
Join Date: Sep 2003
Posts: 27,873
i don't have the time today (shouldn't even be replying at 8am on a saturday), so all i can say is take the sc_trans options from sc_serv.conf (the block at the bottom of your file) and put them into the sc_trans config file. as for setting up calendar.xml, look at the dj_calendar.xml example which is shipped with sc_trans which shows how to do specify things. and no, setting djlogin to nothing would not aid in getting SAM to connect, rather it makes sure that sc_trans will reject _all_ DJ connections.

the main issue is you've not got sc_trans using the correct configuration options, resolving that should be enough to get you going. and hopefully someone else with the time will be able to aid you, otherwise will be monday / tueday before i can.

-daz
DrO is offline   Reply With Quote
Old 15th September 2012, 08:24   #6
Angrry
Junior Member
 
Join Date: Aug 2012
Posts: 10
Thank you for all , thanks for replay even it is saturday , thanks for all what you do , but , i'm not continue to make a radio station , i'm tierd , it's so hard , verry much and anoying settings solve an error and hug another.maybe i was close to solve it , but i'm tierd. Thanks .
Angrry is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump