Old 1st October 2000, 02:30   #1
mpasco
Guest
 
Posts: n/a
i have a very specific issue.
i cannot play audio cds from WinAmp,
UNLESS win media plyr 7 is also open.
i can play mp3s fine, with or without
windows media plyr open. i can play
mp3s from win med plyr. i can play
audio cds from win med plyr. if i
open win med plyr7, then play a an
audio cd from winamp, it plays fine,
but as soon as i close win med plyr7,
the audio goes too. winamp appears
to keep playing, and the cd drive
i am playing from continues to light
up. the only thing that changes is
the audio stops. if i reopen win
media plyr the audio comes back on.
i only have this problem with cds,
and not with mp3s. i HAVE to have
win media plyr open in order to get
audio from cds in winamp.

winamp is associated with ALL audio
formats. i am running an AMD tbird
950 and 1gig of ram so i dont think
i am underpowered. i have a sb live
platinum card which seems to be
working fine also.

any suggestions?
  Reply With Quote
Old 1st October 2000, 07:06   #2
canuckteach
Junior Member
 
Join Date: Aug 2000
Location: Orillia, ON Canada
Posts: 24
Send a message via ICQ to canuckteach
mpasco- I'm not sure what you've tried so far or how much experince you've had with multi-media.. so, I'll give a little background..

each 'media player' available for Windows has its own peculiarities.. I have 4 installed on my PC.. almost anything can happen if you have 2 open at once.. and they can all be set up to 'reclaim' any or all media types as soon as you open them.. (Options-Preferences in Winamp; Tools-options-Formats in Win Media).. it certainly looks like you have a 'clash' !

you could just use the Windows Media player to play your CD's..will you be recording from your CD's? if you want to produce win media files (*.wma's), suggest you just stick with it..

if you want to record MP3's--or if you just prefer to use Winamp (quicker, smaller, more plugins available), try this in Winamp:
1> open the menu Options-Preferences - click on the File Types tab.. you should see the 'associated extensions' box in the middle (on my PC, all are selected except WAV).. 2>underneath it, put a check in the box 'Associate with audio CD's'..
3> on the right, you can check the box that says 'Register Types on Winamp Start'..
4> close Winamp (keep Win media closed too)
5> place a CD in your drive
6> open Winamp - menu:
Options-preferences-Input-click on the in_ccda.dll in the input plugins box - close
7> menu: Play-Audio CD
this should work.. open up Disk Explorer, look at Drive D (your CD-ROM drive) - what is the 'file type' of the CD audio traks? it should be 'Winamp Media file'..

if it's still not working, tell us what did happen and what you observed in step 7.. with that, we'll be able to finish this up-- ok? (--:

anyone else? have a quicker solution? you're welcome to jump in! I'm a teacher.. why say 10 words when 100 will do? (--:




------------------
< canuckteach (-:-) >
canuckteach is offline   Reply With Quote
Old 1st October 2000, 23:57   #3
Pio2001
Senior Member
 
Join Date: Aug 2000
Location: Lyon, France
Posts: 293
Knowing the SBLive mixer, I think I know what happens : It can play only one external source at a time : Micro, CD, Line in, ect. Its the one selected in the AudioHQ/Mixer/Record control. Even if you check CD in the Play control, it won't play until its also checked in record Control.
Microsoft softs detect your external source in Record Control and switch it if need be. For example, Netmeeting, when opening, switches Record control to micro, and restores back the old setting when closing.
I think Media Player does the same : it turns on CD in the record control while open.
If I'm right, there are two solutions :
1) Close media player (and netmeeting, if open), go to AudioHQ/Mixer/Record Control and select CD. It should always play well in Winamp.
2) Get In_CD_Reader Winamp plugin, which reads CD digitally through IDE, not with audio wire, and plays it in the Wave/DirectX channel.
Its far better because sound is better, no setup or volume for CD Chanel, no wire connection problems, and, selecting Disk Writer Output Plugin, you can extract audio CDs like with any CDGrabber in burst mode. But not all cd rom drives manage to read Audio digitally very well, some older drives clic and skip.

Hope it helps

Pio2001
Pio2001 is offline   Reply With Quote
Old 2nd October 2000, 02:54   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,075
mpasco

Just a few modifications to canuckteach's post:

In step 2} also select CDA from the available list.
This will then make the CDAudio trax appear as Winamp Media Files in the CD-ROM D:\ Folder [as in step 7}]

There's no need to do step 6}
All Input plug-ins operate automatically.

Do as Pio2001 suggests, but also, open Windows Volume Control
1. Goto Options -> Properties -> Recording
2. Make sure CD is selected.
3. Click okay
4. Make sure selection is not muted & that the slider is up high enough.
5. Go back to "Properties" & reselect "Playback"
6. Repeat steps 2-4.

Windows Volume Control is normally accessible via the little yellow speaker in your systray.
If there's no icon there, goto MultiMedia Control Panel & place a checkmark next to "Show volume in taskbar".
If this doesn't work, the executable can be found at:
C:\WINDOWS\SNDVOL32.EXE

--------
DJ-Egg
DJ Egg is offline   Reply With Quote
Old 2nd October 2000, 05:06   #5
Pio2001
Senior Member
 
Join Date: Aug 2000
Location: Lyon, France
Posts: 293
Windows control volume is deleted when installing an SBlive soundcard, it is replaced by the Creative mixer "C:\Program Files\Creative\ShareDLL\AHQ\CTMXCM.EXE".
:-)

Pio2001
Pio2001 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump