Old 19th June 2006, 02:18   #1
acapdir
Junior Member
 
Join Date: Jun 2006
Posts: 6
"Can't open decoder" in W98 with v5.23

All day yesterday & today, I've searched, read and tried w/o joy. I've put wnaspi32.dll, an old one, a new one & the Nero big one, everywhere I can put it. I've clean installed several times, including removing the registration number before the uninstall so I have to reinter it. I've cleaned the windows registers between installs. I get the same results in all rip formats ["Error ripping track...."] whether I modify settings or try as is after a clean install. I've downloaded a fresh copy of the install file. And I'm getting the same results on my desktop W98 computer as well. I would certainly appreciated some advice on what do next.
Attached Files
File Type: zip requested info.zip (9.6 KB, 263 views)
acapdir is offline   Reply With Quote
Old 24th June 2006, 19:29   #2
Rocker
Hiding in plain sight (mod)
 
Join Date: Jun 2000
Location: Melbourne, Australia
Posts: 9,910
it doesn't really make sense why your using windows 98(with a machine with 1 gig of ram and 2ghz cpu)..

wnaspi32.dll will only work with windows NT/2k/xp

look here for info about an aspi driver for windows 98
http://www.nu2.nu/aspi/
Rocker is offline   Reply With Quote
Old 24th June 2006, 20:08   #3
acapdir
Junior Member
 
Join Date: Jun 2006
Posts: 6
Thank you for your response.
Running aspichk shows APIXD V4.71.2 and WINASPI32.DLL V4.71.2 are running for WINDOWS 98.
acapdir is offline   Reply With Quote
Old 25th June 2006, 00:50   #4
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
You may not have a correct install, ASPI for Win9X should show 4 files.

ASPI 4.6 is generally advised for Win9X machines. The easiest way to install is with a program called ForceASPI 1.7 http://www.afterdawn.com/software/cd...ls/frcaspi.cfm

It comes with an HTML doc that gives full instructions and suggested installation method.

UJ
ujay is offline   Reply With Quote
Old 25th June 2006, 03:20   #5
acapdir
Junior Member
 
Join Date: Jun 2006
Posts: 6
Thanks for the advice. I had read on the net the aspi 4.72 was the last to support w98 but several sites said that 4.71.2 was the last reliable. I uninstalled and cleared the .ini files for winamp's full reinstall. I followed the instructions for ForceASPI, rebooted and ran aspichk and found the four files all with the 4.6 number, installed winamp v5.24 and got the same error when I tried to rip. Don't know if it's useful but, during the wait time for help I installed versions 5.03, .07, .08e, .092, .094, .1, .111 & .21. All ripped just fine [5.1 was fastest]. v5.23 & 5.24 failed to rip. I will restore my aspi to the 4.71.2 I got from adaptec and hope for more advice. Thanks again.
acapdir is offline   Reply With Quote
Old 25th June 2006, 03:54   #6
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
The Sonic Engine is broken under Win9x in 5.23/24, so you need to uncheck "use sonic" in Winamp > Prefs > CD Ripping > Ripping tab for it to use aspi instead.
DJ Egg is offline   Reply With Quote
Old 25th June 2006, 07:44   #7
acapdir
Junior Member
 
Join Date: Jun 2006
Posts: 6
Thanks for a definitive answer. I guess I'm just out of luck as this is pretty much were I started. I still had the ASPI 4.6 installed when I got your msg so I tried it with sonic turned off. No soap. I did the clean install again after I reinstalled the ASPI 4.71.2, still the same error [in both instances I tried w/o and then with .dll file copied to the winamp directory]. I hope the sonic engine will work with w98 in some future release; until then I guess I have to run v5.1. I'm sure if Rocker thinks about it, he'll be able to think of legacy situations that dictate the OS. I cannot use my XP machines for ripping. [I still have to run w95 to serve 21 CD-ROMS.] Thanks to all of you for your help.
acapdir is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump