Old 1st March 2006, 05:48   #1
dmadman55
Junior Member
 
Join Date: Mar 2006
Location: Philippines
Posts: 2
MSVCR71.DLL Not Found

Right after I upgraded to 5.2 I started getting an error message whenever I click the menu bar on the Winamp player.

Zone Labs Integrity Desktop, PermissionDlg, and my AT&T Client are all reporting the same error message that 'iclient.exe' is unable to locate component.

"Zone Labs Integrity Desktop: iclient.exe - Unable To Locate Component; This application has failed to start because MSVCR71.dll was not found. Re-installing the application may fix the problem."

However, when I checked the DLL is present in several folders including C:\Program Files\Winamp.

I didn't have this problem with the previous Winamp version. Please advise ....Thanks
dmadman55 is offline  
Old 1st March 2006, 16:48   #2
dpayne@suffolk
Junior Member
 
Join Date: Mar 2006
Location: NY, USA
Posts: 2
me too

I have the exact same problem. Affected apps for me are:
- Check Point Integrity Flex (iclient.exe);
- taskmgr.exe

Platform is Windows XP Pro, version 2002, Service Pack 2.
dpayne@suffolk is offline  
Old 1st March 2006, 18:59   #3
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Hmm... strange.
Is there also an msvcr71.dll file in the same folder as the apps reporting the error?

eg. in C:\Windows\System32 for taskmgr.exe
and in X:\Path\to\Zone Alarm for iclient.exe

Do you have any 3rd-party Winamp plugins installed?
DJ Egg is offline  
Old 1st March 2006, 19:17   #4
kingbeowulf
Junior Member
 
Join Date: Mar 2006
Location: NM
Posts: 1
Send a message via AIM to kingbeowulf Send a message via Yahoo to kingbeowulf
MSVCR71.DLL in the wrong folder

Several apps use msvcr71.dll (ugh .NET runtime). "not found" popped up for me when trying to access the menues after upgrading to 5.2; however, it was McAfee Update that complained. Winamp still worked but I just couldn't access any menues. Turns out, by copying msvcr71.dll from

..\winamp

to

..\winamp\plugins

fixed the problem. Check the pop up error messages for where your system is looking for the .dll
kingbeowulf is offline  
Old 2nd March 2006, 01:03   #5
dmadman55
Junior Member
 
Join Date: Mar 2006
Location: Philippines
Posts: 2
In my case, msvcr71.dll is NOT present in the same folder as the applications reporting the error. However, this did not cause any problem with the previous Winamp version. Checked with a few other users and found that msvcr.dll is also not present in those folders and they are using previous versions of Winamp without problems.

Msvcr71.dll is present in the following folders in my laptop:
1. C:\Program Files\Winamp
2. C:\Program Files\Yahoo!\Messenger
3. C:\WINDOWS\system32\URTTemp
4. C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322

I've never had any problem installing previous versions of Winamp until 5.2.

Has anyone attempted to uninstall 5.2 and re-install the previous version? Wonder if the error message will remain and pop-up even when you downgrade. I'm not quite comfortable with work-arounds and temporary fixes. I'd rather wait for the next release when these kinks are ironed out.
dmadman55 is offline  
Old 4th March 2006, 18:14   #6
dpayne@suffolk
Junior Member
 
Join Date: Mar 2006
Location: NY, USA
Posts: 2
Quote:
Originally posted by DJ Egg
... Is there also an msvcr71.dll file in the same folder as the apps reporting the error?

eg. in C:\Windows\System32 for taskmgr.exe
and in X:\Path\to\Zone Alarm for iclient.exe

Do you have any 3rd-party Winamp plugins installed?
msvcr71.dll is in:
C:\Program Files\Winamp
C:\IBMTOOLS\Python22\DLLs
C:\WINDOWS\system32\URTTemp
C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322

3rd-party Plugins: Don't think so; I merely installed Winamp bundles (the full freeware bundles) from the Winamp site. I have installed a few versions; I upgraded by installing the new version without first removing the old.


Here is a directory listing of my plugins dir:

C:\Program Files\Winamp\Plugins>dir /o
Volume in drive C has no label.
Volume Serial Number is 8017-F8A8

Directory of C:\Program Files\Winamp\Plugins

02/28/2006 06:44 PM <DIR> .
02/28/2006 06:44 PM <DIR> ..
12/13/2005 10:17 AM <DIR> avs
12/13/2005 09:49 AM <DIR> DSP_SPS
12/13/2005 09:49 AM <DIR> freeform
12/13/2005 10:17 AM <DIR> Milkdrop
03/04/2006 12:29 PM <DIR> ml
12/13/2005 09:49 AM <DIR> Predixis MusicMagic
09/14/2005 02:17 PM 258,048 CDDBControlWinamp.dll
09/14/2005 02:17 PM 282,624 CDDBUIWinamp.dll
09/19/2005 12:32 PM 39,424 dsp_sps.dll
02/23/2006 02:10 PM 511,488 enc_aacplus.dll
02/23/2006 02:10 PM 10,752 enc_lame.dll
02/23/2006 02:10 PM 26,112 enc_wma.dll
02/23/2006 02:10 PM 1,738,240 gen_ff.dll
02/23/2006 02:09 PM 19,968 gen_hotkeys.dll
02/21/2006 09:57 AM 171,008 gen_jumpex.dll
02/23/2006 02:09 PM 393,216 gen_ml.dll
03/04/2006 12:29 PM 1,196 gen_ml.ini
02/23/2006 02:08 PM 15,872 gen_tray.dll
02/27/2006 11:39 AM 6,679 in_cdda.cdb
02/23/2006 02:08 PM 81,920 in_cdda.dll
02/23/2006 02:03 PM 70,656 in_dshow.dll
02/23/2006 02:07 PM 4,608 in_linein.dll
02/23/2006 02:07 PM 90,624 in_midi.dll
02/23/2006 02:07 PM 155,648 in_mod.dll
02/23/2006 02:07 PM 307,200 in_mp3.dll
02/23/2006 02:05 PM 21,504 in_mp4.dll
02/23/2006 02:05 PM 166,400 in_nsv.dll
02/23/2006 02:05 PM 236,544 in_vorbis.dll
02/23/2006 02:01 PM 9,728 in_wave.dll
02/23/2006 02:02 PM 239,104 in_wm.dll
12/29/2005 02:58 PM 462,848 lame_enc.dll
02/23/2006 02:06 PM 148,992 libmp4v2.dll
09/15/2005 12:31 PM 62,016 milkdrop.html
09/15/2005 12:31 PM 49,285 milkdrop_preset_authoring.html
02/23/2006 02:04 PM 102,912 ml_online.dll
02/23/2006 02:01 PM 91,136 ml_pmp.dll
02/23/2006 02:04 PM 169,984 ml_wire.dll
02/15/2006 05:55 PM 1,536,000 ml_xpdxs.dll
02/23/2006 02:03 PM 180,224 nsvdec_vp5.dll
02/23/2006 02:03 PM 194,048 nsvdec_vp6.dll
02/23/2006 02:01 PM 16,896 out_disk.dll
02/23/2006 02:03 PM 40,960 out_ds.dll
02/23/2006 02:10 PM 13,824 out_wave.dll
02/23/2006 02:01 PM 129,536 pmp_ipod.dll
02/23/2006 02:01 PM 13,824 pmp_njb.dll
02/23/2006 02:03 PM 101,376 pmp_p4s.dll
09/14/2005 02:17 PM 84,480 read_file.dll
09/15/2005 12:25 PM 1,029 vis_avs.dat
09/19/2005 12:32 PM 405,504 vis_avs.dll
12/05/2005 12:44 AM 430,592 vis_milk.dll
01/30/2006 02:05 PM 27,648 vis_nsfs.dll
09/14/2005 02:17 PM 49,152 vms_desktop.dll
10/26/2005 05:56 PM 115,200 wmahelp.dll
47 File(s) 9,286,029 bytes

I forgot to mention that my Winamp menu's actually work: if you ignore the pop-ups, you can still navigate the menus.

Finally, as kingbeowulf reports, copying the .dll from Winamp\ to Winamp\plugins fixes the problem instantly. I didn't need to restart Winamp.
dpayne@suffolk is offline  
Old 4th March 2006, 20:43   #7
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Strange. Probably just making sure there's a copy of msvcr71.dll in the system32 root dir will fix everything, because that's the place where all programs look for it (if it can't be found in the same folder as the .exe calling it).

Other than that, I'm not sure how/why copying it to the Winamp\Plugins folder fixes it, or what plugin is looking for it there. Most strange indeed.
DJ Egg is offline  
Old 5th March 2006, 10:46   #8
dronkert
Guest
 
Posts: n/a
Same problem here; asus a7v600x, athlonxp 2500, audigy 2zs, no creative software installed except drivers, xp pro sp2 all updates, dx90c, winamp52 full, no library or video support installed.
I run Task Manager minimized in systray on startup and it complains "msvcr71.dll not found" whenever I access winamp menus (that work nevertheless). No problem when taskmanager is not running (either minimized or normally).
Indeed, moving msvcr71.dll from winamp to plugins solves the problem. I wonder whether the moving out of winamp or into plugins does it.
 
Old 5th March 2006, 11:15   #9
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Well, I can't reproduce the problem, even after disabling c:\windows\system32\msvcr71.dll

Comparing my list of installed default plugins to dpayne@suffolk's list...

The only files I don't have in the Winamp\Plugins folder from that list are:

ml_xpdxs.dll (I always uncheck Predixis MusicMagic plugin in the installer options)

pmp_ipod.dll (I don't have an ipod, so no use for this file)

pmp_p4s.dll (I don't have any PlaysForSure devices, my Creative Zen Micro uses ml_pmp and pmp_njb.dll, so no need for the other two pmp_*.dll's)

I'm not sure, but it's possible that maybe one of those 3 files are looking for msvcr71.dll in the Winamp\Plugins folder.

If someone could confirm whether the problem still occurs after disabling those 3 files, then this will either prove or negate my theory.

eg. move msvcr71.dll, ml_xpdxs.dll, pmp_ipod.dll and pmp_p4s.dll out of the Winamp\Plugins folder to some backup folder somewhere else.

Reopen Winamp, and confirm whether the problem still occurs.

If it does, then we're back to square one.

If it doesn't, then close Winamp, put one of the files back in, reopen Winamp, etc etc.
I suggest doing them in this order:
1) ml_xpdxs.dll
2) pmp_ipod.dll
3) pmp_p4s.dll

Let us know the results, and we'll take things from there.
DJ Egg is offline  
Old 6th March 2006, 19:03   #10
ionreflex
Junior Member
 
Join Date: Jan 2003
Posts: 1
Send a message via Yahoo to ionreflex
I just reinstalled my laptop - new HD - so i didn't have WINAMP installed before... downloaded latest version and BOOM, "MSVCR71.DLL Not Found" popuped! Then i installed my preferred skin - MMD3 - and it solve the problem! Menu "engine" not the same ? i don't know... i'll leave that to the expert, i'm just the net-ops around here


__________
ion][reflex
[reflexion]
ionreflex is offline  
Old 11th March 2006, 00:34   #11
Mythica
Junior Member
 
Join Date: Mar 2006
Posts: 1
Send a message via Yahoo to Mythica
msvcr71.dll

I think the problems we are having has to do w/ the firewalls. I get my error msg from zone alarm and i saw a couple others say the same. I tried copying that dll to the pluggins folder and sure enough, the problem was solved. No clue why, but the older versions didn't do it, just this new one. So you might start with checking to do w/ the firewall software and where they are looking for something?
Hope that helps,
Mythica
Attached Images
File Type: gif winamp.gif (72.8 KB, 977 views)
Mythica is offline  
Old 11th March 2006, 01:00   #12
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
We still can't reproduce the problem.

I'd rather see a list of all files in the Plugins dir actually
[edit: oh, we already have, in one of the above posts, heh].

I'm using Zone Alarm, and zlclient.exe is running fine with no msvcr71.dll in the Winamp\Plugins folder (using Winamp 5.21).

The only files I don't have from the default installation are:
ml_xpdxs.dll (I always uncheck Predixis MusicMagic in the installer options)
pmp_p4s.dll (I don't have any PlaysForSure Devices, so no need for this plugin)
pmp_ipod.dll (no iPod, no need for this plugin)

It's unlikely, but all I can think of is that maybe one of those files are looking for msvcr71 in the wrong place? The recommended global location for msvcr71.dll is the %system% dir (eg. C:\Windows\System32), where any programs which call/require it can find it straight away.

Can someone please confirm if you still get the error message after disabling those 3 files, and if not, then which of the 3 files is the guilty party?
DJ Egg is offline  
Old 11th March 2006, 10:58   #13
ulillillia
Senior Member
 
ulillillia's Avatar
 
Join Date: Feb 2002
Location: Minot, ND, USA
Posts: 381
I, too, have Zonealarm (free edition, not the paid edition), along with 3 other firewalls (Norton Internet Security, Windows' firewall, and the one from my router), and even with this, I haven't had a single problem. The Winamp plug-ins directory ("C:\Program files\Winamp\Plugins") doesn't have the file, but the Winamp root directory ("C:\Program files\Winamp") does have it but the Windows\system32 directory does. Check to make sure the file is in the Winamp root directory. This is with Winamp 5.2 on Windows XP Pro.

void BlueWater() {water.color=blue; while(GameRunning) {if (fox.pos == InBlueWater) {fox.air--; FoxDrown(fox.air);} else {fox.air=1800; fox.flags = WantsToGetWet; } WaitFrames(1); }} // My top favorite thing in 2D Sonic (as C)
ulillillia is offline  
Old 22nd March 2006, 14:24   #14
Cubed-Matrix
Junior Member
 
Join Date: Mar 2006
Posts: 1
MSVCR71.DLL Fix!!!

The error message getting when tryin to access the Winamp menu is cuz of dat dll missing.,rite!!
Fix:- The insertion of MSVCR71.DLL in Winamp/Plugins folder will resolve tha issue
Cubed-Matrix is offline  
Old 1st April 2006, 22:28   #15
Ares1630
Junior Member
 
Join Date: Apr 2006
Posts: 1
Same Error, glad im not alone

I just wanted to add that i was very reluctant to upgrade, as i am with most programs, but after months of waiting and waiting, i upgraded from 5.0 to the new 5.2 and it was a total mess.

I immediately got the msvcr71.dll error once i tried to access any menu item on the MODERN SKIN. I am running win2000 pro, with no firewalls at all on this particular machine.

I COPIED the msvcr71.dll file present in the winamp program folder and pasted it in the plugin folder (like it wants) and its working fine now.

Nullsoft.. you've got some bugs to work out.
Ares1630 is offline  
Old 2nd April 2006, 01:39   #16
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Quote:
Originally posted by DJ Egg
We still can't reproduce the problem.

I'd rather see a list of all files in the Plugins dir actually
[edit: oh, we already have, in one of the above posts, heh].

I'm using Zone Alarm, and zlclient.exe is running fine with no msvcr71.dll in the Winamp\Plugins folder (using Winamp 5.21).

The only files I don't have from the default installation are:
ml_xpdxs.dll (I always uncheck Predixis MusicMagic in the installer options)
pmp_p4s.dll (I don't have any PlaysForSure Devices, so no need for this plugin)
pmp_ipod.dll (no iPod, no need for this plugin)

It's unlikely, but all I can think of is that maybe one of those files are looking for msvcr71 in the wrong place? The recommended global location for msvcr71.dll is the %system% dir (eg. C:\Windows\System32), where any programs which call/require it can find it straight away.

Can someone please confirm if you still get the error message after disabling those 3 files, and if not, then which of the 3 files is the guilty party?
DJ Egg is offline  
Old 5th April 2006, 21:56   #17
Captain Morgasm
Junior Member
 
Join Date: Apr 2006
Posts: 1
I dont know what causes this, I do know how to fix it..

Go to Run, type sfc /scannow and run that

you will need your XP CD-rom. It's something to do with windows protected files... Mine does it when I install 5.2 pro.
Captain Morgasm is offline  
Old 16th May 2006, 04:09   #18
cheetah666
Junior Member
 
Join Date: May 2006
Posts: 2
MSVCR71.DLL Not Found

I have XP - SP2 with all recent updates.
Starting with a spanking new clean install -
I have been tracking and refining installation process closely.

The system is an Nforce2 motherboard
MY C: drive is a SCSI drive runing off a Adaptec 2490 (Ithink) Most all else is stock/standard.

I have installed:
Spybot
McAfee enterprise 8
Norton Ghost 9.0 (which requires MS .NET (1.1)
Nero 6
Office XP

I have several services turned off as reccomened by the CIS
guidlines for Windows XP. I am using classic desktop and I have system restore turned off.

During installing Winamp I get a rollback to mediaplayer 9 warning. I have received the same results choosing both options here.
After installation of winamp it will start and run OK, except that everytime I click on the menu bar (to click Options for exampel) it spits out an error box:

The error Window title is: "McAfee AutoUpdate: UpdaterUI.exe - unable to locate component" The error message is: "The application has failed to start because MSVCR71.DLL was not found. Re-installing the application may fix the problem"

Well reinstalling the program had the same results as well.
Another unfortuneate result is that Norton Ghost fails to auto start and claims the service failed to start.

Is it possible that MS altered something in the new updates that made installing Winamp cause .NET to break in some way?

I can note that a few other people reporting this problem had .NET installed as well

I have been a loyal winamp promoter and have used as a default install due to its great featues and ease of use.
Thanks to Ghost I was ablet to start out clean and try re-installing this a few times. If Winamp can't fix this myself and others will start to investigate alternatives.

Please let me know if there is a fix for this comming soon... asking people to copy system files is easy for me but unacceptable to ask for the people I install this for.
My mother would not go to the forums to look for a fix, she would just use media player.

Hope this provides some info - I am wiling to provide more data if it will help in result in a fix.

Thanks in advance to any who can shed some light on this.
cheetah666 is offline  
Old 16th May 2006, 04:30   #19
cheetah666
Junior Member
 
Join Date: May 2006
Posts: 2
update

Change of services fixed the problem with ghost - so please disregard that portion of my previous post. Still would like to see new version that doesnt't do this to so many programs.
Thanks again
cheetah666 is offline  
Old 1st November 2006, 21:10   #20
ThRaShErUk2
Junior Member
 
Join Date: Nov 2006
Posts: 1
Have you tried downloading MSVCR71.DLL from Download a DLL ?
ThRaShErUk2 is offline  
Closed Thread
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump