Old 21st January 2016, 17:25   #1
web_wvum
Junior Member
 
Join Date: Jan 2016
Posts: 3
Shoutcast + NiceCast: Bad Password

I'm trying to set up a Shoutcast server to broadcast using Nicecast. The website I manage used an old version of Shoutcast to do just that, but we're moving hosting services and I've made a new website so I figured I'd download the newest version of the software. Shoutcast starts up fine, but when I try to connect using Nicecast, I get the following error message:
code:
SHOUTcast 1 source connection denied. Bad password: adminpass

I also am suspicious of these warnings, which I get when I start up Shoutcast. I assumed they would go away after I changed the admin password, but they have remained:
code:
2016-01-21 10:11:24 WARN **
2016-01-21 10:11:24 WARN [CONFIG] A dedicated `adminpassword' should be specified in the configuration.
2016-01-21 10:11:24 WARN [CONFIG] Legacy handling has been enabled to map `adminpassword' to `password'.
2016-01-21 10:11:24 WARN [CONFIG] This is not deemed safe and `adminpassword' should be directly set.
2016-01-21 10:11:24 WARN **


Given that I have specified a dedicated admin password in the config file, I don't see why I'm getting a warning. But more to the point, does anyone know why this might be happening? I've tried using both the Shoutcast password and admin password as my password in Nicecast but to no avail.
web_wvum is offline   Reply With Quote
Old 21st January 2016, 17:42   #2
djSpinnerCee
Forum King
 
djSpinnerCee's Avatar
 
Join Date: Aug 2004
Location: Hollis, Queens/The Bronx, NYC
Posts: 3,525
make sure in your config file both passwords are set and different. they cannot be the same. they also cannot be left at their defaults.
djSpinnerCee is offline   Reply With Quote
Old 22nd January 2016, 18:39   #3
web_wvum
Junior Member
 
Join Date: Jan 2016
Posts: 3
I've done that. Which password am I supposed to use in Nicecast- admin or normal? I tried both of them and neither work. And again, I'm still getting that warning which is confusing since it shouldn't really apply to me after changing the config file.
web_wvum is offline   Reply With Quote
Old 22nd January 2016, 20:00   #4
djSpinnerCee
Forum King
 
djSpinnerCee's Avatar
 
Join Date: Aug 2004
Location: Hollis, Queens/The Bronx, NYC
Posts: 3,525
your config file should have two passwords set:

adminpassword=dkecuxo
password=docodmx

password= is the password used by sources.
djSpinnerCee is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Tags
nicecast, shoutcast

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump