Old 6th July 2010, 19:49   #1
ChazZeromus
Junior Member
 
Join Date: Jul 2010
Posts: 18
Bad icy header string

This is the first time I'm setting up my server. I downloaded the shoutcast server application and the DSP plugin for winamp all on that same download page. For my shoutcast server, this is my configuration:
code:
LogFile=log.log
password=somepassword
ScreenLog=1


After it starts, I go in winamp and configure the DSP plugin for output1 to encode to mp3, then I go to the "Output" tab, making sure the port is 8000, the password matching the config file's, and selecting the approprate encoder. After pressing connect, I get this in my log:
code:


2010-07-06 15:47:05 I msg:<***> Logger startup
2010-07-06 15:47:05 I msg:<***> version 0.2.0.0 build 0.0.7.0
2010-07-06 15:47:05 D msg:<***>
2010-07-06 15:47:05 I msg:[main] calculated cpu count is 2
2010-07-06 15:47:05 I msg:[main] starting 2 network threads
2010-07-06 15:47:05 I msg:[ban] Banned 0 IP's
2010-07-06 15:47:05 I msg:[rip] 0 entries in rip list
2010-07-06 15:47:05 I msg:[microServer]Listening for connection on port 8001
2010-07-06 15:47:05 I msg:[microServer]Listening for connection on port 8000
2010-07-06 15:47:11 I msg:[src 127.0.0.1:4219 sid=1] Shoutcast source connection.
2010-07-06 15:47:11 E msg:[src 127.0.0.1:4219 sid=1] [src 127.0.0.1:4219 sid=1] connection rejected. Bad icy header string [icy-genre:]
2010-07-06 15:47:11 E msg:[src 127.0.0.1:4219 sid=1] connection rejected. Bad icy header string [icy-genre:]


I've googled connection rejected. Bad icy header string but found nothing pertaining to the shoutcast server.
I wish I knew what the problem was. Any help is appreciated!
ChazZeromus is offline   Reply With Quote
Old 6th July 2010, 20:35   #2
dotme
Moderator
 
dotme's Avatar
 
Join Date: Feb 2005
Location: USA
Posts: 4,024
You're working with a 1.x DSP and a 2.x Shoutcast Server. The two are incompatible.

1) There is no 2.x DSP
2) You can't currently download a 1.x Shoutcast Server from shoutcast.com

It's a strange state of affairs, but you do have options...

1) Go search the Googles for Shoutcast 1.9.8 Download and see if you can find a copy somewhere

2) Go buy hosting from a stream host

3) Try to wade through the miles of config files and documentation needed to set up SC_Trans2 (beta) and DNAS 2 (Beta)
dotme is offline   Reply With Quote
Old 6th July 2010, 20:41   #3
ChazZeromus
Junior Member
 
Join Date: Jul 2010
Posts: 18
Oh geeze! One question, why in the world are the downloads grouped on that once page as if they would work in perfect harmony together? Thanks, I think I'll try to find a solution from here, your response really helped!!!!!!!!1
ChazZeromus is offline   Reply With Quote
Old 6th July 2010, 21:09   #4
dotme
Moderator
 
dotme's Avatar
 
Join Date: Feb 2005
Location: USA
Posts: 4,024
Quote:
Originally Posted by ChazZeromus View Post
Oh geeze! One question, why in the world are the downloads grouped on that once page as if they would work in perfect harmony together? Thanks, I think I'll try to find a solution from here, your response really helped!!!!!!!!1
Fair question. It's going to lead to a lot of posts like yours in the days ahead if it's not fixed. If you can find DNAS 1.9.8, you'll be in good shape. Here's a setup guide if you need one after you get the exe...

http://www.bbnlive.com/shoutcast.asp
dotme is offline   Reply With Quote
Old 6th July 2010, 21:12   #5
ChazZeromus
Junior Member
 
Join Date: Jul 2010
Posts: 18
Thanks so much! I googled the exact name and version of the DNAS server app and found it. Another question if it doesn't bother you, where in the ini file or somewhere else do I configure the name of my station? It's stuck on "Unnamed Server", if you know what I mean.
ChazZeromus is offline   Reply With Quote
Old 6th July 2010, 21:15   #6
dotme
Moderator
 
dotme's Avatar
 
Join Date: Feb 2005
Location: USA
Posts: 4,024
You can make a few changes in the config (careful though, only change Password and MaxListeners). The name of the station, Genres etc, are all set in the Winamp DSP Plugin (YP Button in the Encoder)
dotme is offline   Reply With Quote
Old 6th July 2010, 21:18   #7
ChazZeromus
Junior Member
 
Join Date: Jul 2010
Posts: 18
Ohh, thats where that is!! Thanks, I think I can solve any further problems from here. You've been a great help.
ChazZeromus is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Tags
header, icy, shoutcast

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump