Old 12th June 2008, 02:25   #1
loshman55
Junior Member
 
Join Date: Jun 2008
Posts: 7
Shoutcast / Nicecast - Progress but need help...

Ok... I've spent the better part of the past week combing this forum and getting some help from some great people. I think I'm close but have a few more questions...

Background - I'm broadcasting from an Intel iMac using the sc_serv 1.9.8 script with Nicecast / iTunes as my source. I had some password issues for a while but went back to the out of the box conf file and have been able to connect successfully (I think) Here's my latest log file:

Last login: Wed Jun 11 20:58:37 on ttys000
Dads-iMac:~ NAMEMASKED$ /Users/NAMEMASKED/Shoutcast/sc_serv /Users/NAMEMASKED/Shoutcast/sc_serv.conf\ 2
*******************************************************************************
** SHOUTcast Distributed Network Audio Server
** Copyright (C) 1998-2004 Nullsoft, Inc. All Rights Reserved.
** Use "sc_serv filename.ini" to specify an ini file.
*******************************************************************************

Event log:
<06/11/08@21:11:56> [SHOUTcast] DNAS/MacOS_X v1.9.8 (Feb 28 2007) starting up...
<06/11/08@21:11:56> [main] pid: 283
<06/11/08@21:11:56> [main] loaded config from /Users/NAMEMASKED/Shoutcast/sc_serv.conf 2
<06/11/08@21:11:56> [main] initializing (usermax:32 portbase:8000)...
<06/11/08@21:11:56> [main] No ban file found (sc_serv.ban)
<06/11/08@21:11:56> [main] No rip file found (sc_serv.rip)
<06/11/08@21:11:56> [main] opening source socket
<06/11/08@21:11:56> [main] source thread starting
<06/11/08@21:11:56> [main] opening client socket
<06/11/08@21:11:56> [source] listening for connection on port 8001
<06/11/08@21:11:56> [main] Client Stream thread [0] starting
<06/11/08@21:11:56> [main] client main thread starting
<06/11/08@21:12:24> [source] connected from 192.168.1.100
<06/11/08@21:12:24> [source] icy-name:losh radio ; icy-genre:Everything
<06/11/08@21:12:24> [source] icy-pub:0 ; icy-br:96 ; icy-url:http://71.235.148.245:8000/listen.pls
<06/11/08@21:12:24> [source] icy-irc: ; icy-icq: ; icy-aim:
<06/11/08@21:18:24> [active] 0 listeners (0 unique)

I opened up the stream URL in on my wife's mac book in iTunes and heard everything loud and clear.

All I really want to be able to do with this is to broadcast some periodic shows of course with a link off of my web site that people can just click on so the stream will open in their default player. Being new to broadcasting and Mac OSX in general, I've learned that Shoutcast is the best way to do that efficiently.

Now for a couple of questions...

Everything seems to be working but I'm not showing up in the Shoutcast directory when I search for my name, "losh radio" Any idea from the log why this might be?

Secondly, based on the log, am I using the shoutcast server at all or am I just broadcasting off my Mac to the net in general?

Edit - The link to my stream is working now and automatically loading iTunes when I access it from another point.

As always, the help is greatly appreciated!!

Thank you!

Losh
loshman55 is offline   Reply With Quote
Old 12th June 2008, 02:38   #2
Thebig429
Senior Member
 
Thebig429's Avatar
 
Join Date: Apr 2006
Location: Right here!
Posts: 358
Make sure you check off public to get listed

Cadillac Radio
Classic rock from the 60s to the 90s


listen here

Talk Webcasting .com - The Webcaster's Second Home
Thebig429 is offline   Reply With Quote
Old 12th June 2008, 02:41   #3
loshman55
Junior Member
 
Join Date: Jun 2008
Posts: 7
"Check off public" where? I have "PublicServer=default" in my conf file.
loshman55 is offline   Reply With Quote
Old 12th June 2008, 03:04   #4
Thebig429
Senior Member
 
Thebig429's Avatar
 
Join Date: Apr 2006
Location: Right here!
Posts: 358
I never used Nicecast, but in an educated guess would be DNAS

Cadillac Radio
Classic rock from the 60s to the 90s


listen here

Talk Webcasting .com - The Webcaster's Second Home
Thebig429 is offline   Reply With Quote
Old 12th June 2008, 06:04   #5
WINGZERO619
Junior Member
 
Join Date: May 2008
Posts: 10
"PublicServer=Always" Try that to see if it will put you on the servers.
WINGZERO619 is offline   Reply With Quote
Old 12th June 2008, 11:22   #6
loshman55
Junior Member
 
Join Date: Jun 2008
Posts: 7
JACKPOT! I'm in and I'm on!! Many thanks Wingzero619 and others for all your help!!!
loshman55 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump