Old 8th January 2003, 18:09   #1
ginormous
Junior Member
 
Join Date: Jan 2003
Posts: 1
Can't play shoutcast streams (.pls) in Winamp 2.81

When I click on a "Tune In" button Shoutcast.com, or the radio streams at Winamp.com, I get a message pop - up saying "Access to the specified device, file or path is denied". What the hell? I'm running Windows 2000 pro.

Thanks for any help you guys can give me.
ginormous is offline   Reply With Quote
Old 9th January 2003, 02:22   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,076
Hmm . . . try this:

First, make sure PLS is selected in Winamp -> Prefs (Ctrl+P) -> Filetypes.
Also, checkmark "register types on winamp start"
(you can always uncheck this option later once the problem is fixed)
Close Prefs, close Winamp, restart Winamp, close Winamp again.

Windows Folder Options -> File Types
PLS -> Advanced
Under Actions, Hi-lite "Play in Winamp" -> Edit
App used command line should be:
"C:\PROGRAM FILES\WINAMP\WINAMP.EXE" "%1"
(all 4 quotation marks included, and naturally if you installed Winamp to somewhere other than the default dir, then this will need editing accordingly)
Click "Okay"
Back in original "Advanced" box for PLS,
hi-lite "Play in Winamp"
Click "Set Default"

Let me know if this works.
DJ Egg is offline   Reply With Quote
Old 17th January 2003, 20:04   #3
Marlboro Man
Junior Member
 
Join Date: Jan 2003
Posts: 4
How does one add a file type to associate with Winamp?

Currently running Win2k Pro. Winamp 2.81

Desire to listen to streaming media in *.asf format which returns:
[error syching to mpeg] <location> msg when trying to play. I certainly do NOT wish to play their music thru Micro$oft's browser.
Marlboro Man is offline   Reply With Quote
Old 18th January 2003, 02:32   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,076
Give us some sample url's
Save the small .asx playlist to disk, open it in Notepad, then copy & paste the actual stream url into winamp's open location box, and add /.wma to the end of the url (this tells winamp to use in_wm.dll instead of in_mp3.dll)

(naturally, you'll need the full version of WA2 installed, with WMA support)

[edit]
D'oh!
Double/cross-posted here:
http://forums.winamp.com/showthread....hreadid=121823
DJ Egg is offline   Reply With Quote
Old 18th January 2003, 14:08   #5
Marlboro Man
Junior Member
 
Join Date: Jan 2003
Posts: 4
Thanks DJ Egg. I am still learning the skills to search a BB and scan the postings to find something relevant to my needs. After an hour of summaries in the Tech2 Support you can imagine the rut I talked myself into when searching for related postings.

Specifically I am trying to run http://www.jazzradio.net The "listen links" I attempt to use are on the far right. I was getting the same response from the MP3 and Stream links as the MS audio link.

I am off to try your solution from last post.

Thanks again.
Marlboro Man is offline   Reply With Quote
Old 18th January 2003, 16:02   #6
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,076
Yeah, that's a simple one, hehe.

Paste this url into Winamp's Open/add Location Box
(Playlist -> Add Button -> url -or- just: Playlist -> Ctrl+L)

http://wma.irco163.com/jazzradio/.wma
DJ Egg is offline   Reply With Quote
Old 18th January 2003, 17:21   #7
Marlboro Man
Junior Member
 
Join Date: Jan 2003
Posts: 4
I have the full version of 2.81 (even re-installed it today to make sure).

Did your suggestion re: forcing winamp to use the correct dll. Still negative reaction. MSMediaPlayer launches autmatically and begins streaming. However, MP9 can only handle 5 minutes of the stream before it craps out.

Should I be associating *.asx and *.asf files with Winamp inside my OS?
Marlboro Man is offline   Reply With Quote
Old 18th January 2003, 17:52   #8
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,076
umm, no . . . read my previous post again (did u even see it?)
It'll only work in WA2 by copy/paste method and adding /.wma to the end of the url.

Sorry, but there's no way to make WA2 the default ASF player, at least not without a 3rd-party plugin anyway...
WA3 supports ASF straight out of the box (as long as you install video support).
DJ Egg is offline   Reply With Quote
Old 17th December 2003, 02:39   #9
PeteC
Junior Member
 
Join Date: Dec 2003
Posts: 2
DJ Egg,

I have upgraded from WINAMP 3 to WINAMP 5. I am receiving the same exact message. When I try and connect to any SHOUTCAST broadcast, I get that ACCESS TO FILE DENIED. I'm not super familiar with this but I can tell you that WINAMP 3 is the only version of the program that does not give me the error messge. I have REALONE also installed and it works fine but I would prefer WINAMP 5 or even 2, which I cannot get working.
PeteC is offline   Reply With Quote
Old 17th December 2003, 02:53   #10
PeteC
Junior Member
 
Join Date: Dec 2003
Posts: 2
I saw another post where the EXPLORER, FOLDER OPTIONS, FILE ASSOCIATIONS were mentioned. I did this and it worked.

Thank you so much.
PeteC is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump