Old 18th July 2022, 14:47   #1
WsmMLM6999
Junior Member
 
Join Date: Jun 2022
Posts: 4
Sound issues

Why does WinAmp play a file but not give any sound? I have checked everything and I am at my wits end with it.
WsmMLM6999 is offline   Reply With Quote
Old 18th July 2022, 15:20   #2
Mikey7
Senior Member
 
Mikey7's Avatar
 
Join Date: Jul 2022
Location: Sierra Vista, AZ
Posts: 143
Hi - this issue usually has nothing to do with Winamp and is more determined by how your OS is configured for sound. Before anyone can help you, you'll need to list what your OS is and your computer make and model. Have you been able to play and hear music with Winamp before? Are you getting sound from say, Youtube at the moment?
Mikey7 is offline   Reply With Quote
Old 18th July 2022, 17:03   #3
WsmMLM6999
Junior Member
 
Join Date: Jun 2022
Posts: 4
I get sound from everything but WinAmp. As a matter of fact, I was getting sound from WinAmp up to about an hour before it quit producing. (For the record, I am using Win 10)
WsmMLM6999 is offline   Reply With Quote
Old 18th July 2022, 20:56   #4
Mikey7
Senior Member
 
Mikey7's Avatar
 
Join Date: Jul 2022
Location: Sierra Vista, AZ
Posts: 143
That's unusual but at least we know your system sound isn't affected and it does seem to be Winamp related. Let's look at two really obvious but possible issues.

1. Check and make sure you don't have Winamp's volume turned down.
2. Is Winamp's mute button on?
Mikey7 is offline   Reply With Quote
Old 18th July 2022, 20:59   #5
NJK
FRISIAN (MOD)
 
NJK's Avatar
 
Join Date: Sep 2003
Location: in a house
Posts: 16,359
in addition , check the settings about output.
windows sometimes acts up and changes things that you don't want.

it should be on directsound output.
NJK is offline   Reply With Quote
Old 18th July 2022, 21:20   #6
Mikey7
Senior Member
 
Mikey7's Avatar
 
Join Date: Jul 2022
Location: Sierra Vista, AZ
Posts: 143
I believe Win 10's "Settings" app works the same as Win 11's. If Winamp's own volume control or mute button wasn't the issue, go into the Settings app and type in "sound mixer options." This is where you'll check and make sure that Winamp's sound output device is the same as the system output. Usually, any app or hardware that uses a sound device (ex. speakers, headphones, etc., will be associated with a sound device) will (or should be) listed here.
Mikey7 is offline   Reply With Quote
Old 18th July 2022, 21:44   #7
Mikey7
Senior Member
 
Mikey7's Avatar
 
Join Date: Jul 2022
Location: Sierra Vista, AZ
Posts: 143
As NJK pointed out above, you can also check Winamp's Preferences and go to Plug-ins...Output. Double-click on "DirectSound Output" (out_ds.dll). The first item under the "Device" tab is a drop-down box. it should be set to either "Primary Sound Driver" or otherwise, to the device listed in "Sound Mixer Options" (Settings app) as the current output device.
Mikey7 is offline   Reply With Quote
Old 19th July 2022, 02:28   #8
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,860
Selecting "Primary Sound Driver" never works for me. I have to select the same device that is selected in Windows sound control panel.

Winamp v5.9.0.9999 - Quinto Black CT v3.6 skin
Windows 11 Home 64-bit v22H2 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 19th July 2022, 02:46   #9
Mikey7
Senior Member
 
Mikey7's Avatar
 
Join Date: Jul 2022
Location: Sierra Vista, AZ
Posts: 143
Right now, in Windows 11, I'm able to choose "Primary Sound Driver" and it works. I seem to recall that it didn't always work - probably in some prior build of Windows 10 but I can't remember what or when. Not surprising, right?
Mikey7 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump