Old 28th July 2022, 09:45   #1
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,069
Post All Winamp 5.9 Bug Reports In This Thread

Report all Winamp 5.9 bugs in this thread.


Provide the Following Information with every Report,
and with every CONFIRMATION of someone else's report:


- Winamp 5.9 (5.90.0.9999) - clean install
- Active Winamp Language Pack (if any)
- System Specs (Model, CPU, RAM)
- Windows OS, incl. Service Pack & Locale
- Video card + drivers version
- Sound card/chip + drivers version
- Detailed step-by-step method of reproduction (eg. numbered list)


Plus confirmation that the bug exists with NO 3rd-party plugins installed,
and whether it occurs with the Bento, Winamp Modern and/or Winamp Classic skin(s)
(3rd-party plugins & skins are NOT supported here).

If using a Winamp Language Pack, please also confirm whether the problem also occurs when using the default built-in English translation.

If applicable, send us Error Logs and/or FULL Error Messages.


The more information you provide US, the faster we can or will help you, e.g.
- The format/extension of the filetypes you are loading/playing
- A link to a zipped sample of a particular problem file*
- A Winamp Info Tool Report attached in a zip file.


*Sample files:
If zipped files are too large to attach to your post, please upload them to e.g.
zippyshare.com, wikisend.com, ge.tt, mediafire.com, sendspace.com, or dropbox.com (or your own webspace).


Also, be sure to read other stickys first, especially:
The "Known Issues" section of the "5.9 Released" thread
Known Winamp 5 Bugs
Fixed Winamp 5 Bugs
How to write a useful bug report



Do NOT post requests for Technical Support in the Bug Reports forum.

This thread is not a discussion thread. Post the reproducible bug and that is it!

Incomplete reports/useless posts will be moved or deleted (you have been warned).
DJ Egg is offline   Reply With Quote
Old 28th July 2022, 09:48   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,069
Here is a LIST of the Official Plugins and their Versions that shipped with 5.9

Input:
Nullsoft AVI Demuxer v0.77 [in_avi.dll]
Nullsoft CD Plug-in v4.6 [in_cdda.dll]
Nullsoft DirectShow Decoder v1.14 [in_dshow.dll]
Nullsoft FLAC Decoder v3.2 [in_flac.dll]
Nullsoft Flash Control Playback v1.15 [in_swf.dll]
Nullsoft Flash Video Decoder v1.46 (h) [in_flv.dll]
Nullsoft LineIn plugin v3.16 [in_linein.dll]
Nullsoft Matroska Demuxer v0.85 [in_mkv.dll]
Nullsoft MIDI Player v3.57 [in_midi.dll]
Nullsoft Module Decoder v3.03 [in_mod.dll]
Nullsoft MP4 Demuxer v2.67 [in_mp4.dll]
Nullsoft MPEG Audio Decoder v4.5 [in_mp3.dll]
Nullsoft NSV Decoder v1.76 [in_nsv.dll]
Nullsoft Vorbis Decoder v1.79 [in_vorbis.dll]
Nullsoft Waveform Decoder v3.26 [in_wave.dll]
Nullsoft Windows Media Decoder v3.9 [in_wm.dll]

Output:
DirectSound Output v2.81 [out_ds.dll]
Disk Writer v2.18 [out_disk.dll]
WASAPI Output v0.2 [out_wasapi.dll]
WaveOut Output v2.22 [out_wave.dll]

Visualization:
Advanced Visualization Studio v2.92 [vis_avs.dll]
MilkDrop v2.25d [vis_milk2.dll]

DSP/FX:
Nullsoft Signal Processing Studio DSP v1.0b [dsp_sps.dll]

CD Ripping Encoders:
FLAC Encoder 2.45 (libFLAC 1.3.4) [enc_flac.dll]
MP3 Encoder v1.38 [enc_lame.dll] (with lame_enc.dll 3.100.1)
Ogg Vorbis Encoder v1.57 (aoTuV b6.03)
WAV Encoder v1.02a [enc_wav.dll]
WMA Encoder v1.23 [enc_wma.dll]

General Purpose:
Nullsoft Error Feedback v1.15 [gen_crasher.dll]
Nullsoft Global Hotkeys v1.97 [gen_hotkeys.dll]
Nullsoft Media Library v3.77 [gen_ml.dll]
Nullsoft Modern Skins Support v1.50 [gen_ff.dll]
Nullsoft Notification Area Control v2.48.1 [gen_tray.dll]

Media Library:
Nullsoft Bookmarks v1.27 [ml_bookmarks.dll]
Nullsoft Database Import/Export v2.64 [ml_impex.dll]
Nullsoft Device Manager v1.34 [ml_devices.dll]
Nullsoft Downloads v1.32 [ml_downloads.dll]
Nullsoft Format Converter v2.78 [ml_transcode.dll]
Nullsoft History v2.03 [ml_history.dll]
Nullsoft Library v3.34 [ml_local.dll]
Nullsoft Online Services v2.02 [ml_online.dll]
Nullsoft Playlists v1.76 [ml_playlists.dll]
Nullsoft Podcasts v1.60 [ml_wire.dll]
Nullsoft Portable Music Player Support v2.24 [ml_pmp.dll]
Nullsoft Replay Gain Analyzer v1.29 [ml_rg.dll]
Nullsoft Rip & Burn v2.00 [ml_disc.dll]

Portables:
Nullsoft Android Device Plug-in v1.71 [pmp_android.dll]
Nullsoft Creative NJB Plug-in v0.57 [pmp_njb.dll]
Nullsoft iPod Plug-in v0.89 [pmp_ipod.dll]
Nullsoft Microsoft PlaysForSure Plug-in v0.99.1 [pmp_p4s.dll]
Nullsoft USB Device Plug-in v1.62 [pmp_usb.dll]
Nullsoft Wi-Fi Device Plug-in v1.55 [pmp_wifi.dll]
Nullsoft ActiveSync Plug-in v0.20 [pmp_activesync.dll]


Do NOT report ANY 3rd-party plugin bugs/issues here.
DJ Egg is offline   Reply With Quote
Old 29th July 2022, 03:22   #3
genecooper_1
Junior Member
 
Join Date: Jul 2022
Posts: 1
The EQ presets are in Chinese

The EQ presets are in Chinese with 5.9 RC1.
genecooper_1 is offline   Reply With Quote
Old 29th July 2022, 08:31   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,069
Quote:
Originally Posted by genecooper_1 View Post
The EQ presets are in Chinese with 5.9 RC1.

Good catch. Thanks!

Will be fixed for the next public release.


[EDIT]

Fixed for Winamp 5.9 RC4 and newer.
DJ Egg is offline   Reply With Quote
Old 29th July 2022, 16:09   #5
highonsnow
Junior Member
 
Join Date: Jul 2022
Posts: 6
Reproduction: Audio collection on shuffle (looking for playback bugs). It always appears to complete a song and then I discover it has crashed. Unaware of specific files/formats causing the crashes. Three exe crashes so far (resulting in multiple Windows Event entries). This is the most recent data I have.

Skin: Bento

OS Name Microsoft Windows 10 Pro
Version 10.0.19044 Build 19044
Other OS Description Not Available
OS Manufacturer Microsoft Corporation
System Manufacturer System manufacturer
System Model System Product Name
System Type x64-based PC
System SKU SKU
Processor AMD Ryzen 9 5900X 12-Core Processor, 3701 Mhz, 12 Core(s), 24 Logical Processor(s)
BIOS Version/Date American Megatrends Inc. 4002, 15/06/2021
SMBIOS Version 3.3
Embedded Controller Version 255.255
BIOS Mode UEFI
BaseBoard Manufacturer ASUSTeK COMPUTER INC.
BaseBoard Product ROG STRIX X570-E GAMING
BaseBoard Version Rev X.0x
Platform Role Desktop
Secure Boot State Off
PCR7 Configuration Elevation Required to View
Windows Directory C:\Windows
System Directory C:\Windows\system32
Boot Device \Device\HarddiskVolume3
Locale United Kingdom
Hardware Abstraction Layer Version = "10.0.19041.1806"
Username APTRIVA-RACK1\higho
Time Zone GMT Summer Time
Installed Physical Memory (RAM) 64.0 GB
Total Physical Memory 63.9 GB
Available Physical Memory 41.6 GB
Total Virtual Memory 73.4 GB
Available Virtual Memory 41.3 GB
Page File Space 9.50 GB
Page File C:\pagefile.sys
Kernel DMA Protection Off
Virtualisation-based security Running
Virtualisation-based security required security properties
Virtualisation-based security available security properties Base Virtualisation Support, DMA Protection, UEFI Code Readonly, Mode Based Execution Control
Virtualisation-based security services configured
Virtualisation-based security services running
Device Encryption Support Elevation Required to View
A hypervisor has been detected. Features required for Hyper-V will not be displayed.

Name AMD High Definition Audio Device
Manufacturer Advanced Micro Devices
Status OK
PNP Device ID HDAUDIO\FUNC_01&VEN_1002&DEV_AA01&SUBSYS_00AA0100&REV_1007\7&2A902989&0&0001
Driver C:\WINDOWS\SYSTEM32\DRIVERS\ATIHDWT6.SYS (10.0.1.23, 240.41 KB (246,176 bytes), 13/10/2021 11:24)

Name AMD Streaming Audio Device
Manufacturer AMD
Status OK
PNP Device ID ROOT\AMDSAFD&FUN_01&REV_01\0000
Driver C:\WINDOWS\SYSTEM32\DRIVERSTORE\FILEREPOSITORY\AMDSAFD.INF_AMD64_EDD3335A4253BF6D\AMDSAFD.SYS (1.0.0.6, 106.95 KB (109,520 bytes), 03/12/2021 17:16)

Name High Definition Audio Device
Manufacturer Microsoft
Status OK
PNP Device ID HDAUDIO\FUNC_01&VEN_10EC&DEV_1168&SUBSYS_104387C5&REV_1001\5&590AA42&0&0001
Driver C:\WINDOWS\SYSTEM32\DRIVERS\HDAUDIO.SYS (10.0.19041.264, 420.00 KB (430,080 bytes), 19/11/2020 02:49)

Name AMD Radeon RX 5700
PNP Device ID PCI\VEN_1002&DEV_731F&SUBSYS_04E41043&REV_C4\6&256B734F&0&00000019
Adapter Type AMD Radeon Graphics Processor (0x731F), Advanced Micro Devices, Inc. compatible
Adapter Description AMD Radeon RX 5700
Adapter RAM (1,048,576) bytes
Installed Drivers C:\Windows\System32\DriverStore\FileRepository\u0380677.inf_amd64_dba19d925381d5ad\B380472\aticfx64.dll,C:\Windows\System32\DriverStore\FileRepository\u0380677.inf_amd64_dba19d925381d5ad\B380472\aticfx64.dll,C:\Windows\System32\DriverStore\FileReposi tory\u0380677.inf_amd64_dba19d925381d5ad\B380472\aticfx64.dll,C:\Windows\System32\DriverStore\FileRepository\u0380677.inf_amd64_dba19d925381d5ad\B380472\amdxc64.dll
Driver Version 30.0.21023.1015
INF File oem4.inf (ati2mtag_Navi10 section)
Colour Planes Not Available
Colour Table Entries 4294967296
Resolution 3440 x 1440 x 50 hertz
Bits/Pixel 32
Memory Address 0xD0000000-0xE01FFFFF
Memory Address 0xE0000000-0xE01FFFFF
I/O Port 0x0000FF00-0x0000FFFF
Memory Address 0xFCD00000-0xFCDFFFFF
IRQ Channel IRQ 4294967232
Driver C:\WINDOWS\SYSTEM32\DRIVERSTORE\FILEREPOSITORY\U0380677.INF_AMD64_DBA19D925381D5AD\B380472\AMDKMDAG.SYS (30.0.21023.1015, 87.75 MB (92,008,832 bytes), 01/07/2022 14:31)

Windows Error Reporting:

Quote:
1837147199639733586
5
FaultTolerantHeap
Not available
0
winamp.exe
5.9.0.9999
62E16F6C
ffffbaad

\\?\C:\Windows\SERVIC~1\LOCALS~1\AppData\Local\Temp\FTH7205.tmp\fthempty.txt \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER7225.tmp.WERInternalMetadata.xml \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER7236.tmp.xml \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER7234.tmp.csv \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER72B2.tmp.txt

0
159752e3-6dbf-492b-8b7d-ca0cd02c71f2
268435456
f04dbcff82135e87897edba4faa14552
0
Windows Error Reporting:

Quote:
1709081176520418562
1
APPCRASH
Not available
0
winamp.exe
5.9.0.9999
62e16f6c
StackHash_817e
10.0.19041.1806
39cccd9d
c0000374
PCH_66_FROM_ntdll+0x00072F8C


\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER7282.tmp.dmp \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER73CB.tmp.WERInternalMetadata.xml \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER73DC.tmp.xml \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER73DC.tmp.csv \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER7469.tmp.txt
\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_winamp.exe_2c5e2d79c6f47061436bba178b972ffdc8955367_ddc8c6d7_5beac8a9-ef3d-4f50-8f32-8f61403b8084

0
94217761-f911-4435-aa66-46437a61ad89
268435456
8c3dea1a6fd49a0fc7b7e04662ce6502
0
Windows Error Reporting:

Quote:
winamp.exe
5.9.0.9999
62e16f6c
ntdll.dll
10.0.19041.1806
39cccd9d
c0000374
000e6fe3
aaf0
01d8a35373ea3046
H:\Program Files (x86)\Winamp\winamp.exe
C:\Windows\SYSTEM32\ntdll.dll
94217761-f911-4435-aa66-46437a61ad89
Windows Error Reporting:

Quote:
1709081176520418562
1
APPCRASH
Not available
0
winamp.exe
5.9.0.9999
62e16f6c
StackHash_817e
10.0.19041.1806
39cccd9d
c0000374
PCH_66_FROM_ntdll+0x00072F8C


\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER3E12.tmp.dmp \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER3F8A.tmp.WERInternalMetadata.xml \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER3F9B.tmp.xml \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER3F99.tmp.csv \\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER4017.tmp.txt
\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_winamp.exe_2c5e2d79c6f47061436bba178b972ffdc8955367_ddc8c6d7_bffbd999-d862-4c18-a895-f0e09217a7f5

0
86e20173-6648-4c85-8597-fc01d39c25b7
268435456
8c3dea1a6fd49a0fc7b7e04662ce6502
0
highonsnow is offline   Reply With Quote
Old 29th July 2022, 16:11   #6
highonsnow
Junior Member
 
Join Date: Jul 2022
Posts: 6
PS, regarding last post, there are NO third party plugins installed for Winamp, it's a stock install with only music library imported.
highonsnow is offline   Reply With Quote
Old 30th July 2022, 01:01   #7
toss
Junior Member
 
Join Date: Jul 2022
Posts: 1
1. Have a fresh system without any prior use of Winamp (e.g. a VM).
2. Install Winamp as usual, for the first time.
3. Attempt to launch Winamp (either from installer or from desktop shortcuts).
4. Observe Winamp crash while loading initial setup, instead loading the Error Reporter.

System specs:
Motherboard: "Virtual Machine" (Gigabyte X99-SLI-CF)
CPU: Intel Core i7-5820K
RAM: 4 GB
OS: Windows 10 Enterprise v1903
Sound card: "Remote Audio" (Asus Xonar DSX)
Video card: Geforce GTX 970
DirectX 12
VM: Windows Sandbox

Windows Error Reporting seems to show nothing (am I not looking hard enough in Event Viewer?)
toss is offline   Reply With Quote
Old 3rd August 2022, 08:17   #8
Merowinger
Junior Member
 
Join Date: Sep 2018
Posts: 20
@highonsnow - I have a similar problem. Winamp crashes after song is finished.
Merowinger is offline   Reply With Quote
Old 4th August 2022, 05:10   #9
Marz
Junior Member
 
Join Date: Aug 2022
Posts: 2
In response to the Modern Plugin Support not loading... it worked in safe mode but not full mode. Went one by one for plugins and determined which plugins are causing issues.

in_avi.dll
in_cdda.dll
in_dshow.dll
in_flac.dll
in_linein.dll
in_midi.dll
in_mkv.dll
in_mod.dll

If you move all of these out of the plugin directory, the modern skin support works. Obviously will be losing other functionality, but highlights some kind of conflict.

- Winamp 5.9 (5.9.0.9999) - clean install: Yes
- Active Winamp Language Pack (if any): n/a
- System Specs (Model, CPU, RAM): asus P8P67 Delux mobo, i7 2600k, 32gb ram
- Windows OS, incl. Service Pack & Locale: Win 7 SP1, English
- Video card + drivers version: GTX 1080, 411.63
- Sound card/chip + drivers version: Realtek HD Audio, 6.0.1.7541
- Detailed step-by-step method of reproduction (eg. numbered list)
Clean install of Winamp 5.9
Change to modern skin, get error that modern plugin support isn't installed, gen_ff.dll "NOT LOADED"
Move listed DLLs out of plugin folder, gen_ff.dll loads correctly


EDIT: DJ Egg

Fixed in Winamp 5.9 RC3 and newer
Marz is offline   Reply With Quote
Old 5th August 2022, 00:40   #10
eliotime3000
Junior Member
 
Join Date: Oct 2016
Posts: 23
Quote:
Originally Posted by Marz View Post
In response to the Modern Plugin Support not loading... it worked in safe mode but not full mode. Went one by one for plugins and determined which plugins are causing issues.

in_avi.dll
in_cdda.dll
in_dshow.dll
in_flac.dll
in_linein.dll
in_midi.dll
in_mkv.dll
in_mod.dll

If you move all of these out of the plugin directory, the modern skin support works. Obviously will be losing other functionality, but highlights some kind of conflict.

- Winamp 5.9 (5.9.0.9999) - clean install: Yes
- Active Winamp Language Pack (if any): n/a
- System Specs (Model, CPU, RAM): asus P8P67 Delux mobo, i7 2600k, 32gb ram
- Windows OS, incl. Service Pack & Locale: Win 7 SP1, English
- Video card + drivers version: GTX 1080, 411.63
- Sound card/chip + drivers version: Realtek HD Audio, 6.0.1.7541
- Detailed step-by-step method of reproduction (eg. numbered list)
Clean install of Winamp 5.9
Change to modern skin, get error that modern plugin support isn't installed, gen_ff.dll "NOT LOADED"
Move listed DLLs out of plugin folder, gen_ff.dll loads correctly
Wait. I realized that in my case, even with clean install, the modern skin support plugin doesn't appear in "General Purprose" plugin section.
eliotime3000 is offline   Reply With Quote
Old 7th August 2022, 15:52   #11
MRFRoST
Junior Member
 
Join Date: Feb 2012
Posts: 2
Winamp crashes if I use "Rescan Watch Folders (in background)"

1. Winamp works without problems after the initial reading of the songs (approx 39000 entries).
2. However, as soon as I use the "Rescan Watch Folders (in background)" function, Winamp crashes. If I then restart Winamp, it immediately crashes again.
3. Only when I delete the database "C:\Users\user\AppData\Roaming\Winamp\Plugins\ml\main.dat", I can start Winamp again and the database read in again via "Add Media to Library". -> Winamp works again till I use the "Rescan Watch Folders (in background)" function

My Specs:

- Winamp 5.9 (5.9.0.9999) - clean install
- No Active Winamp Language Pack
- AMD Ryzen 9 3900X 12-Core Processor, 32,0 GB
- Windows 10 Version 21H2 (Build 19044.1865) German
- NVidia GeForce RTX 2070 Version 516.59
- Soundblaster ZxR Version 6.0.102.75
MRFRoST is offline   Reply With Quote
Old 8th August 2022, 14:25   #12
Shivan
Junior Member
 
Join Date: Oct 2006
Location: Germany
Posts: 3
Send a message via ICQ to Shivan
Winamp freezes when starting on screen which is currently not connected.

Reproduction:
Status: I have screen 1, 2 and 3. All screens are extending the desktop.

Locations:
Screen 1 | Screen 3
Screen 2
1. move WinAmp to screen 3.
2. Close WinAmp after a while or after playing (it saves its position on close)
3. disconnect screen 3
4. Start WinAmp again. It appears on Screen 2 (with default skin and hanging and unable to do anything... even alt+space to "move" it back, doesn't work. Only killing via taskmanager helps to close. But it cannot be moved back anyhow. Only solution is connect screen 3 again.

Expected result: If a screen is no more available, move it to a visible area.
Even better would be behaviour like Chrome... have a look how it handles screen connect/disconnects...

Windows 11, latest updates
Winamp 5.9 999
Shivan is offline   Reply With Quote
Old 11th August 2022, 04:58   #13
TheDreadPirat
Junior Member
 
Join Date: Aug 2022
Posts: 3
When I have Winamp open on my second monitor with "Always on top" enabled, and I switch back to the game on my primary monitor, Winamp disappears. When I disabled always on top, it doesn't disappear. This also happens with any full screen app. I had MS RDP open and the same behavior happened.

This bug existed for me with 5.8 as well.

Running Windows 10 21H2.
TheDreadPirat is offline   Reply With Quote
Old 11th August 2022, 12:38   #14
Orddu
Junior Member
 
Join Date: Jul 2022
Posts: 1
Can't play Outlook attached WAVs

I have WAV files associated with Winamp in Windows.

If I double-click an Outlook attachment which is a plain WAV file, Winamp starts but the file isn't transferred into the playlist.

Previous behaviour used to be that it would wipe any existing playlist, insert the attachment and immediately play it.

I have reinstalled Winamp, and have the agent running, although it happens either way.

5.9.0 build 9999 on Win 11.
Orddu is offline   Reply With Quote
Old 15th August 2022, 13:45   #15
alimberger
Junior Member
 
Join Date: Aug 2022
Posts: 4
Allow multiple instances.

Multiple instances are allowed anyway I check or not the option.
alimberger is offline   Reply With Quote
Old 15th August 2022, 13:48   #16
alimberger
Junior Member
 
Join Date: Aug 2022
Posts: 4
5.9.0 build 9999 Win 10.
alimberger is offline   Reply With Quote
Old 15th August 2022, 14:15   #17
alimberger
Junior Member
 
Join Date: Aug 2022
Posts: 4
Oh, noticed now this happens when you run the first instance as administrator.
alimberger is offline   Reply With Quote
Old 18th August 2022, 09:51   #18
DMXOnline
Junior Member
 
Join Date: Aug 2022
Posts: 1
- Winamp 5.9 (5.9.0.9999) - tested both ways
- Active Winamp Language Pack yes, but using only english
- System Specs (Ryzen 5600X, 16gb)
- Windows OS, Windows 10 latest, Locale:Bulgaria
- Video card AMD HD7750, drivers version: Adrenalin 22.6.1 Recommended (WHQL)
- Sound card: On-board/chip:Realtek ALC S1200A + drivers version: 6.0.8971.1

- Detailed step-by-step method of reproduction (eg. numbered list):
Tryed on clean instal, not clean install, with 3rd party plugins, without them, there is missing
the jump to file menu from the previus Winamp version 5.666 (3516). What do i mean about missing menu. On the previus version there was at the bottom Search mode, queue file, move after curent jump to file and close. Also i can't make a queue list, from the play list, so i cant mark wich files to play, in what order.
DMXOnline is offline   Reply With Quote
Old 27th August 2022, 01:19   #19
Sopor
Junior Member
 
Join Date: Aug 2022
Posts: 1
I'm using MP3Gain on my mp3 files and when i was running Winamp 5.8 b3660 there was a tab called APEv2 that was showing the gain values, but in version 5.9.0 b9999 RC3/RC4 this tab is empty.

It is only the values there are missing. The gain level is working when i play mp3's, though.

Windows 10 x64 English.
Winamp is running in English and i use no 3rd party plugins.

Screenshots: 5.8 vs 5.9

____________________
Attached Thumbnails
Click image for larger version

Name:	winamp-5.8.b3660-apev2.png
Views:	56
Size:	10.4 KB
ID:	55023   Click image for larger version

Name:	winamp-5.9.0.b9999.RC4-apev2.png
Views:	49
Size:	8.5 KB
ID:	55024  
Sopor is offline   Reply With Quote
Old 27th August 2022, 07:38   #20
Sp3EdeR
Junior Member
 
Join Date: Aug 2006
Posts: 7
First startup, with Big Bento on and the Media Library tab focused, the AVS visualization is configured with the UnConeD - Speeder 4K visualization being set as active before installation.

Upon switching to the Visualization tab, the visualization was black for at least 5-10 seconds.
When right click-selecting the same visualization profile, visualization started instantly and was working fine.
After a restart of the application, the same behaviour happened again.
After another restart of the application, I can no longer reproduce the issue any more. Visualization works right after startup or tab switching, as expected.

Winamp 5.9.0.9999 RC4, update install
Machine:
OS: Windows 11, 22000.856
CPU: AMD Ryzen 5600X
GPU: nVidia RTX 3070
RAM: 32GB RAM @ 3600MHz
Sound card: Creative SoundBlasterX AE-5 Plus
Sp3EdeR is offline   Reply With Quote
Old 4th September 2022, 16:39   #21
Dodus
Junior Member
 
Join Date: May 2016
Posts: 8
Winamp Error Report

Winamp client version: 5.9.0 Build 9999
English
Intel(R) Core(TM) i5-6267U CPU @ 2.90GHz 2.80 GHz
Ram 6,00*Go
Windows 10 famille Version 21H1
Focusrite Scarlett 8i6 (3rd Gen) Versions: Firmware: 1605 Driver: 4.65.5

winamp caused an Access Violation (0xc0000005)
in module nxlite.dll at 0023:725a36cf.

edit by NJK

attachment has the rest of the post.
Attached Files
File Type: 7z logfile.7z (12.0 KB, 26 views)
Dodus is offline   Reply With Quote
Old 4th September 2022, 16:51   #22
Dodus
Junior Member
 
Join Date: May 2016
Posts: 8
Winamp Error Report

Winamp client version: 5.9.0 Build 9999
English
Big Bento
No 3rd party plugin
Intel(R) Core(TM) i5-6267U CPU @ 2.90GHz 2.80 GHz
RAM 6,00*Go
Système d’exploitation 64*bits, processeur x64
Windows 10 famille Version 21H1 Build 19043.1889

winamp caused an Access Violation (0xc0000005) in module winamp.exe at 0023:0040c500.

Report in attachment
Attached Files
File Type: zip report.zip (69.2 KB, 29 views)
Dodus is offline   Reply With Quote
Old 4th September 2022, 16:55   #23
Dodus
Junior Member
 
Join Date: May 2016
Posts: 8
Winamp Error Report

Winamp client version: 5.9.0 Build 9999
English
Big Bento
No 3rd party plugin
Intel(R) Core(TM) i5-6267U CPU @ 2.90GHz 2.80 GHz
RAM 6,00*Go
Système d’exploitation 64*bits, processeur x64
Windows 10 famille Version 21H1 Build 19043.1889

winamp caused an Access Violation (0xc0000005) in module nxlite.dll at 0023:725a36cf.

Report in attachment
Attached Files
File Type: zip report2.zip (59.3 KB, 27 views)
Dodus is offline   Reply With Quote
Old 4th September 2022, 16:58   #24
Dodus
Junior Member
 
Join Date: May 2016
Posts: 8
Winamp Error Report

Winamp client version: 5.9.0 Build 9999
English
Big Bento
No 3rd party plugin
Intel(R) Core(TM) i5-6267U CPU @ 2.90GHz 2.80 GHz
RAM 6,00*Go
Système d’exploitation 64*bits, processeur x64
Windows 10 famille Version 21H1 Build 19043.1889

winamp caused an Access Violation (0xc0000005) in module in_flac.dll at 0023:057a2a7b.

Report in attachment
Attached Files
File Type: zip report3.zip (52.1 KB, 30 views)
Dodus is offline   Reply With Quote
Old 4th September 2022, 17:21   #25
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,069
@Dodus

What is the exact step-by-step method of reproduction?

The crash report shows in_mp3.dll version = v4.4
in_mp3.dll version in Winamp 5.9 RC4 = v4.5

The crash report refers to Winamp\Shared\libalac.dll
This file was in RC1 only and was removed for RC3

Please make sure you are you using the latest version.
DJ Egg is offline   Reply With Quote
Old 4th September 2022, 17:36   #26
Dodus
Junior Member
 
Join Date: May 2016
Posts: 8
I am sorry, i'm not used with your "computer language".
I don't understand what you mean ?:
The crash report shows in_mp3.dll version = v4.4
in_mp3.dll version in Winamp 5.9 RC4 = v4.5
The crash report refers to Winamp\Shared\libalac.dll
This file was in RC1 only and was removed for RC3

I was running Winamp 5.666 Redux until I moved to 5.9.
I'm not looking at upgrade every week.

Winamp crashed especially at startup when winamp rescan the music folders.
Crashed too when analyzing files to calculate replay gain.
Email adress for error report generated by winamp 5.9 is not valid.
I downgrade to my previous 5.666 Redux!
Dodus is offline   Reply With Quote
Old 4th September 2022, 17:49   #27
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,069
We can't reproduce those crashes with Winamp 5.9 RC4
DJ Egg is offline   Reply With Quote
Old 4th September 2022, 18:21   #28
Dodus
Junior Member
 
Join Date: May 2016
Posts: 8
Quote:
Originally Posted by DJ Egg View Post
We can't reproduce those crashes with Winamp 5.9 RC4
Happy to read this news. Meanwhile I will wait awhile before joining 5.9 again.
Too much crashes make me loose too much time of music listening... maybe because I didn't know there was already a new version of the 5.9 .
It's not obvious to a newcomer.
Best regards and keep the llama in good shape !
Dodus is offline   Reply With Quote
Old 4th September 2022, 21:13   #29
NJK
FRISIAN (MOD)
 
NJK's Avatar
 
Join Date: Sep 2003
Location: in a house
Posts: 16,331
Quote:
Originally Posted by Dodus View Post
Happy to read this news. Meanwhile I will wait awhile before joining 5.9 again.
Too much crashes make me loose too much time of music listening... maybe because I didn't know there was already a new version of the 5.9 .
It's not obvious to a newcomer.
Best regards and keep the llama in good shape !

did you by any chance did an upgrade from 5.666 instead of doing a clean install?

http://forums.winamp.com/showthread.php?t=458828
NJK is offline   Reply With Quote
Old 4th September 2022, 23:28   #30
Dodus
Junior Member
 
Join Date: May 2016
Posts: 8
Quote:
Originally Posted by NJK View Post
did you by any chance did an upgrade from 5.666 instead of doing a clean install?

http://forums.winamp.com/showthread.php?t=458828
I've tried both. Upgrade from 5.666 and later a clean install of 5.9 but apparently not the latest version (RC4).
Dodus is offline   Reply With Quote
Old 12th September 2022, 09:38   #31
franpa
Member
 
Join Date: Feb 2007
Location: Australia, QLD
Posts: 60
Ignore this message.

Windows 10 x64
Realtek Audio ALC 1220
Ryzen 3700X
franpa is offline   Reply With Quote
Old 12th September 2022, 16:53   #32
r6gear@gmail.com
Junior Member
 
Join Date: Feb 2021
Posts: 6
guys, why i can't listen anymore any shoutcast https link? the problem started 2 or maybe 3 months ago.
r6gear@gmail.com is offline   Reply With Quote
Old 12th September 2022, 16:57   #33
r6gear@gmail.com
Junior Member
 
Join Date: Feb 2021
Posts: 6
LoL! i just realised that winamp forums not using https in 2022 wtf dudes!
r6gear@gmail.com is offline   Reply With Quote
Old 12th September 2022, 19:48   #34
NJK
FRISIAN (MOD)
 
NJK's Avatar
 
Join Date: Sep 2003
Location: in a house
Posts: 16,331
Quote:
Originally Posted by r6gear@gmail.com View Post
LoL! i just realised that winamp forums not using https in 2022 wtf dudes!

already been on the board a few times before http://forums.winamp.com/showthread.php?t=453660 is one of them


http://forums.winamp.com/search.php
NJK is offline   Reply With Quote
Old 21st September 2022, 06:16   #35
Alpharius
Junior Member
 
Join Date: Sep 2022
Posts: 1
External cover art preview (cover.jpg, folder.jpg, etc.) for a specific skin broken in 5.90.0.9999
Skin involved: Drone v1.1

Good day,

I tried upgrading from Winamp 5.8.0.3660 to 5.90.0.9999 and also tried a clean install. The feature, using the mentioned skin, seems to be broken in the latest version. The cover art is showing properly when I used default skins though, and I am not sure if other user-made skins were affected.

Reverted back to 5.8.0.3660 and the cover art is showing up properly. I hope skin compatibility will not be an issue with the newer builds, but we may have to face it since codes are constantly changing.
Alpharius is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump