Old 23rd April 2003, 08:25   #1
Petepan@london
Member
 
Petepan@london's Avatar
 
Join Date: Apr 2003
Location: Never Never Land
Posts: 69
Broken mms:// .wma streams

"Upgraded" back to 2.9x as it has everything I wanted including the speed, video and "J" Key ... but my fave mms:// .... /.wma radio no longer works. I see that it is in the know bugs list, but was not fixed in 2.91. Any ideas when it will be fixed or if there is a work around?


http://classic.winamp.com/components...onentId=132101
Winamp3 Default Skin for Winamp 2.9x ... As close to looking like Winamp3 without grinding your computer to a halt
Petepan@london is offline   Reply With Quote
Old 23rd April 2003, 12:56   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,072
Yes, it's in the Official Buglist.
No, I don't personally know how/when it will be fixed.

My assumption/synopsis (could be wrong, could be right):

The problem is caused by mms:// streams being associated with the video plugin (in_dshow.dll), but it's not configured to use WMA DirectShow filters (like cnv_dshow.wac is in Winamp3), which is why WMA codec support via in_wm.dll is still required.
in_dshow.dll also doesn't seem to be able to interpret which DirectShow filters to use if there is no file extension in the url (note, adding /.wma was just a workaround for in_wm.dll, it doesn't work with in_dshow.dll)

The current known workaround is to use standard http protocol instead of tcp/mms:

http://some.web.address.here/.wma

This has worked for me, so far, with all mms:// wma streams.

If you want to get experimental, and this is something I've not yet tried personally, then (temporarily?) disable Video support (with Winamp closed, eg. rename in_dshow.dll to in_dshow.off).
See if the old "mms://...../.wma" trick works now . . .

btw, instead of spamming us with your skin (which ain't bad, btw)
why not put a link in your signature, and use that instead?
DJ Egg is online now   Reply With Quote
Old 23rd April 2003, 14:36   #3
Petepan@london
Member
 
Petepan@london's Avatar
 
Join Date: Apr 2003
Location: Never Never Land
Posts: 69
LEGEND!!!!

You were the one who over a year and a half ago helped me get my Net radio working, and again when it is broken in 2.9x you give me a work around. Thanks.

P.S. I also took your advice about the Sig.
Petepan@london is offline   Reply With Quote
Old 28th April 2003, 21:26   #4
glop
Senior Member
 
Join Date: Dec 2002
Location: Paris
Posts: 455
hello

your tip don't match for me <sob>
for example
http://viptvr.yacast.fr/tvr_europe2?site/.wma
nither
vipbu.yacast.fr/encoderlemouv/.WMA
.....
glop is offline   Reply With Quote
Old 28th April 2003, 23:09   #5
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,072
No, I can't even get that stream to work using mms://...../.wma method in Winamp 2.81 or Winamp3, though it does work in WMP using either of:
http://viptvr.yacast.fr/tvr_europe2?site
or mms://viptvr.yacast.fr/tvr_europe2?site
but not with: http://viptvr.yacast.fr/tvr_europe2?site/.wma
It's probably something to do with the dynamic link (?site)

Could you please provide the homepage url of the website for that stream.

Here's a couple of examples which do work in wa 2.91
http://radioio.wm.llnwd.net/radioio-hi/.wma
http://drlive.dr.dk/e05ch2kb64/.wma
DJ Egg is online now   Reply With Quote
Old 29th April 2003, 06:32   #6
glop
Senior Member
 
Join Date: Dec 2002
Location: Paris
Posts: 455
thanks DJ Egg
http://www.tv-radio.com/e2player/europe2/player.php is the page where display the radio
(you must download the file http://www.tv-radio.com/station/euro...rope_2-20k.asx to discover the true adress. the ?site is a tip to ping the radio because only /?WMA don't match...!

Maybe this kind of adress can't be read with the 2.9(1) (bug know list...)
glop is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump