Old 19th September 2012, 14:41   #1
paok1926
Junior Member
 
Join Date: Feb 2010
Posts: 15
SC_Trans & Edcast

hello all,

I'm trying to stream from Edcast encoder to Sc_Trans..
and all i get is this error...
msg:[DJPROTOCOLSHOUTCAST] Received password is in wrong format

i did it once, but i dont remember how.. can anyone help me ?


rgds,
George
paok1926 is offline   Reply With Quote
Old 19th September 2012, 22:21   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
that means it's not received a password like dj:noise (and specifically no colon could be found in the password). make sure that you're entering the password in the correct format (see the docs) and that you've configured the DJ event in the sc_trans config and calendar files.

-daz
DrO is offline   Reply With Quote
Old 19th September 2012, 22:49   #3
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,290
note: older (i.e. oddsock's) version of edcast screwed up passwords with non-alphanumeric passwords (basically anything other than a-z,A-Z,0-9 was being corrupted)

"If you don't like DNAS, write your own damn system"

So I did
jaromanda is offline   Reply With Quote
Old 20th September 2012, 10:37   #4
metal4radio
Junior Member
 
Join Date: May 2012
Posts: 17
In case you are still using the old oddsock version that isn't supported anymore since 2010, get this one: http://code.google.com/p/edcast-reborn/ . Works with sc v2 and also delivers meta data to players - which the old one doesn't when using sc v2.
metal4radio is offline   Reply With Quote
Old 24th September 2012, 11:12   #5
paok1926
Junior Member
 
Join Date: Feb 2010
Posts: 15
hello all,

i use the latest edcast version...
when i use the format adminassword i receive this message

msg:[DJPROTOCOLSHOUTCAST] Login denied from adminassword
paok1926 is offline   Reply With Quote
Old 24th September 2012, 11:19   #6
paok1926
Junior Member
 
Join Date: Feb 2010
Posts: 15
This is the "dj" section from my sc_trans.conf

; DJ stuff
djlogin_1=admin
djpassword_1=password
djpriority_1=1
djreplaygain=0.0
djcapture=0
djport=35020
djport2=0

and this is my calendar.xml

<?xml version="1.0" encoding="UTF-8"?>
<!--Calendar configuration file-->
<!--Made with the SHOUTcast 2 Configuration Builder-->
<eventlist>
<event type="dj">
<dj archive="inherit">dj</dj>
<calendar />
</event>
</eventlist>
paok1926 is offline   Reply With Quote
Old 24th September 2012, 11:36   #7
paok1926
Junior Member
 
Join Date: Feb 2010
Posts: 15
well...

it was my mistake... my sc_trans.conf pointed to a wrong calendar file..
i used the option djdebug=1 to debug...
paok1926 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump