Old 1st June 2012, 21:22   #1
BackY
Junior Member
 
Join Date: Jun 2012
Posts: 9
streampath= ?!

What is the correct value for streampath=
when hosting your shoutcast server in a Linux VPS, and connecting to it from Winamp (playing music from your playlist) ..I tried /live, I tried test.aac, test.mp3
but non seem to work.

When I try to connect to the listen.pls and play it from winamp (from another pc), I get to connect to the radio, but no sound is being played, or 404 error is being showed :/

Any ideas ?!
BackY is offline   Reply With Quote
Old 1st June 2012, 21:55   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
i'd suggest you check the DNAS's log for the errors being shown and any specifically relating to [YP2] as it sounds like the DNAS isn't properly configured which would cause the client to be blocked. since accessing on any invalid / unknown streampath will direct the client to stream #1.

as for the streampath value, all i can really do is point you at http://wiki.winamp.com/wiki/SHOUTcas..._Configuration so i don't re-type out the same thing.


but really check the logs as they will give the best idea of what is going on e.g. no authhash or the YP not seeing the DNAS are the common issues.

-daz
DrO is offline   Reply With Quote
Old 1st June 2012, 22:33   #3
BackY
Junior Member
 
Join Date: Jun 2012
Posts: 9
this is what the log says when I connect from winamp:
code:
2012-06-01 22:24:29 I msg:[SRC 79.126.191.51:3607 sid=1] SHOUTcast 1 source connection.
2012-06-01 22:24:30 I msg:[YP2] Connecting to yp.shoutcast.com
2012-06-01 22:24:30 I msg:[ADMINCGI] Title update [Azizi & Corona - Pasha syte e mi Cke moj Fiti Naze Tuj knu kenge me qiftlie]
2012-06-01 22:24:52 I msg:[YP2] Connecting to yp.shoutcast.com
2012-06-01 22:25:21 I msg:[DST 79.126.147.195:50278 sid=1] SHOUTcast 2 client connection accepted. WinampMPEG/5.62, Ultravox/2.1
2012-06-01 22:27:19 I msg:[DST 79.126.191.51:3661 sid=1] SHOUTcast 2 client connection accepted. WinampMPEG/5.60, Ultravox/2.1
2012-06-01 22:27:19 I msg:[ADMINCGI] Title update [[Connecting] http://184.22.204.96:8000/test.aac]
2012-06-01 22:27:20 I msg:[ADMINCGI] Title update [[HTTP/1.1 200 OK] http://184.22.204.96:8000/test.aac]



this is what the log file says when a client tried to connect:

code:
2012-06-01 22:28:11 E msg:[DST 79.126.147.195:50278 sid=1] Socket error while waiting to send data. err=Broken pipe(32)
2012-06-01 22:28:11 I msg:[DST 79.126.147.195:50278 sid=1] SHOUTcast 2 client connection closed (170 seconds) [Bytes: 2282941] Agent: `WinampMPEG/5.62, Ultravox/2.1'
2012-06-01 22:28:11 I msg:[DST 79.126.147.195:50280 sid=1] SHOUTcast 2 client connection accepted. WinampMPEG/5.62, Ultravox/2.1
2012-06-01 22:28:13 E msg:[DST 79.126.147.195:50280 sid=1] Socket error while waiting to send data. err=Connection reset by peer(104)
2012-06-01 22:28:13 I msg:[DST 79.126.147.195:50280 sid=1] SHOUTcast 2 client connection closed (2 seconds) [Bytes: 224471] Agent: `WinampMPEG/5.62, Ultravox/2.1'
2012-06-01 22:28:13 I msg:[DST 79.126.147.195:50281 sid=1] SHOUTcast 2 client connection accepted. WinampMPEG/5.62, Ultravox/2.1
2012-06-01 22:28:21 E msg:[DST 79.126.147.195:50281 sid=1] Socket error while waiting to send data. err=Connection reset by peer(104)
2012-06-01 22:28:21 I msg:[DST 79.126.147.195:50281 sid=1] SHOUTcast 2 client connection closed (8 seconds) [Bytes: 347722] Agent: `WinampMPEG/5.62, Ultravox/2.1'

BackY is offline   Reply With Quote
Old 1st June 2012, 22:53   #4
BackY
Junior Member
 
Join Date: Jun 2012
Posts: 9
this is how my shoutcast.conf looks:

code:
; NOTE: for any relative paths specified are relative to
; sc_serv and not to where the conf file is being stored

; here we will setup where the log and other related files
; will be stored. make sure that these folders exist else
; sc_serv will throw an error and will close itself down.
; we will make the logs save to the sc_serv2 directory
logfile=/var/log/sc_serv.log
w3clog=/var/log/sc_w3c.log
banfile=control/sc_serv.ban
ripfile=control/sc_serv.rip


; for testing we will make the server only work locally
; (i.e. localhost / 127.0.0.1) though if this is left out
; or set to publicserver=always then we attempt to make a
; connection to the YP for listing - do not forget to add
; in a 'streamauthhash' value for any public streams made
publicserver=always


; if you're wanting to use a different port to use for any
; connections then you can use this option e.g. to use 80
; otherwise port 8000 is used as the default to listen on.
portbase=8000


; password used by sc_trans or the Winamp dsp plug-in
; NOTE: remember to change this to something else
password=abc


; password used for accessing the administation pages
; NOTE: remember to change this to something else
adminpassword=abcd


; now we will specify the details of the stream we're going
; to serve which can be done as follows
streamid=1
; or

; it can be done like this which is how it needs to be done
; if you are going to provide multiple streams from sc_serv
;streamid_1=1
;streampath_1=/test.aac
;streamid_2=2
;streampath_2=/test2.aac
streamauthhash_1=IsVBKcm4dtomAHEpeYp5



and here is my sc_serv_simple.conf
code:
; NOTE: for any relative paths specified are relative to
; sc_serv and not to where the conf file is being stored

; here we will setup where the log and other related files
; will be stored. make sure that these folders exist else
; sc_serv will throw an error and will close itself down.
; we will make the logs save to the sc_serv2 directory

logfile=logs/sc_serv.log
w3clog=logs/sc_w3c.log
banfile=control/sc_serv.ban
ripfile=control/sc_serv.rip


; the following will force any sources to be public which
; allows us to then connect and be listed on the YP

publicserver=always


; password used by sc_trans or the Winamp DSP plug-in
; NOTE: remember to change this to something else
password=abc


; password used for accessing the administation pages
; NOTE: remember to change this to something else

adminpassword=abcd


; as we are going to connect to the YP then we need to fill
; in the required options so we can authenticate to the YP2
; see sc_serv.txt - section 3.0 for details on getting this
;
; make sure that you completely replace the string
; <enter_your_auth_key_here> with the authorisation key you
; obtained when registering the stream for the SHOUTcast YP
; e.g. if you auth hash key is 12345 then the line would be
; streamauthhash=12345

streamauthhash=IsVBKcm4dtomAHEpeYp5

BackY is offline   Reply With Quote
Old 2nd June 2012, 00:24   #5
BackY
Junior Member
 
Join Date: Jun 2012
Posts: 9
I managed to edit it somehow bro
Thank you,
BackY is offline   Reply With Quote
Old 2nd June 2012, 00:53   #6
DrO
 
Join Date: Sep 2003
Posts: 27,873
what you've posted and what your log is showing are contradicting.

the log shows that you've got streampath=/test.aac in the config file being used (what one i cannot tell as you've posted 2 different files which either have that line disabled or not present at all).

check _exactly_ what configuration file you are using and remove streampath=/test.aac as that is going to be the cause of Winamp connecting but not playing - as your stream is mp3 and /test.aac tells Winamp (and other players) to treat it as aac when it is not.

sorting that out will allow Winamp to play your stream.


--------------------------------------------------------


however, i've had to delete your authhash as it is now deemed as compromised (especially as it's been posted publically for 2hrs by the time of me finally seeing your additional posts. so for that you will need to remove the authhash from your config file and create a new one as per http://wiki.winamp.com/wiki/SHOUTcas...ash_Management and also ensure there is streamid=1 in your config file before doing that as per http://forums.winamp.com/showthread....79532#remember

and with that, i'm now off for the weekend (seeing as it's almost 2am my time).

-daz
DrO is offline   Reply With Quote
Old 2nd June 2012, 10:09   #7
BackY
Junior Member
 
Join Date: Jun 2012
Posts: 9
It's all good for now.
I may need to start experimenting for the option that will allow me to play songs diretly from my VPS server (not using winamp), So that I can leave the radio playlist without me being around all the time.
BackY is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump