Old 31st August 2001, 21:59   #1
help_help
Junior Member
 
Join Date: Aug 2001
Posts: 7
Can't hear cd in winamp 2.76

I am using winamp 2.76 on Windows ME. Whenever I insert a cd into either of my drives (dvd-audio or cd-rw) winamp reads the cd and gets cddb info, then it acts like it is playing the cd but no audio comes from the speakers. I know the speakers work because I can get sound from them and also windows media player plays cds fine. Also, mp3's, wavs and other audio play fine in winamp. only cds do not work.
help_help is offline   Reply With Quote
Old 31st August 2001, 22:23   #2
Budgie
Major Dude
 
Budgie's Avatar
 
Join Date: Jul 2000
Location: Hell frozen up
Posts: 1,217
Send a message via ICQ to Budgie
Go get the CD-Reader plugin for Winamp, it will resolve the issue .

The reason you can listen to CD audio without problems using the Windows Media Player is caused by the playback routines WiMP uses. Instead of playing the CD audio analogically through the audio cable interconnection between your CD-ROM / DVD drive and your soundcard, WiMP uses your drive's CDDA extraction feature to play back audio data. The CD-Reader plugin for Winamp works the same .

The advantages are better quality, as playback is being performed digitally using your soundcard's DAC instead of your CD-ROMs DAC. Most DACs that CD-ROM as well as DVD drives have usually only have a resolution of 12 bits . Digital playback is always better than analog, improving quality.

If you don't want to use the CD-Reader plugin, make sure the CD audio volume in the Windows mixer is being set to a decent value, let's say at least 70% of maximum. Just open up the Windows mixer by doubleclicking on the tiny yellowish speaker icon in the bottom right area of your screen (referred to as the "systray"; the area where the clock resides). In the window that appeared you can set up all your soundcard input and output.


Peace.


Please consider the Forum Rules before posting utter crap. Thank you!
Budgie is offline   Reply With Quote
Old 31st August 2001, 23:00   #3
help_help
Junior Member
 
Join Date: Aug 2001
Posts: 7
Okay, I tried to install the plugin but then when I config'd it, it gave me an error and still does not work. I know how to use the mixer and that doesnt seem to be the problem. Any other ideas?

help_help is offline   Reply With Quote
Old 31st August 2001, 23:08   #4
Budgie
Major Dude
 
Budgie's Avatar
 
Join Date: Jul 2000
Location: Hell frozen up
Posts: 1,217
Send a message via ICQ to Budgie
Umm, okay, what kind of error did CD-Reader print out? We'll need more info about that here ...

It should work with the default settings, generally. If not, then tweak CD-Reader's settings. Make sure you select your drive, especially when you have more than one CD-ROM / DVD / CD-Burner installed, it's essential that you select the appropriate drive in the configuration window.

Since WiMP plays flawlessly, I would assume the ASPI layer is installed correctly ... Hmmm ... Are you sure that your computer has an audio interconnection cable installed between your CD-ROM / DVD drive and your soundcard at all?


Peace.


Please consider the Forum Rules before posting utter crap. Thank you!
Budgie is offline   Reply With Quote
Old 1st September 2001, 01:17   #5
help_help
Junior Member
 
Join Date: Aug 2001
Posts: 7
It gave me some form of ASPI error. Yes, everything is connected fine. How would Windows Media Player work if not?
help_help is offline   Reply With Quote
Old 1st September 2001, 01:31   #6
Budgie
Major Dude
 
Budgie's Avatar
 
Join Date: Jul 2000
Location: Hell frozen up
Posts: 1,217
Send a message via ICQ to Budgie
Oh well, then I assume your ASPI layer is not installed correctly. The ASPI layer is required by Windows to communicate with CD-ROM / DVD / CD-Burner drives. I think, Windows originally uses SCSI commands to communicate with those devices, and the ASPI layer translates those to commands that (E)-IDE drives can understand. I am not 100%-ly sure that this is correct, maybe DJ Egg or somebody else knows more about that .

Go to http://www.adaptec.com. Search for an ASPI upgrade, called ASPI32.EXE. The most recent version is v4.60. Download it, as well as ASPICHK.EXE, which checks if and what version of the ASPI layer is installed onto your computer.

The ASPI layer upgrade needs an Adaptec-brand SCSI controller to be installed, otherwise the update won't install. Fortunately, there's an easy work-around : Just install a driver for an Adaptec SCSI controller that you can find on the Windows Installation CD, apply the ASPI layer upgrade, then remove the Adaptec SCSI Controller device from your computer's Control Panel -> System -> Device Manager.
After that, reboot and see if your problem disappeared.

I am actually confused why WiMP works flawlessly at all . What kind of ASPI error did CD-Reader print out? Can you supply us with the full error message, please?


Peace.


Please consider the Forum Rules before posting utter crap. Thank you!
Budgie is offline   Reply With Quote
Old 1st September 2001, 01:34   #7
Budgie
Major Dude
 
Budgie's Avatar
 
Join Date: Jul 2000
Location: Hell frozen up
Posts: 1,217
Send a message via ICQ to Budgie
Quote:
Originally posted by help_help
It gave me some form of ASPI error. Yes, everything is connected fine. How would Windows Media Player work if not?
Even though everything is connected, WiMP works fine as it utilizes your drive's CDDA digital extraction feature, making the audio cable interconnection useless. Did you read my earlier post at all ?


Peace.


Please consider the Forum Rules before posting utter crap. Thank you!
Budgie is offline   Reply With Quote
Old 1st September 2001, 05:39   #8
help_help
Junior Member
 
Join Date: Aug 2001
Posts: 7
Caution:
Do NOT install ASPI32.EXE with Windows 2000, Windows ME, Easy CD Creator 4.x, or with Windows Media Player 7.0. If you have one of these applications (or operating systems), you will be using a different aspi layer that will conflict with the one provided in this file.

From Adaptec's site. I am running windows ME, with Easy CD Creator as well as WiMP.

In reinstalled the plugin and I am no longer getting an error message however, there is still no sound from cds.
help_help is offline   Reply With Quote
Old 1st September 2001, 11:12   #9
EvilDick23
Senior Member
 
Join Date: Aug 2001
Location: I got your Aloha right here
Posts: 110
hmmmmm

You would manually have to install that file and since all the files that you described don't automatically run executables except for the Easy CD Creator, it shouldn't be a problem. One note, don't put Windows ME and Windows 2000 in the same category. They are completely different OS's being that ME is the next gen soon to be retired 98 base and 2000 is the NT base soon to be retired. FAT32 and NTFS are completely different. As are 16 bit and 32-bit apps. Did you build this PC or install the CD-ROM drive yourself? If so, there should be a CD-out 4-pin connection from the drive to the soundcard or to the motherboard. You need this connected in order to play an audio CD (not a CD with recorded MP3's). The manual should tell you how to hook it up if necessary.
EvilDick23 is offline   Reply With Quote
Old 1st September 2001, 13:04   #10
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,074
One thing to check in the config with the in_cdda.dll default plugin (which I take it you've now re-enabled) is whether "sample input from soundcard" is checkmarked or not.
If it is, uncheck it, and vice-versa if it isn't.

If it needs checkmarking, make sure the Audio CD level is up high enough in
Windows Volume Control -> Recording properties (not just Playback controls)

Further info here:
http://forums.winamp.com/showthread.php?threadid=64973

btw, can you hear other formats ok in Winamp, eg. WAV, MP3, WMA, MID, etc?

If not, then make sure the volume slider in the main Winamp window is up high enough. I'm sure you must've checked this, but it's always worthwhile mentioning, just in case

If you still can't get the default CD Input plugin to work, go back to trying the CDReader plugin, but make sure it is properly configured. CDreader has a tendency to confuse drives and ASPI drivers when there's more than one CD-ROM device installed.

CDReader config -> general tab -> hi-lite Drive -> config
Make sure the correct ASPI driver is assigned to the correct device/drive. Repeat this for the other drive too.

You can always experiment a little. Maybe switch to Win32 Interface instead of ASPI. You just never know!

Most importantly, as referred to in the readme.txt which comes with CDReader,
make sure you've disabled the default Nullsoft CD plugin first.
With Winamp closed, in Windows Explorer goto the Winamp\Plugins folder
and rename in_cdda.dll to in_cdda.dll off


btw, WiMP is integrated into the OS, so naturally M$ are going to make sure it fully works, hehe. It uses the system's MCI and DirectX drivers/filters directly, unlike Winamp and other such players which use their own plugin structure/driver interface to connect to your hardware devices' (soundcard, videocard, etc) drivers.

You could also try switching to DirectSound Output instead of WaveOut
(Winamp Prefs -> Output)
Also experiment by changing the Output Device in the config to use your soundcard driver (c/o drop-down menus), instead of WaveMapper or Primary Sound Driver (WaveOut & DS Outputs respectively)

Hope this helps

Good luck!
DJ Egg is online now   Reply With Quote
Old 1st September 2001, 16:00   #11
help_help
Junior Member
 
Join Date: Aug 2001
Posts: 7
All other formats in Winamp work fine. One thing I noticed while playing around in WiMP was that in the Options > CD Audio tab I have "digital playback" checked and if I uncheck it, there is no sound. Also in the sound mixer, while listening to a cd in WiMP, it does not matter if I raise or lower the CD Audio volume however if I adjust the direct sound it affects the cd playback. Does this mean anything?
help_help is offline   Reply With Quote
Old 1st September 2001, 20:04   #12
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,074
The default in_cdda.dll plugin uses the CD Audio slider
(under both playback & recording settings)

CDReader uses WaveOut/DirectSound slider

You might also want to go back into Volume Control -> Options -> Properties
See if Digital CD is available & checkmarked (it all depends on your soundcard)
If there is this option, select it and make sure the slider's up high enough.

Also check Multimedia Control Panel -> CD Audio tab
See if there's an option to enable digital cd audio?

btw, did you try all the suggestions above?
Or are you now saying you can hear your CD's in Winamp, yes?
DJ Egg is online now   Reply With Quote
Old 1st September 2001, 20:11   #13
Budgie
Major Dude
 
Budgie's Avatar
 
Join Date: Jul 2000
Location: Hell frozen up
Posts: 1,217
Send a message via ICQ to Budgie
That can actually only mean one thing: There is no audio cable interconnection between your CD-ROM / DVD drive and your soundcard!

Are you 100%-ly sure you have such a cable installed into your computer? Analog (aka "usual / standard") playback of CD audio on your computer requires that such a cable is properly installed.

If there is such an interconnection present, make sure it's installed properly, that is firmly connected to the drive and the soundcard. Some soundcards have more than one input for CD audio cables, so I would say check your soundcard's documentation for more info.

Usually all PCs automatically come with such a cable installed. Let's say 98 - 99% of all PCs.

The reason that playing around with the CD audio slider in the Windows mixer causes changes in CD volume is because it's a digital CD input. Do you have a SB Live! ? We'll need full system specs, once again. Especially the model / brand of your soundcard.

Did you also chance the CD Recording Volume in the Windows mixer as well, as DJ Egg suggested???


Peace.


Please consider the Forum Rules before posting utter crap. Thank you!
Budgie is offline   Reply With Quote
Old 1st September 2001, 21:32   #14
help_help
Junior Member
 
Join Date: Aug 2001
Posts: 7
My system:
Pentium 4 1.7 Ghz
Intel DBG850 Motherboard
384 MB SDRAM PC800
Dual 75 GB IBM Deskstar Hard Drives
Promise Ultra100 IDE Controller
NVidia GeForce 3 64MB DDR
Soundblaster Live! XGamer
Pioneer 16x DVD Player with Hardware MPEG-2 Decoder
Plextor 16x/10x/40x CD-RW
Midiland 8200 Speaker and Sub system
Microsoft Wundows Millenium OEM

I think I tried everything DJ Egg said... Is CD Recording Balance the same as CD Digital Balance?

Still can not hear cds in winamp. Where do I check to see if the cable is connected? Inside the pc?
help_help is offline   Reply With Quote
Old 2nd September 2001, 15:21   #15
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
Lost track of which plug-in you have in use.

If its in_CDDA then you have to have an analogue connection, this is a normal looking wire(as opposed to a ribbon cable) from the back of your CD drive to a connector on the sound card inside the computer case, one of the sides should come off very easily so you can look.

If its CD_Reader then analogue is not needed. Check that CD_Reader is configured correctly, installation is not automatic and sometimes the wrong drive letter is assigned to the wrong device, causing an ASPI error. This is the one to go for if you can get it working.

I notice you have a Plextor drive. Did it come with a copy of WinOnCD? If so you can update the ASPI layer to the latest version by running the program ASPIINST.EXE which you sould find on the installation CD.

UJ
ujay is offline   Reply With Quote
Old 3rd September 2001, 07:54   #16
rjolicoeur
Junior Member
 
Join Date: Sep 2001
Posts: 1
Quick Fix

This worked for me:

Go into Preferences->Input->Nullsoft CD/LineIn plug-in v1.71
Click on "Configure" and uncheck "Sampling"

Good Luck!
rjolicoeur is offline   Reply With Quote
Old 4th September 2001, 19:21   #17
JamesWElmore
Junior Member
 
Join Date: Sep 2001
Location: Birmingham Alabama
Posts: 3
Apologies if this has already been covered

CD Audio to Winamp also gets disabled if you are running Windows Media Player 7.x. You can fix this by going to (In Media Player)
Tools >Options >CD Audio/ uncheck the "Digital Playback" Settings.

James (No I won't fix your damn computer right now Im fixing my Winamp!!!!) Elmore
JamesWElmore is offline   Reply With Quote
Old 4th September 2001, 20:34   #18
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,074
Well thank you James E for your invaluable contribution.
I really do hope that this is the cause and solution.
It certainly wouldn't surprise me, that's for sure.
btw, I've no way of finding out myself, because I don't have/use WMP7

Can anyone else confirm if this works or not?

Cheers -> DJ-Egg
DJ Egg is online now   Reply With Quote
Old 4th September 2001, 22:00   #19
help_help
Junior Member
 
Join Date: Aug 2001
Posts: 7
Nope. Althought it did cause winamp to make my speakers make a very high pitched buzz... No the volume settings aren't down/up/where they're not supposed to be. I am beginning think the new winamp has a bug...
help_help is offline   Reply With Quote
Old 5th November 2001, 22:33   #20
lili
Junior Member
 
Join Date: Nov 2001
Posts: 1
Thanks

Just wanted to say "Thank you!!" to everyone who posted here with advice. I had the same problem. It was driving me crazy! Thanks again.
lili is offline   Reply With Quote
Old 14th December 2001, 21:03   #21
PipSkywalker
Junior Member
 
Join Date: Dec 2001
Posts: 1
Re: Quick Fix

Quote:
Originally posted by rjolicoeur
This worked for me:

Go into Preferences->Input->Nullsoft CD/LineIn plug-in v1.71
Click on "Configure" and uncheck "Sampling"

Good Luck!
Thank you very much! Winamp worked fine with my IDE CD drive but I recently installed a scsi CD-rom. Music CDs played but produced no sound although they played fine in Windows CD Player. I just spent 2 hours trying to solve this. Thanks for the quick fix!

Pip
PipSkywalker is offline   Reply With Quote
Old 14th December 2001, 21:19   #22
me109cito
Senior Member
 
me109cito's Avatar
 
Join Date: Feb 2001
Location: monterrey,mexico
Posts: 409
reinstall sound card drivers

estos foros estan llenos de geeks!!!
no dejes que te atrapen
me109cito is offline   Reply With Quote
Old 11th March 2002, 02:16   #23
sireynolds
Junior Member
 
Join Date: Mar 2002
Posts: 1
no CD sound

I had this same problem with v2.78 and w2k. Just download the plugin but remember to rename the file in_cdda.dll to something else, e.g. in_cdda.dll.off, then works fine.
sireynolds is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump