Old 25th October 2006, 18:31   #1
kaatinthehaat
Major Dude
 
kaatinthehaat's Avatar
 
Join Date: Jul 2004
Location: Vancouver, Canada
Posts: 504
"Now Playing" crash in 5.31

I've just installed 5.31 and have had recurrent crashes when I click on the "Now Playing" tab in the media library while a song is playing.

This occurs after starting a playlist playing. "Now Playing" will work until I switch back to the Media Library view. After that, if I switch back to Now Playing, the window becomes a blank gray screen, then Winamp will crash and close.

I am using Win XP SP2 with DSL internet connection.

80GB 5.5 generation Video iPod

4GB and 8GB gen 2 Nano's with ****+

Winamp 5.52 Pro ; ml_iPod 3.05
kaatinthehaat is offline   Reply With Quote
Old 25th October 2006, 19:59   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Sorry, but we cannot reproduce this.

What are the details of the crash?

Now Playing uses an embedded Internet Explorer window, so it's possible that there's something wrong with your IE (a possible spyware hijack maybe)?
DJ Egg is offline   Reply With Quote
Old 26th October 2006, 06:40   #3
kaatinthehaat
Major Dude
 
kaatinthehaat's Avatar
 
Join Date: Jul 2004
Location: Vancouver, Canada
Posts: 504
Thanks for the reply. I'll check it out a bit more.

I've noticed it happens when I switch between "Now Playing" and "Dashboard", with or without music playing.

Any chance it could be related to a winamp plugin?

80GB 5.5 generation Video iPod

4GB and 8GB gen 2 Nano's with ****+

Winamp 5.52 Pro ; ml_iPod 3.05
kaatinthehaat is offline   Reply With Quote
Old 26th October 2006, 11:17   #4
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Could be. Attach a HijackThis log and List of Plugins (my_plugins_list.txt)

http://forums.winamp.com/showthread....d=161361#specs
DJ Egg is offline   Reply With Quote
Old 26th October 2006, 21:44   #5
kaatinthehaat
Major Dude
 
kaatinthehaat's Avatar
 
Join Date: Jul 2004
Location: Vancouver, Canada
Posts: 504
Here's the hijack log....

I couldn't find my_plugins_list.txt despite a thorough hard drive search.
Attached Files
File Type: txt hijackthis.txt (23.6 KB, 288 views)

80GB 5.5 generation Video iPod

4GB and 8GB gen 2 Nano's with ****+

Winamp 5.52 Pro ; ml_iPod 3.05
kaatinthehaat is offline   Reply With Quote
Old 27th October 2006, 00:53   #6
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Info on how to produce a my_plugins_list.txt log can be found in paragraph 8 via the same link above, but here's a direct link to said paragrapgh:
http://forums.winamp.com/showthread....161361#plugins


However... I do see a few problems in your HJT log

O4 - HKCU\..\Run: [HwqnRjZmV] mdm2_32.exe

O16 - DPF: {15AD6789-CDB4-47E1-A9DA-992EE8E6BAD6} - http://static.windupdates.com/cab/DownloadAccess/ie/bridge-c15.cab


mdm2_32.exe is definitely something evil, probably a trojan
and windupdates is a known source of spyware/malware.


Close all browser/email/office/explorer windows, checkmark those two entries ONLY in the hjt scan results, and click "Fix checked".



I'm also very suspicious of this entry:

O20 - AppInit_DLLs: C:\WINDOWS\system32\AirfoilInject.dll

Can you shed any light on what that dll is?



I strongly suggest you run a full system scan with Ad-Aware SE, and maybe a couple of online AV scanners, eg. Kaspersky and TrendMicro.

Note that you can use Kaspersky online file scanner (same page as the remote virus scanner) to individually test those files listed above (mdm2_32.exe & AirfoilInject.dll), and/or the jotti scanner.

Also run CCleaner to delete all temp files (including internet cache).


Reboot and be sure to delete mdm2_32.exe (probably in the windows\system32 dir)
DJ Egg is offline   Reply With Quote
Old 27th October 2006, 16:56   #7
kaatinthehaat
Major Dude
 
kaatinthehaat's Avatar
 
Join Date: Jul 2004
Location: Vancouver, Canada
Posts: 504
Wow!

Thanks for the reply. Sorry about the my_plugins file. I just assumed it existed already and I didn't fully read that link.

Airfoil is a program which streams audio to the Apple Airport Express wireless unit from various windows based audio programs such as winamp.

I already ran Ad-Aware SE prior to my first post but I will follow your furthewr advice and get back to you.

Thanks again for your help, DJ Egg.

80GB 5.5 generation Video iPod

4GB and 8GB gen 2 Nano's with ****+

Winamp 5.52 Pro ; ml_iPod 3.05
kaatinthehaat is offline   Reply With Quote
Old 27th October 2006, 17:00   #8
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Ok, keep the airfoil entry, but definitely kill those other two.
DJ Egg is offline   Reply With Quote
Old 27th October 2006, 17:41   #9
kaatinthehaat
Major Dude
 
kaatinthehaat's Avatar
 
Join Date: Jul 2004
Location: Vancouver, Canada
Posts: 504
OK.

Here's what I have done so far:
I ran Hijack this again and fixed those 2 entries.
I rebooted.
I downloaded and ran CCleaner.

Crash still happens. I'm suspicious that it's related to a plugin because I now remember that I had installed but then removed the "NowPlaying2" plugin(http://www.winamp.com/plugins/details.php?id=148285). I should have thought of this earlier but I thought it was removed, and it was prior to upgrading to Winamp 5.31.

Anyway here is the plugin list attached. Thanks.
Attached Files
File Type: txt my_plugin_list.txt (4.2 KB, 373 views)

80GB 5.5 generation Video iPod

4GB and 8GB gen 2 Nano's with ****+

Winamp 5.52 Pro ; ml_iPod 3.05
kaatinthehaat is offline   Reply With Quote
Old 27th October 2006, 17:57   #10
kaatinthehaat
Major Dude
 
kaatinthehaat's Avatar
 
Join Date: Jul 2004
Location: Vancouver, Canada
Posts: 504
Should I just do a clean re-install of Winamp and the plugins that I currently use? On reviewing that plugin file I realized there are a lot of old plugins that I don't use at all anymore.

80GB 5.5 generation Video iPod

4GB and 8GB gen 2 Nano's with ****+

Winamp 5.52 Pro ; ml_iPod 3.05
kaatinthehaat is offline   Reply With Quote
Old 27th October 2006, 17:59   #11
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Ok, at least you got rid of those two evils (assuming they no longer show in the latest hjt log)

Yeah, you've got a fair few 3rd-party plugins installed, any of which could be responsible.

I'll list them below, in order of suspicion...

Minibrowser API Support 0.7.2 for Winamp 5.22+ [gen_mbapi.dll]
ml_Icons v0.3 [ml_icons.dll]
gUSB v1 build 005 [ml_gusb_us.dll]
Tips v0.61 [gen_tips.dll]
Toaster for Winamp Classic v0.7.6 [gen_toaster.dll]
SqrSoft® Advanced Crossfading v1.75 [out_sqr.dll] [active]
jetCast dsp plug-in for Winamp [dsp_jetCast.dll] [active]

There's more (output & vis), but probably not to blame if not active.


btw, there's a newer version of the Transcoder plugin (which works with 5.31, whereas your old version doesn't) available, either separately or as part of the Essentials Pack:
http://forums.winamp.com/showthread....70#post2049870
http://www.srcf.ucam.org/~wdhf2/transcoder/
DJ Egg is offline   Reply With Quote
Old 27th October 2006, 18:28   #12
kaatinthehaat
Major Dude
 
kaatinthehaat's Avatar
 
Join Date: Jul 2004
Location: Vancouver, Canada
Posts: 504
I removed the Minibrowser API Support 0.7.2 for Winamp 5.22+ [gen_mbapi.dll] and the crash seems to have stopped happening so far!!

I'll let you know after a while to see if this was the solution.

Thanks again for all your help. I learned a few things as well

80GB 5.5 generation Video iPod

4GB and 8GB gen 2 Nano's with ****+

Winamp 5.52 Pro ; ml_iPod 3.05
kaatinthehaat is offline   Reply With Quote
Old 16th November 2006, 23:16   #13
fifteenrabbits
Junior Member
 
Join Date: Oct 2006
Location: Massachussetts, currently
Posts: 4
Send a message via AIM to fifteenrabbits
no! I have this same problem, its because of nowplaying2

I really want nowplaying2 to work, but I can't figure out how.

it said to change my configuration so that winamp is set for "not connected to the internet" but I've done that, and it still crashes.

when I uninstall nowplaying2 it operates just fine.

I really want nowplaying2 to work.
fifteenrabbits is offline   Reply With Quote
Old 17th November 2006, 10:12   #14
siebe83
Forum King
 
siebe83's Avatar
 
Join Date: Feb 2004
Posts: 9,222
Sorry, but 3rd-party plugins are not supported on the forums. You would need to contact the plugin author for support.

Good Winamp plugins by Joonas, DrO and shaneh.
If you're bored go here or, if the boredom is more serious, here.
siebe83 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump