Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Reply
Thread Tools Search this Thread Display Modes
Old 4th December 2006, 21:37   #1
jph6t
Major Dude
 
jph6t's Avatar
 
Join Date: May 2004
Location: USA
Posts: 756
"Play selection" works differently in a SmartView vs a CD in the 'Rip & Burn' View

Right clicking and selecting "Play selection" on a CD track within the Media Library’s (ML) "Rip & Burn" View does NOT behave the same way as it does when selecting the same command on a song within a ML SmartView.

Selecting “Play selection” in a ML SmartView …
  1. Clears the Playlist
  2. Enqueues the selected song
    PLUS ALL the songs being displayed along with it in the SmartView’s lower pane, putting them in the same order as they are displayed in the SmartView.
  3. Begins playing the selected song immediately
    from whatever its location in the Playlist
Selecting “Play selection” in the ML’s “Rip & Burn” View …
  1. Clears the Playlist
  2. Enqueues the selected song
  3. Begins playing the selected song immediately
Seems to me that this command should behave the same way
regardless of the View from which it is called.

Funny thing is, the "Play" button at the bottom of the "Rip & Burn" View DOES
behave the same way as the “Play selection” command in a SmartView.

Note: If debating which way is right ...
I personally prefer the way the SmartView and the “Play” button work.

Please let me know if I can provide any other information.

----------------------------------------------------

I doubt that this issue is related to my machine and settings, but just in case someone asks ...

My System Specs:
  • Windows XP Professional SP2
  • DirectX 9.0c
  • Internet Explorer v6
  • Winamp v5.32 + 5.32 Update Pack
  • Separate User Setting Option
  • Jump To File Extra v0.97.10 (Build_86)
  • Running all the plugins in my signature
jph6t is offline   Reply With Quote
Old 4th December 2006, 21:57   #2
siebe83
Forum King
 
siebe83's Avatar
 
Join Date: Feb 2004
Posts: 9,222
Prefs (Ctrl+P) > Media Library > tab Library Options > 'Play all search results (start with selected) on double click in media views'

(where 'media views' refers to the views under Local Media)

Good Winamp plugins by Joonas, DrO and shaneh.
If you're bored go here or, if the boredom is more serious, here.
siebe83 is offline   Reply With Quote
Old 5th December 2006, 05:52   #3
jph6t
Major Dude
 
jph6t's Avatar
 
Join Date: May 2004
Location: USA
Posts: 756
Problem when “Double click or Enter in the Library” = “Enqueues selected item(s)"

siebe83, the setting you pointed me to was not responsible for my problem.
(I already had that setting checked.)
However, you did give me the clue I needed to figure out what is going on!

The settings on the “Media Library” > “Library Options” tab
(in the Winamp Preferences) are absolutely related to this issue!

Attached is a screen shot of my settings while experiencing the above noted problem.

Everything is working as expected when ...
  • “Double click or Enter in the Library” = “Play selected item(s)”

    OR
  • “Play all items (start with selected) on double click in playlists” AND
    “Play search results (start with selected) on double click in media views”
    are UNCHECKED
The problems occur when …
  • “Double click or Enter in the Library” = “Enqueues selected item(s)” AND
    EITHER
    “Play all items (start with selected) on double click in playlists” OR
    “Play search results (start with selected) on double click in media views”
    are CHECKED.
I will document and post my test results in the morning,
but I definitely think there is a bug when the above condition(s) exist.
Attached Images
File Type: jpg screen shot.jpg (47.0 KB, 436 views)
jph6t is offline   Reply With Quote
Old 31st December 2006, 17:24   #4
jph6t
Major Dude
 
jph6t's Avatar
 
Join Date: May 2004
Location: USA
Posts: 756
Re: Problem when “Double click or Enter in the Library” = “Enqueues selected item(s)"

Quote:
Originally posted by jph6t
I will document and post my test results in the morning, but I definitely think there is a bug when the above condition(s) exist.
Ok, so that was a looooong winter’s nap (aka delay) … but after a long wait …
below/attached are the results of my tests using the various combinations of settings. Results written in RED are the suspected problems.

From these tests, I’ve isolated the following bugs:


Bug #1
  • w/ “Double click or Enter in the Library” = “Enqueues selected item(s)”
  • AND the “Play search results (start with selected) on double click in media views” property CHECKED
Double click a song via a SmartView in the ML.
Winamp will enqueue ONLY the one selected song.

Expected Behavior – Winamp will enqueue the search results in the same order they are displayed in the ML.

Bug #2
  • w/ “Double click or Enter in the Library” = “Enqueues selected item(s)”
  • AND the “Play all items (start with selected) on double click in playlists” property CHECKED
Double click a CD track via the “Rip & Burn” view in the ML.
Winamp will enqueue ONLY the one selected song.

Expected Behavior – Winamp will enqueue the entire contents of the CD in the same order they are displayed in the ML.

Bug #3A
  • w/ “Double click or Enter in the Library” = “Enqueues selected item(s)”
  • AND the “Play all items (start with selected) on double click in playlists” property CHECKED
Right-click a song and select “Play selection” via a ML Playlist in the ML.
Winamp will clear the active Playlist, and begin playing ONLY the one selected song.

Expected Behavior – Winamp will clear the active Playlist, enqueue the entire contents of the ML Playlist in the same order they are displayed in the ML, and begin playing the selected song from wherever it is located within the Playlist.

Bug #3B
  • w/ “Double click or Enter in the Library” = “Enqueues selected item(s)”
  • AND the “Play all items (start with selected) on double click in playlists” property CHECKED
Right-click a CD track and select “Play selection” via the “Rip & Burn” view in the ML.
Winamp will clear the active Playlist, and begin playing ONLY the one selected song.

Expected Behavior – Winamp will clear the active Playlist, enqueue the entire contents of the CD in the same order they are displayed in the ML, and begin playing the selected song from wherever it is located within the Playlist.

Now one could argue that my Expected behavior to Bug #3A & Bug #3B is inaccurate. That the given properties on the “Media Library” > “Library Options” tab were never meant to affect the performance of the “Play selection” command.
However, if that is the case then Bug #3A & Bug #3B would be replaced with:


Bug #3 v2
  • w/ “Double click or Enter in the Library” = “Enqueues selected item(s)”
  • AND the “Play search results (start with selected) on double click in media views” property CHECKED
Right-click a song and select “Play selection” via a SmartView in the ML.
Winamp will clear the active Playlist, enqueue the search results in the same order they are displayed in the ML, and begin playing the selected song from wherever it is located within the Playlist.

Expected Behavior – Winamp will clear the active Playlist, and begin playing ONLY the one selected song.
Attached Images
File Type: jpg test results.jpg (33.4 KB, 745 views)

Last edited by jph6t; 31st December 2006 at 18:13.
jph6t is offline   Reply With Quote
Old 31st December 2006, 17:49   #5
jph6t
Major Dude
 
jph6t's Avatar
 
Join Date: May 2004
Location: USA
Posts: 756
Update Property Label

As documented in the posts above ...
the “Play all items (start with selected) on double click in playlists” property, located on the “Media Library” > “Library Options” tab (in the Winamp Preferences) and circled in the attached, is NOT only affecting the performance of commands executed via the ML Playlists within the ML. This property is ALSO affecting the performance of commands executed via the “Rip & Burn” view in the ML.

As such, might I request the label of this property in the Preferences window be updated to accurately reflect the affect it has on the operation of Winamp.

Perhaps update the label to state:
“Play all items (start with selected) on double click in playlists and CDs”
Attached Images
File Type: jpg screen shot - property label.jpg (47.6 KB, 713 views)
jph6t is offline   Reply With Quote
Old 31st December 2006, 18:10   #6
jph6t
Major Dude
 
jph6t's Avatar
 
Join Date: May 2004
Location: USA
Posts: 756
Problem when “Double click or Enter in the Library” = “Play selected item(s)”

Quote:
Originally posted by jph6t
Everything is working as expected when ...
  • “Double click or Enter in the Library” = “Play selected item(s)”
I was too quick to give a passing grade in my original tests.
CD play is NOT always working as expected while “Play selected item(s)” is selected.

Bug #4
  • w/ “Double click or Enter in the Library” = “Play selected item(s)”
  • AND the “Play all items (start with selected) on double click in playlists” property UN-CHECKED
Double click a CD track via the “Rip & Burn” view in the ML.
Winamp will clear the active Playlist, enqueue the entire contents of the CD in the same order they are displayed in the ML, and begin playing the selected song from wherever it is located within the Playlist.

Expected Behavior – Winamp will clear the active Playlist, and begin playing ONLY the one selected song.
Attached Images
File Type: jpg screen shot - double click plays.jpg (47.3 KB, 375 views)
jph6t is offline   Reply With Quote
Old 31st December 2006, 18:17   #7
jph6t
Major Dude
 
jph6t's Avatar
 
Join Date: May 2004
Location: USA
Posts: 756
Can anyone else replicate the above bug(s)?
jph6t is offline   Reply With Quote
Old 3rd January 2007, 10:51   #8
jph6t
Major Dude
 
jph6t's Avatar
 
Join Date: May 2004
Location: USA
Posts: 756
Quote:
Originally posted by jph6t
Can anyone else replicate the above bug(s)?
Anyone?
jph6t is offline   Reply With Quote
Old 3rd January 2007, 12:04   #9
siebe83
Forum King
 
siebe83's Avatar
 
Join Date: Feb 2004
Posts: 9,222
Yeah, there seem to be some inconsistencies there...
I can reproduce #1 and #3.

As for #1, one could argue that the 'Play all search results' option does not affect enqueueing, however the 'Play all items' option does affect enqueueing in playlists.


As for #2 and #4: it seems to me that neither the 'Play all search results' nor the 'Play all items' option affects double-click actions in the CD Ripping/Burning view.
For me, if 'Play selected items' is selected, double-clicking will always load all items and start playing the selected item. If 'Enqueue selected items' is selected, double-clicking will always add the selected items only. Right-clicking and choosing 'Play selection' will always load the selected items only.
If you want to be able to configure that behaviour, you'd need an extra option (e.g. 'Play all items (starting with selected) on double click in CD views'), which turns #2 & #4 in a feature request.

Good Winamp plugins by Joonas, DrO and shaneh.
If you're bored go here or, if the boredom is more serious, here.
siebe83 is offline   Reply With Quote
Old 24th February 2007, 15:46   #10
jph6t
Major Dude
 
jph6t's Avatar
 
Join Date: May 2004
Location: USA
Posts: 756
Quote:
Originally posted by siebe83
As for #2 and #4: it seems to me that neither the 'Play all search results' nor the 'Play all items' option affects double-click actions in the CD Ripping/Burning view.
For me, if 'Play selected items' is selected, double-clicking will always load all items and start playing the selected item. If 'Enqueue selected items' is selected, double-clicking will always add the selected items only. Right-clicking and choosing 'Play selection' will always load the selected items only.
Well my test results are different for whatever reason, and are documented above.
I still think there is a bug here, although perhaps it's a little more quirky than originally thought if siebe83's system is behaving as expected.
jph6t is offline   Reply With Quote
Old 24th February 2007, 15:51   #11
jph6t
Major Dude
 
jph6t's Avatar
 
Join Date: May 2004
Location: USA
Posts: 756
Problems w/ ML's "Double Click or Enter Options"

Quote:
Originally posted by siebe83
Yeah, there seem to be some inconsistencies there...
I can reproduce #1 and #3.
I installed Winamp v5.33 and redid my testing.

While I notice that v5.33 has improved the response time of the ML's "Rip & Burn" view, my test results were identical to those documented above

Can anyone else replicate the above bug(s)?
  • Problem w/ “Double click or Enter in the Library” = “Enqueues selected item(s)"
    (Visual Aid - Items in RED are the bugs)
  • Bug #1
  • Bug #2
  • Bug #3A & Bug #3B

    Problem w/ "Double click or Enter in the Library” = “Play selected item(s)”
  • Bug #4

Last edited by jph6t; 24th February 2007 at 16:11.
jph6t is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump