Old 20th September 2010, 06:54   #1
nick_goyal
Junior Member
 
Join Date: Aug 2008
Posts: 24
default buttons are not working on a custom page

Hi Everybody,

I have a custom page to check the tcp open port, in the leave function i have a condition that if the port is occupied don't move to next page and show a message. Now my problem is when i click cancel button on that page it checks the port and show the message then finally stay on the same page in place of canceling the installation. As well the previous button cancel the installation in place of taking to the old page. Please help me asap as i am in a mess.

I am attaching the custom page code.
Attached Files
File Type: zip CustomPage.zip (987 Bytes, 94 views)
nick_goyal is offline   Reply With Quote
Old 20th September 2010, 08:27   #2
Afrow UK
Moderator
 
Afrow UK's Avatar
 
Join Date: Nov 2002
Location: Surrey, England
Posts: 8,434
Your first message box needs a +2 (or CANCEL) on the end. You're not telling it where to jump to on Cancel click. As for your problem, I can't see any. What is your page definition?
Page ServerChangesCreate ServerChangesLeave?

Stu
Afrow UK is offline   Reply With Quote
Old 20th September 2010, 09:05   #3
nick_goyal
Junior Member
 
Join Date: Aug 2008
Posts: 24
Hi Afrow,

Yes i am giving the same definition to the page.

Page ServerChangesCreate ServerChangesLeave

Well i have attached the full script for the reference. Thank you very much for giving time.
Attached Files
File Type: zip TestScript.zip (5.4 KB, 96 views)
nick_goyal is offline   Reply With Quote
Old 20th September 2010, 17:11   #4
Afrow UK
Moderator
 
Afrow UK's Avatar
 
Join Date: Nov 2002
Location: Surrey, England
Posts: 8,434
Just noticed you have !insertmacro XPUI_INSTALLOPTIONS_DISPLAY "" in your custom page show functions. You're using nsDialogs, not InstallOptions. Take those lines out.

Edit: Also your test script does not build. If you want more people to help you should make a script that reproduces the problem that has no dependencies (XPUI for example).

Stu
Afrow UK is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Developer Center > NSIS Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump