Old 13th February 2014, 01:58   #1
Obsdark
Member
 
Join Date: Jan 2011
Posts: 75
Problems of SHOUTcast on CentOS

Hey oh!

I have a little problem, you see...

when i active shoutcast on CentOS, it seems not been working, i mean i try, not with music but try to connect to it, to try at least to connect it to know than it is possible, but it seems than that doesn't happend

Also, i notice than, when i active through terminal the sc_serv, the terminal never "end" the starting, i mean, keep advancing and stop in one point, but never send me again to write command from [User@Radio /] or somethink like that, any help?

CentOS 6.5

Please, feel free to ask

Thanks you for everything
Obsdark is offline   Reply With Quote
Old 13th February 2014, 02:50   #2
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,289
you try not with music? what you try with? you must send something to shoutcast for it to send to you something

can you see the welcome page when you go to http://your.server.address:port/index.html

Is it just me or are shoutcast users getting dumber?
jaromanda is offline   Reply With Quote
Old 13th February 2014, 17:40   #3
Obsdark
Member
 
Join Date: Jan 2011
Posts: 75
try to run it but now it says

"[MAIN] Aborting as no valid configaa files could be found.

[MAIN] Try running setup mode to create a valid config file"

Any ideas?

it was working yesterday, at least don't send me that message before, just happend what i first post in this post,

Is there any IRC where i can find fast-help too?
Obsdark is offline   Reply With Quote
Old 13th February 2014, 19:08   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
the error is pretty clear on what is going on. there is no config file which it can automatically find and you either need to make one or explicitly tell the DNAS _what_ config file to use (as per the docs).
DrO is offline   Reply With Quote
Old 13th February 2014, 19:40   #5
Obsdark
Member
 
Join Date: Jan 2011
Posts: 75
i try to do it with the setup.sh again.. but can't do it

Is it really necesary be a root to use shoutcast?, isn't that unsafe?
Obsdark is offline   Reply With Quote
Old 13th February 2014, 19:46   #6
DrO
 
Join Date: Sep 2003
Posts: 27,873
if you're having to do it as root then you've not got things setup correctly on the system you're using. the only possible reason to have to do it as root is to be able to run it directly on port 80 and even that can be resolved via other means (which are easily found and not really the intention of this help forum).

so if it was working then you must have been able to generate a config file and i'd suggest you try to find it (named sc_serv.conf by default). otherwise you need to ensure you're running the DNAS in a location which allows for it to save the files it needs to without root access (either doing it as a normal user or specifically creating a user with the required access).

either way, it sounds like most of the issues are stemming from you knowledge / experience with the OS you're trying to use and you probably need to re-consult documentation and guides relating to it to sort out those issues before trying to get a DNAS running.
DrO is offline   Reply With Quote
Old 13th February 2014, 21:48   #7
Obsdark
Member
 
Join Date: Jan 2011
Posts: 75


i really apreciate your faith on my skills but i just restart the process and works!

(no root btw) however... i saw very decidedly the icecast guys telling me than him's software must be runned as a root, i must say..., even when some other people strongly recomended not run it like root (thinking than i agreed)

icecast in fact is the one than still send me problems and distract me all this time thou

however, now than i fix my problem... (SHOUTcast) there is the last one still

the index.html works, the console run, but is not like the terminal can be used to anything else after it right? at least not that window.

Let me know if this is normal, otherwise i try to correct it

Thanks a lot for all!
Obsdark is offline   Reply With Quote
Old 13th February 2014, 22:12   #8
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally Posted by Obsdark View Post
the index.html works, the console run, but is not like the terminal can be used to anything else after it right? at least not that window.

Let me know if this is normal, otherwise i try to correct it
it is normal if not running it as a daemon process i.e. ./sc_serv daemon (the simplest way to run it in the background without linking to the console shell it was started with) or setting screenlog=0 in the config file and then doing ./sc_serv &
DrO is offline   Reply With Quote
Old 14th February 2014, 10:11   #9
aron9forever
Junior Member
 
Join Date: Jan 2014
Posts: 47
Quote:
Originally Posted by Obsdark View Post


i really apreciate your faith on my skills but i just restart the process and works!

(no root btw) however... i saw very decidedly the icecast guys telling me than him's software must be runned as a root, i must say..., even when some other people strongly recomended not run it like root (thinking than i agreed)

icecast in fact is the one than still send me problems and distract me all this time thou

however, now than i fix my problem... (SHOUTcast) there is the last one still

the index.html works, the console run, but is not like the terminal can be used to anything else after it right? at least not that window.

Let me know if this is normal, otherwise i try to correct it

Thanks a lot for all!

This is happening on centos to me too, starting sc_serv, the console doesn't show anything but opens. For me the simple solution is just closing the terminal and opening another instance, the sc_serv is working fine, been running non stop for a week now.

If you want to make sure the config you made is being loaded, use sc_serv correctly, run it by typing ./sc_serv sc_serv.conf or whatever the name of your config is, and it will force it to use that config file(you should really read the docs better)

You don't need root, you shouldn't use root, make sure that all the folders including the folders leading to your shoutcast path have chmod 777.

If you want the terminal to be usable after running sc, run it as a daemon(you got your answer above)
aron9forever is offline   Reply With Quote
Old 14th February 2014, 11:38   #10
Obsdark
Member
 
Join Date: Jan 2011
Posts: 75
I just fix some permissions and then, it's ready, thanks a lot for all your help, and i'm in fact running it now like a daemon.

And again

Thanks for all help
Obsdark is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump