Old 4th January 2010, 19:28   #1
praveen_recker
Junior Member
 
Join Date: Jan 2010
Location: INDIA
Posts: 3
Opening .avi file is crashing Winamp 5.571

Created a file with name, aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa.avi

Opening file with this name crashes Winamp v5.571

I tested this on Windows7 Ultimate.

Add .avi extension to the attached file and open with Winamp

Best Regards,
Praveen Darshanam
praveen_recker is offline   Reply With Quote
Old 5th January 2010, 09:42   #2
mhanor
Junior Member
 
Join Date: Sep 2005
Posts: 28
I can reproduce it on XP
an empty "a.avi" file is enough
it crashes in the in_avi plugin
mhanor is offline   Reply With Quote
Old 5th January 2010, 10:40   #3
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,866
It crashes explorer.exe for me...
Though I think that was the explorer preview using ffdshow to blame.

But yeah, we'll need to fix 0 byte AVI files crashing.
Is it just AVI, or are any other formats affected, eg. MKV or MP4/M4V?

I wasn't sure at first if it was the 0 byte factor or the filename length to blame... or both.
DJ Egg is offline   Reply With Quote
Old 5th January 2010, 10:51   #4
mhanor
Junior Member
 
Join Date: Sep 2005
Posts: 28
I can't reproduce this with other media file name extensions

LE: I've uninstalled ffdshow, it still crashes
mhanor is offline   Reply With Quote
Old 10th January 2010, 16:13   #5
praveen_recker
Junior Member
 
Join Date: Jan 2010
Location: INDIA
Posts: 3
not long file name but zero avi file

Hello Friends,

Crash is not due to long avi file name...the CRASH is due to zero size avi file.
I tried few other extensions but didn't observe this bug.

I wanted to directly report to Winamp guys but couldn't get any Email-ID so ended up in posting the forum.

Best Regards,
Praveen Darshanam
praveen_recker is offline   Reply With Quote
Old 10th January 2010, 16:34   #6
praveen_recker
Junior Member
 
Join Date: Jan 2010
Location: INDIA
Posts: 3
Hi DJ Egg.....Can I make it public, like disclosing at securityfocus.com and obtain CVE ID from MITRE or wait until the bug is fixed.
praveen_recker is offline   Reply With Quote
Old 10th January 2010, 20:04   #7
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,866
This should fix it....

Nullsoft AVI Demuxer v0.3 [in_avi.dll]
DJ Egg is offline   Reply With Quote
Old 23rd July 2012, 22:21   #8
AdmiralSirJohn
Junior Member
 
Join Date: Jul 2007
Posts: 4
I'm having the same problem, but it happens with ANY avi file, regardless of name or size.

They play fine in all other players, but crash Winamp on open.

I have the latest codecs and Winamp version.

Everything worked until a week or so ago...
AdmiralSirJohn is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump