Old 16th August 2008, 11:27   #1
knutblub
Junior Member
 
Join Date: Aug 2008
Posts: 5
Wrong VBR bitrate reported for some LAME mp3 files

For some LAME encoded mp3 files I see a wrong VBR bitrate reported in the file info dialog. Instead of e.g. 220kbps, I see values like 32kbps or 128kbps (as if it's a CBR file).

Programs like Mp3tag and foobar2000 show the right bitrate.

Attached a zipped test mp3 of a few seconds that shows this problem. In Winamp the bitrate shows 128kbps, in other programs 148kbps.

Tested with latest Winamp version 5.541, on Windows XP.
knutblub is offline   Reply With Quote
Old 16th August 2008, 11:29   #2
knutblub
Junior Member
 
Join Date: Aug 2008
Posts: 5
I thought I did attach the file... second try.
Attached Files
File Type: 7z test.7z (101.9 KB, 300 views)
knutblub is offline   Reply With Quote
Old 4th October 2008, 17:36   #3
knutblub
Junior Member
 
Join Date: Aug 2008
Posts: 5
It's been a while since I asked this question...
Is there anybody who can at least confirm that this problem exists?
knutblub is offline   Reply With Quote
Old 27th October 2008, 03:36   #4
drakestail
Junior Member
 
Join Date: Oct 2008
Posts: 1
I'm having the same issue. Some VBR mp3 songs report the wrong bitrate in the Media Library and sometimes even when using the file info option.

I'm still looking through the forum to see if this has already been answered, but bumped into your post first and wanted to tell you: you're not alone
drakestail is offline   Reply With Quote
Old 28th October 2008, 12:10   #5
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
Looks as if Winamp 'File Info' is just showing the bitrate for the first block in this particular VBR file.
Probably just a non-standard/old style header.

Run it through VBRFix (http://www.willwap.co.uk/Programs/vbrfix.php), should sort it out.

UJ
ujay is offline   Reply With Quote
Old 1st November 2008, 13:23   #6
knutblub
Junior Member
 
Join Date: Aug 2008
Posts: 5
Thanks for the VBRFix suggestion, but unfortunately it does not solve the problem... Still the same wrong bitrate in the file info dialog.

I agree that this has probably to do with a strange VBR header, but still, other programs show the bitrate correctly!
knutblub is offline   Reply With Quote
Old 1st November 2008, 16:46   #7
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
Hi knutblub

Just taken a look at the file and VBRFix does it for me.

I'm wondering which version of VBRFix you found. There is a cross platform version and a Windows only version, I've used the Windows only one (Zip attached).

There is a Winamp setting that shows individual block rates in the Main window info area, but File Info should show the correct average rate regardless.
Prefs > Input plugins > Nullsoft MPEG audio decoder > Decoder tab > 'Show average bitrate'

UJ
Attached Files
File Type: zip vbrfixv5-3-15.zip (71.5 KB, 358 views)
ujay is offline   Reply With Quote
Old 2nd November 2008, 14:09   #8
knutblub
Junior Member
 
Join Date: Aug 2008
Posts: 5
ujay, thanks! The version you attached works. The VBRfix website said that the cross-platform version was the preferred version so I only tried that one...

By the way, the setting you mention always shows the correct average in the main window, also for unfixed files. So I still think that the wrong average in the file info dialog is a (small) bug in Winamp. But at least I have a workaround now!
knutblub is offline   Reply With Quote
Old 3rd November 2008, 09:51   #9
elfin
Junior Member
 
Join Date: Jan 2006
Location: Russia, Moscow
Posts: 15
Quote:
Originally posted by knutblub
In Winamp the bitrate shows 128kbps, in other programs 148kbps.
Heh... I'm curious to test yor sample file. So Winamp 5.35 shows me 174kbit (VBR) in the "File info box", but during playback it's show 150 VBR in "Main Window".
elfin is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump