Old 28th July 2007, 00:46   #1
caliphornia
Junior Member
 
Join Date: Jul 2007
Posts: 4
Why Do my MKV Movies play Choppy in Winamp?

hey guys,

so i downloaded an MKV codec pack today, and i'm watching a movie in high definition (it's an mkv file) it runs perfectly smooth in all media players except for winamp. winamp makes it have a very low framerate for some reason. does anyone know what the problem is?


btw, it's not a problem with my PC (i have a high end PC) it's a problem with winamp... the movie runs smooth in WMP and all other players and they're all using the same codec pack...
caliphornia is offline   Reply With Quote
Old 28th July 2007, 06:42   #2
Rocker
Hiding in plain sight (mod)
 
Join Date: Jun 2000
Location: Melbourne, Australia
Posts: 9,910
what mkv codec pack?

ffdshow with haalis matroska splitter?
Rocker is offline   Reply With Quote
Old 28th July 2007, 08:01   #3
caliphornia
Junior Member
 
Join Date: Jul 2007
Posts: 4
yea those are the ones i have
caliphornia is offline   Reply With Quote
Old 12th September 2007, 06:56   #4
VORTIA
Junior Member
 
Join Date: Sep 2007
Posts: 9
Was a solution ever worked out for this problem? I am experiencing the same problem. I'm running the CCCP Code Pack and the Haali Splitter and .mkv files sieze up during playback.
VORTIA is offline   Reply With Quote
Old 4th March 2008, 09:03   #5
bemymonkey
Senior Member
 
bemymonkey's Avatar
 
Join Date: Dec 2004
Location: Germany
Posts: 461
Sorry to bring this back from the dead, but I'm having pretty much the same problem - anyone found a solution yet? The CCCP runs pretty well in progs like Media Player Classic, but somehow Winamp doesn't seem to like hi-res mkv's...

I've noticed that Winamp's CPU usage is lower than the others' during playback - maybe that has something to do with is? (MPC pegs one of my cores at 100% most of the time without stuttering one bit, whereas Winamp hovers around 80% on that core, and the video pretty much grinds to a halt if the usage hits 100%)...

Any ideas?

Weeeeeeeeeeee
bemymonkey is offline   Reply With Quote
Old 4th July 2008, 18:26   #6
Sjakko
Junior Member
 
Join Date: Aug 2007
Location: Netherlands
Posts: 13
I also have this problem (low FPS and very slow and choppy playback), but today i found a workaround! The 5.1 audio stream seems to be the problem. The 5.1 videos i tried all have AC3 audio. AC3Filter is my default AC3 decoder.

The steps to "fix" it:
-Download Directshow Filter Manager* and run it.
-Select AC3Filter and press the Show filter properties button.
-Press the Filter settings button.
-Change the Output from AS IS(no change) to for example 2/0 - stereo or any other.
-Apply the changes and play a video with a 5.1 audio stream.

The video now plays just as smooth as all the others, with normal FPS and no choppy playback. When i use the same splitter+decoders in another player (i tried The KMPlayer) there are no problems. My pc is fast enough (core2duo E8400 cpu). Tried avi and mkv videos.

Can someone tell me if this is a Winamp bug? Please reply so i can report it.

* http://www.videohelp.com/tools/DirectShow_Filter_Manager
Sjakko is offline   Reply With Quote
Old 16th March 2009, 19:52   #7
alabama26
Junior Member
 
Join Date: Mar 2009
Posts: 1
I am having the same problem.
Your URL is blocked by the forum. We can't see it.
alabama26 is offline   Reply With Quote
Old 16th March 2009, 20:49   #8
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,980
I've edited the url into Sjakko's post, though you don't need to install the DirectShow Filter Manager.
Just go to: Start -> Programs -> AC3Filter -> AC3Filter config
and change the Output there.

I already had mine set to "3/2+SW 5.1 channel" & "PCM 24bit"
and have never experienced any problems
(though you can try "2/0 stereo" & "PCM 16-bit" or whatever if you want)

Alternatively, you could use latest FFDShow for AC3 instead...
Start -> Programs -> ffdshow -> Audio decoder config -> Codecs page,
set AC3 to Liba52
(probably requires you to disable use of AC3Filter first in AC3Filter -> config -> System tab)
DJ Egg is offline   Reply With Quote
Old 4th April 2009, 21:27   #9
theloonster
Junior Member
 
Join Date: Aug 2008
Posts: 3
Quote:
Originally posted by DJ Egg
I've edited the url into Sjakko's post, though you don't need to install the DirectShow Filter Manager.
Just go to: Start -> Programs -> AC3Filter -> AC3Filter config
and change the Output there.

I already had mine set to "3/2+SW 5.1 channel" & "PCM 24bit"
and have never experienced any problems
(though you can try "2/0 stereo" & "PCM 16-bit" or whatever if you want)

Alternatively, you could use latest FFDShow for AC3 instead...
Start -> Programs -> ffdshow -> Audio decoder config -> Codecs page,
set AC3 to Liba52
(probably requires you to disable use of AC3Filter first in AC3Filter -> config -> System tab)
I too an having the juddering/choppy problem. I have tried all the above and still the problem remains..

Has anyone tried the comments above?? Has it worked for you??? Does anyone recommend i try a different way??

I have ffdshow and on the above advice, ac3filter too...
Would also note that it works ok in windows media plopper and that the audio is fine, its just the video thats choppy


Thanks
theloonster is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump