Old 13th November 2013, 17:33   #1
SomeJ
Junior Member
 
Join Date: Nov 2013
Posts: 4
Current Song Title not received by v1 server from v2

So I have been working on upgrading out servers this week and ran into a snag.

I setup a new root server using DNAS v2.2. We also have a lot of relays out there that are run by other parties using varying DNAS versions. We want to keep support for these relays so we have done everything we can to keep support for the old v1 DNAS. We are starting up a dedicated v2.2 instance for each stream so we can continue to have a dedicated port for each stream to facilitate this.

So far in testing this has worked well and I have been able to get v1 servers to connect to our new root v2 server and users can pull functional audio streams. However, it appears the v1 server is not receiving the current song title from the v2 server. Or the v1 server does not like something from the v2 server. It appears that all other meta data is passing, just the current song title is blank.

Source is Winamp v5.65 running the Nullsoft DSP v2.3.3
Root server is Shoutcast v2.2.0.107
Legacy relay servers are mostly v1.9.8 and v1.9.7

I have not gone so far as getting a packet capture yet, as I first wanted to put a feeler out there on if anyone knew anything off the top of their head on this issue.

Which logs and configs from me would help with trouble shooting this?

Thanks much!
Jason
SomeJ is offline   Reply With Quote
Old 13th November 2013, 17:51   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
only obvious thing i can think off is that the useicy option is messing up things (as there's at least one known bug where that option needs to be inverted to allow titles to work so might be that i.e. setting useicy=0 may resolve it).

if not, would suggest seeing if it happens with another v2.2 DNAS pulling from the master and checking the logs on any of the DNAS for title update messages.
DrO is offline   Reply With Quote
Old 13th November 2013, 18:04   #3
SomeJ
Junior Member
 
Join Date: Nov 2013
Posts: 4
Awesome, that worked!

Thanks for the quick reply DrO!

-J
SomeJ is offline   Reply With Quote
Old 13th November 2013, 18:07   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
rightio, you'll need to remember to revert that when the v2.2.1 update is released (don't have an eta other than it's underway but other projects are getting in the way of fully working on that release at the moment).

also out of curiosity, why not use v2.2 DNAS on everything?
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump