Prev Previous Post   Next Post Next
Old 5th July 2014, 14:07   #1
EduardoWeber
Junior Member
 
Join Date: Jul 2014
Posts: 2
Sc_trans dj setup problem

I'm going to use a custom auto dj software, for this, I need to connect it to the stream. And I'll have live streams too, I would disconnect the autodj from the sc_trans and then connect the dj.
I'm trying to connect to the transcoder with a Shoutcast v1, but I get a [djProtocolShoutcast] Login denied from dj:123
sc_trans.conf
code:
;; VU Images
vuimagedirectory=C:\Documents and Settings\nradisch\My Documents\programming\shoutcast\current\sc_trans\vuimages\

;; ENCODER OPTIONS
encoder=aacp
bitrate=96000
samplerate=44100
channels=2

;;; NETWORK OPTIONS
outprotocol=1
serverip=127.0.0.1
serverport=8000
password=**


;;;; LOGGING OPTIONS:
;where does the log file go
logfile=C:\Arquivos de programas\SHOUTcast\sc_trans.log
; 1 to do screen logging else 0
screenlog=1

;;;;;; METADATA CONTROL
; my stream name
streamtitle=Neil Test2
; url related to my stream
streamurl=http://foobar.com
; my genre
genre=classical
; other assorted stuff
;aim=myaimaddr
;irc=myirc
;icq=myicq
; register with yp
public=1

;;;; PLAYLIST CONTROL
; your playlist
playlistfile=C:\Documents and Settings\nradisch\My Documents\programming\shoutcast\current\sc_trans\playlist_win32.lst
; by default we shuffle the playlist. Lets turn that off
shuffle = 0
; set our crossfade time to 2 seconds. zero means no xfade
xfade=2
; file must be at least 20 seconds or we don't crossfade
xfadethreshold=20
; drop folder for priority playlists
playlists=c:\sc_trans\playlists\
; where finished priority playlists get copied
archive=c:\sc_trans\playlists\archive\

;;; LIVE CAPTURE:
; don't capture
capture=0
; set capture parameters
;capturedevice=Sound Blaster
;captureinput=Line-In
;capturesamplerate=44100
;capturechannels=2


;;;; DJ SUPPORT:
; dj listen port
djport=9000
; dj password
djpassword=123
; idle time until auto-dump
autodumpsourcetime=30
; record dj broadcasts here
djbroadcasts=c:\sc_trans\recorded\



;; REPLAY GAIN CONTROL:
applyreplaygain=0
calculatereplaygain=0

;;; OTHER:
adminport=5555
adminuser=admin
adminpassword=**



sc_trans.log
code:
2014-07-05 10:41:32 I msg:<***> Logger startup
2014-07-05 10:41:32 I msg:<***> version 0.2.0.0 build 0.0.39.0
2014-07-05 10:41:32 D msg:<***>
2014-07-05 10:41:32 I msg:TimeMultiplier = 1 TimeShift = 0
2014-07-05 10:41:32 I msg:[VUPush] 0 VU images loaded
2014-07-05 10:41:32 I msg:[VUPush] 0 VU images loaded
2014-07-05 10:41:32 I msg:[playlistMgr] playlist load from file C:\Documents and Settings\nradisch\My Documents\programming\shoutcast\current\sc_trans\playlist_win32.lst
2014-07-05 10:41:32 E msg:[playlistMgr] Could not activate playlist playlist_win32 because No playlist file found C:\Documents and Settings\nradisch\My Documents\programming\shoutcast\current\sc_trans\playlist_win32.lst
2014-07-05 10:41:32 I msg:*******************************************************************************
2014-07-05 10:41:32 I msg:** TRANScast Distributed Network Audio Content Provider
2014-07-05 10:41:32 I msg:** Copyright (C) 2000 Nullsoft, Inc. All Rights Reserved.
2014-07-05 10:41:32 I msg:** Use "sc_trans filename.conf" to specify a config file.
2014-07-05 10:41:32 I msg:*******************************************************************************
2014-07-05 10:41:32 I msg:[TRANSCast] DNAS/win32 v 0.2.0.0 b 0.0.39.0 (Feb 22 2010) starting up...
2014-07-05 10:41:32 I msg:[MAIN] PID: 1500
2014-07-05 10:41:32 I msg:[MAIN] Loaded config from sc_trans.conf
2014-07-05 10:41:32 I msg:[MAIN] Streaming thread starting
2014-07-05 10:41:32 I msg:[resampler] deactivated 44100/2 == 44100/2
2014-07-05 10:41:32 I msg:[sourceAndEndpointManager] Encoder thread 0 starting
2014-07-05 10:41:32 I msg:[sourceRelay] Thread starting
2014-07-05 10:41:32 I msg:[sourceAndEndpointManager] broadcast thread 0 starting
2014-07-05 10:41:32 I msg:[MAIN] Playlist decoder thread starting
2014-07-05 10:41:32 I msg:[rgCalc] thread running
2014-07-05 10:41:32 I msg:[microServer] Listening for connection on port 9001
2014-07-05 10:41:32 I msg:[STREAM] 26311 giving replay gain calculator a head start
2014-07-05 10:41:32 I msg:[decode] giving replay gain calculator a head start
2014-07-05 10:41:32 I msg:[decode] begin decoding
2014-07-05 10:41:32 I msg:[STREAM] 26311 running
2014-07-05 10:41:32 I msg:[STREAM] 26311 Creating stream socket
2014-07-05 10:41:32 I msg:[STREAM] 26311 Connected to host server
2014-07-05 10:41:32 I msg:[AAC] encoder config: sample rate=44100 channelMode=Stereo sbrMode=Normal bitRate=96000 signalType=Default
2014-07-05 10:41:32 I msg:[AAC] encoder stream type: bsFormat=ADTS bsConfig=adifConfig=bOriginalCopyBit=0 bHomeBit=0 adtsConfig=bWriteAdtsCRCheck=0 bOriginalCopyBit=0 bHomeBit=0 numSubFrames=1 bMp2AdtsPce=0 sendAdtsPceInterval=1 sendAdtsPceOffset=0 latmLoasConfig=bSendMuxConfigInBand=1 bWriteCRCheck=0 numSubFrames=1 sendConfigDataInterval=1 sendConfigDataOffset=0 ascConfig=signallingMode=Implicit bWriteSbrCrc=0 sendSbrHeaderInterval=1 sendSbrHeaderOffset=0
2014-07-05 10:41:32 I msg:[MAIN] Broadcast Receiver thread starting
2014-07-05 10:41:32 I msg:[AAC] encoder configuration: qualityMode=Highest allowNarrowing=1 allowTns=1 allowPns=0 requestedBandwidth=0 codecDelay=4347 effectiveBandwidth=20327
2014-07-05 10:41:32 I msg:[AAC] aac setup complete
2014-07-05 10:41:32 I msg:[STREAM] 26311 Host server gave success (OK2)
2014-07-05 10:41:32 I msg:[STREAM] 26311 Stream to 127.0.0.1 established
2014-07-05 10:41:32 I msg:[STREAM] 26311 Sending stream information
2014-07-05 10:41:34 W msg:[decode] Playlist is empty
2014-07-05 10:41:36 W msg:[decode] Playlist is empty
2014-07-05 10:41:38 W msg:[decode] Playlist is empty
2014-07-05 10:41:38 W msg:[djProtocolShoutcast] Login denied from dj:123
2014-07-05 10:41:40 W msg:[decode] Playlist is empty
2014-07-05 10:41:42 W msg:[decode] Playlist is empty
2014-07-05 10:41:44 W msg:[decode] Playlist is empty
2014-07-05 10:41:45 I msg:[MAIN] Exiting loop
2014-07-05 10:41:45 I msg:[AAC] Exiting encoder thread
2014-07-05 10:41:45 I msg:[rgCalc] thread exiting
2014-07-05 10:41:45 W msg:[decode] Playlist is empty
2014-07-05 10:41:45 E msg:[decode] Playlist has run dry
2014-07-05 10:41:45 I msg:[decode] Exiting decoder thread
2014-07-05 10:41:45 I msg:[resampler] tIn=0 tOut=0 bIn=0 bOut=0
2014-07-05 10:41:45 I msg:[crossfader] in=0 out=0
2014-07-05 10:41:45 I msg:<***> Logger shutdown

EduardoWeber is offline   Reply With Quote
 
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Tags
problem, sc_trans, transcoder

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump