Old 13th March 2012, 06:34   #1
DJ Iboga
Junior Member
 
Join Date: Mar 2012
Posts: 4
updated to DNAS build 29, now causes crash at start up

ok so, i had build 19 up and running, but i couldnt get an authash, after poking around, i discovered i needed an update, so i uninstalled, and installed build 29,

1. tried to run wit the CONF file from build 19, told me log file path doesnt exist, and aborted

2. i then updated the log file path, then passed the CONF file again, this time it just crashed and windows gave me this nugget:


Problem signature:
Problem Event Name: APPCRASH
Application Name: sc_serv.exe
Application Version: 29.7.31.2011
Application Timestamp: 4e355891
Fault Module Name: sc_serv.exe
Fault Module Version: 29.7.31.2011
Fault Module Timestamp: 4e355891
Exception Code: c0000005
Exception Offset: 00003ed3
OS Version: 6.0.6002.2.2.0.256.1
Locale ID: 1033
Additional Information 1: 4ee5
Additional Information 2: 3350e07c08d531f9783b4f1d071594d6
Additional Information 3: 4f97
Additional Information 4: 9a3b5b9026f4c019b810d4788d5589ec

and here is the CONF file contents:
;DNAS configuration file
;Made with the SHOUTcast 2 Configuration Builder

password= WITHHELD
adminpassword= WITHHELD!
portbase=8000
requirestreamconfigs=1
yp2=1
log=1
screenlog=1
logclients=1
logfile=c:/program files/shoutcast/logs/
w3cenable=1
w3clog=sc_w3c.log
publicserver=always
banfile=sc_serv.ban
ripfile=sc_serv.rip
riponly=0
savebanlistonexit=1
saveriplistonexit=1
maxuser=32
listenertime=0

streamid=1

can some perhaps enlighten me on the goings on here?
DJ Iboga is offline   Reply With Quote
Old 13th March 2012, 06:42   #2
DJ Iboga
Junior Member
 
Join Date: Mar 2012
Posts: 4
nevermind, disabled logging, worked right away, all is good
DJ Iboga is offline   Reply With Quote
Old 13th March 2012, 07:16   #3
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,013
Send a message via Skype™ to thinktink
Note to DrO:
Retool config builder to set path delimiters to appropriate character automatically for the OS build for.
thinktink is offline   Reply With Quote
Old 13th March 2012, 09:42   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
DJ Iboga: from what you've posted, i assume you're using Vista with UAC enabled? if so then there is a known issue where the DNAS fails to update the config file path if it's a) not able to use the file specified and b) if it's already using %temp%\sc_serv.log and it incorrectly tries to re-create it.

i say that as you're showing as using c:/program files/shoutcast/logs/ which isn't valid and needs to be more like c:/program files/shoutcast/logs/sc_serv.log (note the underlined part) and most likely you don't have write permissions for that folder anyway. as such it's in the trying to use %temp%\sc_serv.log twice and crashes.

is fixed internally, but the simplest way is to either a) move the SHOUTcast folder out of the program files directory to somewhere without UAC write permission issues or b) just change the logfile entry to specify a folder and filename which can be freely written to or just remove it and allow it to just use the default of %temp%\sc_serv.log.

thinktink: have made a note though as the path handling for the next drop (if it ever makes it out) improves the path conversion between the OS variants, i'm not sure if there is much point. plus the more native setup mode will mean the DNAS creates the correct path style at the time of creation (which is all defaulted to work as relative paths to the install folder anyway).

-daz
DrO is offline   Reply With Quote
Old 13th March 2012, 15:12   #5
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,013
Send a message via Skype™ to thinktink
Quote:
Originally Posted by DrO View Post
...thinktink: have made a note though as the path handling for the next drop (if it ever makes it out) improves the path conversion between the OS variants, i'm not sure if there is much point. plus the more native setup mode will mean the DNAS creates the correct path style at the time of creation (which is all defaulted to work as relative paths to the install folder anyway)...
I guess that would work as well.
thinktink is offline   Reply With Quote
Old 13th March 2012, 18:18   #6
DJ Iboga
Junior Member
 
Join Date: Mar 2012
Posts: 4
if that was the case, wouldnt running it from the command-line in root mode fix it, which it doesn't, i disabled logging because im only gonna be up for 2-3 hours, friday and saturday, while im spinning hard drive platters, and dont really foresee using it
DJ Iboga is offline   Reply With Quote
Old 13th March 2012, 18:41   #7
DrO
 
Join Date: Sep 2003
Posts: 27,873
if the config file is explicitly passed at the start and you run with admin access (so you can write to that folder) then there won't be issues. but your config option for logfile was invalid so even with admin access it is still going to hit the re-use of the default log file issue (which is user-account independent).

really you either need to just remove the logfile entry or fix it to point to a filename which can be created by the DNAS. that way you then shouldn't need to run it with admin access at all.

-daz
DrO is offline   Reply With Quote
Old 13th March 2012, 19:20   #8
DJ Iboga
Junior Member
 
Join Date: Mar 2012
Posts: 4
ok, well thats fixed now, but now YP2 cant see the server, ive got the port opened, maybe this will help someone better with networks then me see the problem,

i have changed the portbase to 8024

DJ Iboga is offline   Reply With Quote
Old 13th March 2012, 20:57   #9
DrO
 
Join Date: Sep 2003
Posts: 27,873
if the DNAS is running on 8024 then the private port also needs to be set as 8024. and if you wanted remote sources using the v1 protocol to connect to your DNAS, then 8025 would also need to be opened i.e. as it's own rule but you probably won't need to do that.

-daz
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump