Old 28th January 2012, 18:17   #1
beattie282
Junior Member
 
Join Date: Jan 2012
Posts: 3
Sambrodcaster wont connect

I have got the server running and i can listen to the defult trans

but for some reason no matter what i try i cannot login via sam

i have tryed many passwords, i have set up the auth as far as i kno it seems to have added it into the files.

all i want it to stream using sam but it wont let me!!!!!!!
beattie282 is offline   Reply With Quote
Old 28th January 2012, 19:52   #2
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,013
Send a message via Skype™ to thinktink
What version of the SHOUTcast tools are you using?

Are you using the Transcoder?

Which operating system and version are you running the SHOUTcast tools on?

Can you post some logs from your SHOUTcast tools?
thinktink is offline   Reply With Quote
Old 28th January 2012, 20:27   #3
beattie282
Junior Member
 
Join Date: Jan 2012
Posts: 3
since i posted this i have managed to get it working via the winamp plugin but still sam will still not connect i mean i can use winamp i suppose.

shoutcast 2.0 the newest one according to the site
erm the server is on linux CentOS 6
am on win 7

it gives me this in terminal

2012-01-28 19:26:22 I msg:[MAIN] Logger updating log file to use
2012-01-28 19:26:22 I msg:[MAIN] Loaded config from ./sc_serv_simple.conf
2012-01-28 19:26:22 I msg:[MAIN] Calculated CPU count is 2
2012-01-28 19:26:22 I msg:[MAIN] Starting 2 network threads
2012-01-28 19:26:22 I msg:[MICROSERVER] Listening for connection on port 8000
2012-01-28 19:26:22 I msg:[MICROSERVER] Listening for connection on port 8001
2012-01-28 19:26:28 I msg:[SRC 94.172.226.199:54912] SHOUTcast 2 source connection.
2012-01-28 19:26:28 E msg:[SRC 94.172.226.199:54912] Bad Stream ID (0). Stream ID cannot be below 1 or above 2147483647.

like i say the winamp plugin is working for now but it would be nice to get sam working thanks for any help m8
beattie282 is offline   Reply With Quote
Old 28th January 2012, 22:03   #4
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,013
Send a message via Skype™ to thinktink
Does the SAM broadcaster connection settings have a v2 encoder mode? I'm not familiar with SAM but according to your DNAS log SAM is not sending the right info (or the DNAS is interpreting it wrong.) If it does have a v2 mode double check your Stream ID in the encoder settings of SAM. It should start with 1, not 0.
thinktink is offline   Reply With Quote
Old 28th January 2012, 22:36   #5
beattie282
Junior Member
 
Join Date: Jan 2012
Posts: 3
thanks! ive got it working now there was a box called SID i dident know what it was, i put that to 1 and it worked but now i dont know what to do with my key i bought to encode mp3 lol ill leave that till tomorrow

thanks again
beattie282 is offline   Reply With Quote
Old 29th January 2012, 04:17   #6
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,013
Send a message via Skype™ to thinktink
(As of this post) the mp3 key is only for MP3 encoding for the Transcoder. Hold on to it. You might want to use the Transcoder some day to manage DJs.
thinktink is offline   Reply With Quote
Old 29th January 2012, 22:21   #7
DrO
 
Join Date: Sep 2003
Posts: 27,873
i have let Spacial know about the issue previously during testing before the v2 support came out in their tools but seems this issue is still present - will have to give them a nudge again about this. though i really had hoped that error message was obvious for it to be worked out without having to post on here *shrugs*

-daz
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump