Old 28th January 2003, 01:40   #1
gizmogurl
Junior Member
 
Join Date: Aug 2002
Posts: 12
Echo?

This is incredibly frustrating. For some reason, after an idiot sister of mine used Winamp, I started getting an echo-type effect everytime I use this program. Does anyone know how to get rid of it?
gizmogurl is offline   Reply With Quote
Old 28th January 2003, 02:57   #2
JonnyMac
Moderator
 
JonnyMac's Avatar
 
Join Date: Dec 2000
Posts: 14,385
She may have installed a DSP plug-in.
In Winamp, Ctrl+P (for Preferences) > Plug-ins > DSP/Effect > if any are there select (none).

Please do not PM me for tech support. Any request for tech support through PM will be ignored.
Read the Stickies
---> | | | | <--- Knowledge is power
JonnyMac is offline   Reply With Quote
Old 28th January 2003, 03:57   #3
gizmogurl
Junior Member
 
Join Date: Aug 2002
Posts: 12
Quote:
Originally posted by JonnyMac
She may have installed a DSP plug-in.
In Winamp, Ctrl+P (for Preferences) > Plug-ins > DSP/Effect > if any are there select (none).
I already checked, and there is none installed.

Could it be a certain problem with an input/output plugin?
gizmogurl is offline   Reply With Quote
Old 28th January 2003, 04:48   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,091
Well, which Output plugin is currently selected and active?
Prefs -> Plugins -> Output
The hi-lighted one is the active one.
This should be one of WaveOut or DirectSound Output.
These are the two default Output plugins which can be used for normal playback.
Neither of these include any options to create echo/reverb/chorus effects.

What file formats are you playing?
mp3, wav, midi, mod, ogg, Audio CD, other?
Are all types affected, or just the one?
If all, then it can't be an input plugin setting to blame.

What is your soundcard?
eg. if it's a Soundblaster Live or Audigy card, you will probably also have an EAX Control Panel where you can enable global environmental effects. Look in here and set the Effects to None, or Room, etc.
DJ Egg is online now   Reply With Quote
Old 28th January 2003, 05:02   #5
gizmogurl
Junior Member
 
Join Date: Aug 2002
Posts: 12
Quote:
Originally posted by DJEgg
Well, which Output plugin is currently selected and active?
Prefs -> Plugins -> Output
The hi-lighted one is the active one.
This should be one of WaveOut or DirectSound Output.
These are the two default Output plugins which can be used for normal playback.
Neither of these include any options to create echo/reverb/chorus effects.
My output plugin is the DirectSound output ver.2.21 ... which is odd, because it's selected and this echo thing STILL occurs.



Quote:
Originally posted by DJEgg

What file formats are you playing?
mp3, wav, midi, mod, ogg, Audio CD, other?
Are all types affected, or just the one?
If all, then it can't be an input plugin setting to blame.
I'm mostly playing MP3s, but it does the same thing to audio CDs, midis and ogg/other files.


Quote:
Originally posted by DJEgg

What is your soundcard?
It's SiS 7018 (? I think..)
gizmogurl is offline   Reply With Quote
Old 28th January 2003, 06:35   #6
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,091
Yes, it is very odd . . .

Ok, looks like you've got an on-board sound chip (as opposed to a pci soundcard)

If it affects all filetypes, and you've not got any DSP/FX plugins installed/enabled, then it's highly likely that the problem is coming from a source outside of Winamp... this is assuming that nothing's gone a bit funky with the Winamp EQ. Is the EQ window open and switched "on" by any chance? Still, the EQ shouldn't cause echo/reverb effects, not under normal circumstances anyway.

This could be proved further if the same thing happens when you play any system sounds or music in another player.

Is there any Control Panel anywhere for your sound?
If not one specific to the chip, then maybe it's added a page/tab/option somewhere to the default Windows Audio/Sound/Multimedia Control Panel (the name of this Control Panel varies under different Windows Operating Systems, which was one detail I forgot to ask you for, oops)
If you can find anything relating to Echo/reverb/3d-sound/tunnel-effects/etc in here, disable it.

There's also the chance that it adds an option to the Windows Volume Control Mixer.

Double click the little yellow speaker icon in your system tray to open up the mixer.

Go to: "Options" menu
If it's available & not checkmarked, checkmark "Advanced Controls"
Now click the "Advanced" button below.
If there's any options enabled in there for 3D Sound, or reverb/chorus/etc, disable them.
DJ Egg is online now   Reply With Quote
Old 28th January 2003, 15:12   #7
gizmogurl
Junior Member
 
Join Date: Aug 2002
Posts: 12
Quote:
Originally posted by DJEgg

Go to: "Options" menu
If it's available & not checkmarked, checkmark "Advanced Controls"
Now click the "Advanced" button below.
If there's any options enabled in there for 3D Sound, or reverb/chorus/etc, disable them.
This is frustrating..
I did exactly that and it didn't help. There's still the echo, only the 3D effect stopped.
gizmogurl is offline   Reply With Quote
Old 28th January 2003, 15:58   #8
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 36,091
Ok, does the echo effect occur when you play your music through a different player, eg. Windows Media Player? Or is it only with Winamp?

I still don't think that it's a setting in Winamp to blame, because there's no universal setting for each individual input plugin. MP3's are controlled by in_mp3.dll, audio cd by in_cdda.dll, midi by in_midi.dll, etc

You can try clicking the "Reset All" button in DirectSound Output config to restore all the default settings, but I doubt if this is the cause . . .

You could also post a list of all the .DLL files in your Winamp\Plugins folder, just so we can confirm that there are definitely no gen or dsp/fx plugins installed.

And there's no EAX/FX control panel for your sound anywhere?

I don't suppose you can ask the person responsible to see if they can remember exactly what it was that they did?
DJ Egg is online now   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump