Old 14th July 2012, 12:12   #1
DJBBTONE
Junior Member
 
Join Date: Jul 2012
Posts: 4
Shotcast 2 + sc_trans probleme

Hello Community, after weeks of looking and trying I give it to me now, and turn here to the forum I will gladly cast the shot to run server-2 and sc_trans only bring me down I do not get it. While I get things running at the start and they happen but do nothing

Here is my configuration
Shoutcast 2
Quote:
;DNAS configuration file
;Made with the SHOUTcast 2 Configuration Builder

yp1debug=1
yp2debug=1
shoutcastsourcedebug=1
uvox2sourcedebug=1
shoutcast1clientdebug=1
shoutcast2clientdebug=1
relayshoutcastdebug=1
relayuvoxdebug=1
relaydebug=1
streamdatadebug=1
httpstyledebug=1
statsdebug=1
microserverdebug=1
threadrunnerdebug=1
rtmpclientdebug=1
webclientdebug=1
password=test123
adminpassword=test1234
requirestreamconfigs=1
logfile=C:\SHOUTcast\sc_serv.log
w3clog=C:\SHOUTcast\sc_w3c.log
banfile=C:\SHOUTcast\sc_serv.ban
ripfile=C:\SHOUTcast\sc_serv.rip
maxuser=10

streamid=1
streampath=1
streammaxuser=10
streamauthhash=1234567890
streampassword=test123
streamadminpassword=test1234
Sc_Trans
Quote:
;Transcoder configuration file
;Made with the SHOUTcast 2 Configuration Builder

shuffledebug=1
shoutcastdebug=1
uvoxdebug=1
gaindebug=1
playlistdebug=1
mp3encdebug=1
mp3decdebug=1
resamplerdebug=1
rgcalcdebug=1
apidebug=1
calendardebug=0
capturedebug=0
djdebug=1
flashpolicyserverdebug=1
fileconverterdebug=1
sourcerelaydebug=1
sourceandendpointmanagerdebug=1
streamtitle=Unnamed Server
streamurl=http://localhost
genre=Misc
adminport=8002
adminpassword=test1234
adminuser=admin
inheritconfig=C:\SHOUTcast\sc_serv.conf
unlockkeyname=**** *******
unlockkeycode=*****-*****-*****-*****
logfile=C:\SHOUTcast\adj\sc_trans.log
playlistfile=C:\SHOUTcast\adj\playlist.lst

encoder=mp3
Now when I start to run both the server and is not only the tonund sc_trans is then after a few seconds online now someone can help me configure this correctly in the playlist I've got a track that runs for about 30 min

sorry for my english is translated with google were
DJBBTONE is offline   Reply With Quote
Old 15th July 2012, 11:54   #2
DJBBTONE
Junior Member
 
Join Date: Jul 2012
Posts: 4
I have now put geschaft both run on but here's the problem if someone wants the fortuitous stream is the message which HTTP authentication settings do I have it all not coming please help me
DJBBTONE is offline   Reply With Quote
Old 15th July 2012, 20:35   #3
DrO
 
Join Date: Sep 2003
Posts: 27,873
you probably don't have an authhash correctly set for the stream. please follow http://wiki.winamp.com/wiki/SHOUTcas...ash_Management and make sure that you do not have streamauthhash=1234567890 in your DNAS config file before following those instructions.

-daz
DrO is offline   Reply With Quote
Old 16th July 2012, 14:22   #4
DJBBTONE
Junior Member
 
Join Date: Jul 2012
Posts: 4
the hash mitlerweile've already changed and admin interface to be generated but still I get the HTTP authentication

Shoutcast 2 conf
Quote:
;DNAS configuration file
;Made with the SHOUTcast 2 Configuration Builder

password=test123
adminpassword=test1234
portbase=6650
requirestreamconfigs=1
logfile=C:\SHOUTcast\sc_serv.log
w3clog=C:\SHOUTcast\sc_w3c.log
publicserver=always
banfile=C:\SHOUTcast\sc_serv.ban
ripfile=C:\SHOUTcast\sc_serv.rip
maxuser=10

streamid=1
streammaxuser=10
streampassword=test123
streamadminpassword=test1234
streamauthhash_1=*************
SC_TRANS conf

Quote:
;Transcoder configuration file
;Made with the SHOUTcast 2 Configuration Builder

streamtitle=testserver
streamurl=127.0.0.1
genre=Misc
usemetadata=0
adminport=6652
adminpassword=test1234
adminuser=admin
inheritconfig=C:\SHOUTcast\sc_serv.conf
unlockkeyname=*** ****
unlockkeycode=*****-*****-*****-*****
logfile=C:\SHOUTcast\sc_trans.log
public=1
playlistfile=C:\SHOUTcast\playlist.lst
streamauthhash_1=*************
encoder=mp3
channels=1
EDIT// authhash changed
DJBBTONE is offline   Reply With Quote
Old 16th July 2012, 14:44   #5
DrO
 
Join Date: Sep 2003
Posts: 27,873
Never post your authhash publically. I did not ask for it to be posted, i just wanted confirmation if you had created an authhash or not.

I've had to delete the authhash from the system as posting it publically deems it compromised. So you will need to remove the streamauthhash line and start over.

Also why have you got it in the sc_trans configuration file?


As i think we're having a language issue, all i can say is look for any errors reported in the log output of the tools and try to resolve what is said.

-daz
DrO is offline   Reply With Quote
Old 16th July 2012, 15:50   #6
DJBBTONE
Junior Member
 
Join Date: Jul 2012
Posts: 4
ok have the problem solved and I now work to simply put habs public server and public = 1 = always deleted from the conf
DJBBTONE is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump