Old 26th August 2011, 18:53   #1
ukn742
Junior Member
 
Join Date: Aug 2011
Posts: 3
Seriously annoying old playlist bugs.

Winamp 5.621, but this happened for years I believe.

"Q" - the queue command in playlist.

If you have duplicate entries in your playlist, and you're queuing the bottom entry, it draws the square brackets [#] around the one that's higher in the list.

Another problem. The "J" (Jump to File) doesn't always work. I can't figure out, but depends on what's in the list, it take several minutes to display. I am not showing more than 350 songs in a list. It happens A LOT. The J just doesn't do jack sometimes.

This might not be useful info, but there's a likelihood that some songs would have been selected from the local library, and the exact same songs could've been enqueued from Explorer.


I was going to moan about another bug where the hotkeys (like CTRL+P) only work from the playlist, but when in the main Winamp window, but I can't reproduce it so it was probably fixed.


- ukn742
ukn742 is offline   Reply With Quote
Old 26th August 2011, 19:02   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
welcome to the world of my rubbish coding...
Quote:
Originally Posted by ukn742 View Post
If you have duplicate entries in your playlist, and you're queuing the bottom entry, it draws the square brackets [#] around the one that's higher in the list.
to resolve this requires changes in Winamp and yes it's been like it ever since the feature appeared in 2004, but the current option of using the first match is the best of a bad lot of options i.e. it not tracking things if the playlist item position changes. the feature is a hack and i've just never gotten around to implementing a better solution when i've been able to work on the client itself as the whole feature (and plug-in which does it) has always been something i've done in my freetime and is essentially a 3rd party bundled plug-in with Winamp.

Quote:
Originally Posted by ukn742 View Post
Another problem. The "J" (Jump to File) doesn't always work. I can't figure out, but depends on what's in the list, it take several minutes to display. I am not showing more than 350 songs in a list. It happens A LOT. The J just doesn't do jack sometimes.
it should never take minutes to appear (unless on a really really old machine from like 2001) and even if you've a 100k playlist to start with and have it filtering the number of results. without much information, there's not much i could even do to try to give you an idea of why it's not working as no one else has reported such an issue before to my knowledge.

-daz
DrO is offline   Reply With Quote
Old 29th August 2011, 17:01   #3
ukn742
Junior Member
 
Join Date: Aug 2011
Posts: 3
I am honored to get a reply from the coder himself - thanks.

About the "J" command, well, I'll do my best to try and find consistent conditions under which the bug occurs. I'll find it. I think it might have something to do with the code that actually shows the windows, but it's not worth investigating yet.

I just remembered another OLD bug. My Winamp is setup to only be in the tray. I used Winamp like that for as long as I remember, so this might be tray specific. Basically, when I want to bring Winamp to the foreground (clicking its try icon), only peripheral windows appear, not the main Winamp window. At that point to get Winamp main window visible, I'd click on any other currently running application in the task bar, then click on the Winamp's tray icon again - voila it's back again.


P.S. it would be nice if one of the hotkeys could be setup to bring Winamp to the foreground.

- ukn742
ukn742 is offline   Reply With Quote
Old 4th September 2011, 14:27   #4
ukn742
Junior Member
 
Join Date: Aug 2011
Posts: 3
Opened Winamp today, hit J, something stole the focus away from the main window / playlist, but never showed up. I minimized all other apps just in case it popped up beneath them, but nope... I closed winamp, started again, hit J, it worked this time. Hrmrmmmm
ukn742 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump