Prev Previous Post   Next Post Next
Old 8th January 2012, 09:21   #1
doniels
Junior Member
 
Join Date: Jan 2012
Posts: 3
Unhappy Linker::link plugin not working for me

I've spent most of the past week trying to add a link to MUI_PAGE_COMPONENTS - I've tried all the various examples that I found by searching the forum.

But there's not way to get the text to be "live" and open a browser.

The classic
PHP Code:
    FindWindow $"#32770" "" $HWNDPARENT
    GetDlgItem 
$$0 1006
    Linker
::link /NOUNLOAD $"http://nsis.sourceforge.net/Linker_plug-in" 
does nothing, no matter which control I use. (I'd prefer to use 1021, based on Resource Hacker)

My latest attempt tried all the tricks on this old thread. The "go to google" link appears as text but is not a hyperlink.

I've tried with "linker" and "linker 1.1" from the linker plug in page. I'm using NSIS version 2.45

I've considered adding a button instead, but that looks even more complicated.

Any ideas? Our MUI_PAGE_COMPONENTS has a list of 10 check-boxes, so I'm in no hurry to recreate it as a custom screen, unless that's the easy way to do it.

- Danny, who inherited a rather large and complicated NSIS installation that needs to be maintained.
doniels is offline   Reply With Quote
 
Go Back   Winamp & Shoutcast Forums > Developer Center > NSIS Discussion

Tags
links, nsis, url

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump