Old 15th August 2002, 08:34   #1
hiphip
Junior Member
 
Join Date: Aug 2002
Posts: 8
skins won't load , never had this problem before

I formatted yesterday. Went to put winamp 2.8 back onto my computer and saw that 3.0 was out. I gave 3.0 a try but hated how sluggish it was and how you can't double click for file ID anymore, so I uninstalled and went back to 2.8 After that I went skin searching, found a few i liked, and was unable to load them. They are in the correct directory, I didn't mess with the extensions or anything, but they won't load. They appear as an unknown file type (icon is msdefult). I thought maybe winamp3 had something to do with it, so i uninstalled 2.8... deleted some ini files from c:/windows and then took out the registry entry for winamp3, rebooted, and reinstalled 2.8. But its the same deal, they just won't load. They don't appear in the skins browser (alt +s). I never had this problem before and i've been using winamp for years. Does anyone have any ideas that would help me ?
hiphip is offline   Reply With Quote
Old 15th August 2002, 13:43   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
The winamp.com site is currently being re-optimized & redesigned due to the switcharound with wa2 and wa3 components etc. All problems should be fixed very soon.

At the moment, all WA2 skins from http://classic.winamp.com/skins/ are downloading as WA3 skins with the .WAL extension

First, make sure "hide extensions for known filetypes" isn't checkmarked in Windows "Folder Options -> View" tab, then goto the dir where the skin files are (usually the ...\Winamp\Skins dir), rt click the skin file, select "rename", and change the extension from .wal to .wsz (in some weird cases, this will be .sz or .wz to .wsz)

For those asking "how?", basically, you type it in manually, so that filename.wal or filename.sz or filename.wz becomes filename.wsz


If the problems persist, tell me what your Windows OS is...


WinME/2k instructions:
Control Panel -> Folder Options -> File Types tab
Scroll down for WSZ (winamp extension installation file) -> Advanced
Default action should be: Install
App used command line = "C:\Program Files\Winamp\winamp.exe" "%1"

Win9x Folder Options accessible via:
My Computer/Windows Explorer -> View or Tools Menu (can't remember which)
or via: Start -> Settings -> Folder Options

____________________________________________________________________


Advanced help:

For people who have both WA2 and WA3 installed:

Note: This is a temporary measure and can be UNDONE once the winamp site is fixed.

Folder Options -> File Types tab
Scroll down for & hi-lite WAL (Winamp3 Skin file)
Click "Advanced" (WinME/2k) or Edit (Win9x) or whatever it is in WinXP
Checkmark: Confirm open after download
Okay everything

Now when you try to download a skin, you'll be prompted to open/save the file first.

For WA3 skins, save to the Winamp3\Skins dir
No further action is required except to open WA3 and select the skin via the GUI.
Or, you can select "open from current location" and the process will be automated.

For WA2 skins, save to the Winamp\Skins dir
Then repeat the "rename" action as outlined above (*.WAL to *.WSZ)
Alternatively, in the "Save to Disk" dialog, change the filetype to "all files" from the drop-down menu, and manually change & type in the correct finename/extension, eg. filename.wsz
____________________________________________________________________

Now, for those who are getting these weird .wz or .sz extensions, you'll need to try this little workaround.
In Folder Options -> File Types
Click "New"
Type in the following:
Extension = wz
(or if you're getting *.sz files, Extension = sz)
For WinME/2k, click "Okay" (I don't know if it's the same for WinXP)

Depending on your Windows OS, you'll then need to edit the properties for this new (temporary) filetype.
In Win9x, this is all done in the same "New" screen
For Win2k/ME, back in the original "File Types", you'll now see your new filetype is hi-lighted in the Extensions list.
Click "Advanced"
Checkmark: confirm open after download
Checkmark: Always show extension

If you want, you can also type in a description (the cursor will already be in this box, ie. the one next to "Change Icon")
If you want, you can type in something like:
Borked Winamp Skin

You can also change the icon if you wish, but this is not relevant to the problem/solution.
(eg. click "change icon", then "browse" to say winamp.exe and select one of the icons. I suggest using a different icon to the one used for .WSZ files, to help you distinguish between the two)

That's it!
Now when you download a skin, you should get the Open/Save Dialog.
Select "Save" and download it to the Winamp\Skins dir.

Now follow the instructions above to rename the file from *.WZ or *.SZ to *.WSZ

(or simply change the filetype in the save dialog to: "all files" and type in the correct filename and extension, eg. skin.wsz)

I don't think you'll even need to create a default "Action" (eg. Open) in Folder Options, because Winamp won't recognize the .WZ or .SZ extension anyway, that's why it's adding them to the playist and trying to play them instead.

____________________________________________________________________

IMPORTANT
Make sure you are downloading Winamp 2 skins for Winamp 2x
and not Winamp3 skins for Winamp 2x
Winamp3 skins (.wal) will NOT work with Winamp 2x
____________________________________________________________________

Note:

You can currently only download from the individual skin's "more info" page, the "download" links from the WA2 "browse" category sections are still borked.

Please be patient and everything will eventually return to normal.

Thank you for your kindness & understanding.

[edit] now fixed [/edit]

____________________________________________________________________


ps. note that this post doesn't cover all skin-loading problems, only the current issue. For further tips/help regarding problems with downloading/installing skins, see here
____________________________________________________________________

pps. note to self:
I'm pretty certain this is due to a winamp.com fault, and nothing to do with the Windows Registry settings. I've checked the Registry and everything seems to be in order, but I'll dig even deeper just to make sure. It's also possible that installation/uninstallation of WA3 is causing weird things to happen, eg. a buggy conflict of interests with WA2
DJ Egg is offline   Reply With Quote
Old 15th August 2002, 18:51   #3
hiphip
Junior Member
 
Join Date: Aug 2002
Posts: 8
DJEgg:
The files are infact downloading as a .wz I sort of figured that this was part of the problem when they downloaded as an unknown file type (that MSDefult icon appeared). I simply corrected the extension in the download window before starting to the one you mentioned (.wsz) and the skins are loading perfectly back into 2.8 thanks for the info I really appreciate it. Now i just have to find that 1 skin that I forgot to back up! HA. thanks again -hiphip
hiphip is offline   Reply With Quote
Old 16th August 2002, 00:01   #4
bball4eva23
Junior Member
 
Join Date: Aug 2002
Location: ma
Posts: 2
skin thread

i've unchecked the box that said hide... but where is the dir where the skins r stored i have no idea how to get there and im getting annoyed with the skins going into my playlist
bball4eva23 is offline   Reply With Quote
Old 16th August 2002, 07:56   #5
hiphip
Junior Member
 
Join Date: Aug 2002
Posts: 8
about the box, how to rename

What the box does is the following... By unchecking it "hide file extensions for known file types", you will be able to see the extension on the skin. (see previous post for info on how to find this box) In order to change the actual file extension, navigate to the directory that you installed winamp under.

the defult is:
C:\Program Files\Winamp

Thus skins will be found in:
C:\Program Files\Winamp\Skins

Once your in the correct directory, and now that the file extensions are showing, simply right click the skin that you would like to fix, and select "Rename", or click on the skin once and press F2 (both do the exact samething) and change the .wal or .wz or .sz (all bad extensions) to the correct ".wsz" and your skins will load once again into winamp2.8.

If your familiar with the Command Prompt and MSDOS you could also navigate you way to the skins directory and type:

rename nameofskin.sz newnameofskin.wsz

the third method is to rename the file before it downloads when the saveas.. dialogue box appears.

Goodluck -hiphip
hiphip is offline   Reply With Quote
Old 16th August 2002, 13:43   #6
bball4eva23
Junior Member
 
Join Date: Aug 2002
Location: ma
Posts: 2
it worked thanx!!! i had been there before i just didnt notice the .sz after the name when i hit rename so i got confused....thankyou again!
bball4eva23 is offline   Reply With Quote
Old 20th August 2002, 03:52   #7
exotube
Junior Member
 
Join Date: Aug 2002
Location: pa
Posts: 1
Send a message via AIM to exotube
i don't get the option to save the skin or open it from it's current loaction so it downloads then the 'what program do you want to use to open this' box pops up. can anyone help ?
exotube is offline   Reply With Quote
Old 20th August 2002, 04:40   #8
Wildrose-Wally
The Albertan
 
Join Date: Mar 2001
Posts: 6,122
Instead of left clicking on the link, try right clicking. You'd be surprised how much difference that can make.
Wildrose-Wally is offline   Reply With Quote
Old 21st August 2002, 20:40   #9
elliebell370
Junior Member
 
Join Date: Aug 2002
Posts: 3
I deleted WAL file types, and now can't change them

Trying to fix the problem with the Winamp 2 skins, I deleted the *.wal file type in the folder options and now I can't change the file type to *.wsz. Also, the skins download to C:/Windows/TEMP, so what so I do? Please help!
elliebell370 is offline   Reply With Quote
Old 22nd August 2002, 01:22   #10
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
exotube and elliebell370

I've edited my post above to include extra info.
Confirm you've tried everything there first.

Note: wal skins for Winamp3 do NOT work with Winamp 2.x
DJ Egg is offline   Reply With Quote
Old 22nd August 2002, 22:52   #11
spenrok
Junior Member
 
Join Date: May 2002
Location: UK
Posts: 11
I have had the same problem with skins and sadly although I have tried all of the above I still can't get them to work.
I'm running XP and 2.8 was playing up way before I tried version 3.

It doesn't make a lot of sense really and like everyone else i'd love to be able to get other skins on there rather than the default (sorry no offence Mr Winamp !)

In anticipation

spenrok is offline   Reply With Quote
Old 23rd August 2002, 20:30   #12
elliebell370
Junior Member
 
Join Date: Aug 2002
Posts: 3
I had replied earlier to this thread because I thought I had tried everything until "DJ Egg" had edited his reply. Try to follow these directions exactly (it worked for me even though I deleted File Types and thought I had messed it up more):
1. Open Winamp.
2. Find the skin you want to download for Winamp 2 and RIGHT click where it says "Download".
3. Choose "Save Target As..."
4. When it asks you to save it, make sure that you save it to the folder C:\Program Files\Winamp\Skins (which should be default already).
5. The default name of the skin you chose to download should be in the "File Name" field. MAKE SURE THAT THE FILE EXTENSION ("dot whatever") SAYS .WSZ Nothing else will work (I promise).
6. Press "Save". Make sure that "Close this dialog box when download completes" is UNCHECKED as it is downloading.
7. When it is finished, Press "OPEN" and cross your fingers. Hopefully, if all went well, the skin should work.
I hope this works for you because I know the frustration of not getting something so little to work. But keep trying!
elliebell370 is offline   Reply With Quote
Old 24th August 2002, 09:38   #13
spenrok
Junior Member
 
Join Date: May 2002
Location: UK
Posts: 11
Thanks for replying Elliebell,

I tried to do exactly as you said and unfortunately it still doesn't work. I have a whole selection of skins all with the altered "wsz" extension in my skins folder, and it appears that Winamp won't even detect these under options, skins.

It's a total mystery as to why it doesn't work...help me please somebody !!

Spec

XP, Win 2.80


spenrok is offline   Reply With Quote
Old 24th August 2002, 09:44   #14
spenrok
Junior Member
 
Join Date: May 2002
Location: UK
Posts: 11
Ok so I finally cracked it !

Although i'd reinstalled Winamp on a number of occassions i'd always kept the plug in's and skins folder, for obvious reasons.
So, I finally thought what the hell and deleted the whole lot.

Upon reinstalling Winamp the first skin download I made had the WSZ extension rather than WAL and it worked !

Hurrah !!

Thanks again Elliebell and for anyone who had the time to read my mad English ramblings.

Spenrok

spenrok is offline   Reply With Quote
Old 24th August 2002, 12:09   #15
Terragina
Junior Member
 
Join Date: Aug 2002
Posts: 3
Sorry, but I try to load some skins, too under XP. I`d changed the extensions, see the skins in the browser... but the look will not change.

Can anybody help me?

Greetz,

Terragina
Terragina is offline   Reply With Quote
Old 24th August 2002, 18:44   #16
spenrok
Junior Member
 
Join Date: May 2002
Location: UK
Posts: 11
Hi Terragina,

The way I sorted mine out was to uninstall Winamp including the skins/plug ins folder and then reinstall it.

Once reinstalled again try right clicking the bit on the skins website which says download and then select save target (courtesy of elliebell !)
Make sure it says .wsz as the extension, if not change it yourself and it should work.

I spent a couple of days trying to puzzle this out, and it only sorted itself out by doing the above and taking hints/help from the wonderfull users of this forum.

Good luck
spenrok is offline   Reply With Quote
Old 24th August 2002, 20:02   #17
Terragina
Junior Member
 
Join Date: Aug 2002
Posts: 3
Hi spenrok,

thanks for your help. I did it the same way, "down the drain" - install once again....and have a look: Now it wasn`t a problem any longer ;-) But I must not understand it.... "my baby`s" living :-)

Much greetings from germany, sorry for my horrible english!!

Terragina
Terragina is offline   Reply With Quote
Old 24th August 2002, 21:03   #18
spenrok
Junior Member
 
Join Date: May 2002
Location: UK
Posts: 11
No worries Terragina glad to have helped someone !

take care

Spenrok

PS Your English is fine, you should hear my German !
spenrok is offline   Reply With Quote
Old 25th August 2002, 01:01   #19
mudyh2o
Junior Member
 
Join Date: Aug 2002
Posts: 5
DJEgg "You The Man" thanks, the w in the name fixed, Thanx Man!!!
Also thanx Reaper
mudyh2o is offline   Reply With Quote
Old 26th August 2002, 03:13   #20
gametempest
Junior Member
 
Join Date: Aug 2002
Posts: 1
Winamp Classic 2.81 Skins HELP!

I need help on Winamp Skins! I once installed Winamp 3 and uninstalled it for it sucks 2.xx is much better. So I went to the site and downloaded the latest classic version 2.81, and after I installed it to my computer, I went back to the Official Site to download skins. When I am to download a skin, a download dialog box appears and asking whether I should save it or open it from my current location. To cut it short, the skins don't get installed, instead they pop out in the playlist!

I am using Windows 98, IE 5.5, and WA 2.81 Classic
Please help me!

+info=I already read and did what was posted in the FAQ and forums yet it still doesn't work!
gametempest is offline   Reply With Quote
Old 26th August 2002, 13:05   #21
elliebell370
Junior Member
 
Join Date: Aug 2002
Posts: 3
When it asks you whether to save or open the skin, click save and then make sure that it saves to the folder C:\Program Files\Winamp\Skins (I believe, or something like that). Then, make sure that your file extension is .WSZ NOT .sz or something along those lines. I hope that it works for you!
elliebell370 is offline   Reply With Quote
Old 26th August 2002, 16:37   #22
Terragina
Junior Member
 
Join Date: Aug 2002
Posts: 3
Hi gametempest,

make sure that you wanna download skins for Winamp 2 (just at the top of the winamp.com site in the right corner!!) That`s the secret, because if you use the version 2.81, you only can use it with the skins and Plug-Ins for Winamp 2 ( `cause these are already "wsz"-Files)!!! Really hope that that helps you!!

Please let me know, if it work or not!!

Greetz,

Terragina
Terragina is offline   Reply With Quote
Old 1st September 2002, 19:46   #23
dezarray
Junior Member
 
Join Date: Sep 2002
Posts: 11
wow, spanks.
i was having the same problem and lo and behold here is the answer.
and if this doesn't work........i will be back for this forum's expertise!!!!!!

Originally posted by DJEgg
Quote:

The winamp.com site is currently being re-optimized & redesigned due to the switcharound with wa2 and wa3 components etc. All problems should be fixed very soon.

At the moment, all WA2 skins from http://classic.winamp.com/skins/ are downloading as WA3 skins with the .WAL extension

First, make sure "hide extensions for known filetypes" isn't checkmarked in Windows "Folder Options -> View" tab, then goto the dir where the skin files are (usually the ...\Winamp\Skins dir), rt click the skin file, select "rename", and change the extension from .wal to .wsz (in some weird cases, this will be .sz or .wz to .wsz)
dezarray is offline   Reply With Quote
Old 1st September 2002, 23:52   #24
dezarray
Junior Member
 
Join Date: Sep 2002
Posts: 11
well, it didn't work for me.
i checked and the "folder options" isn't checked for "hide file extensions".
i went in and renamed the downloaded skins, from .wal to .wsz.
i was using winamp version 2.6.
so i uninstalled it and downloaded 2.8 full version.
the skin is listed in the skins directory, but won't load.


*edit......i am trying this now
Quote:
WinME/2k instructions:
Control Panel -> Folder Options -> File Types tab
Scroll down for WSZ (winamp extension installation file) -> Advanced
Default action should be: Install
App used command line = "C:\Program Files\Winamp\winamp.exe" "%1"
okay, i did that and it didn't work.
i had also "right-clicked" on the "download" to "save as" and although i could change the extension, i couldn't change it within the lower window which has .wal or "all files".
would i change to the "all files"?
anyhoot.......i downloaded anyway, went in to the "skins" directory and they do read as .wsz. but i click on them and nada!

i just don't know.
any other suggestions?
maybe i missed something.
i'm gonna go reread this thread.
spanks to u all!!!!!!!!!!



p.s. i'm running windows ME.

Last edited by dezarray; 2nd September 2002 at 00:12.
dezarray is offline   Reply With Quote
Old 2nd September 2002, 00:37   #25
dezarray
Junior Member
 
Join Date: Sep 2002
Posts: 11
i'm sorry guys and dolls.
i didn't know that by running 2.81, i needed to go here, for the "classic" skins site.
i am downloading again.
and my fav "The Silence" wasn't listed and i wondered why.
now i know.
so just disregard my above posts, please.
but damn, there were some cool skins at that other site.
guess i'll just have to get 3.0, eh?
thanks DJEgg!
dezarray is offline   Reply With Quote
Old 11th September 2002, 01:06   #26
sweetxpchunsa88
Junior Member
 
Join Date: Jul 2001
Posts: 13
Help!

How am I suppose to reinstall if i cant uninstall it???????????????????
sweetxpchunsa88 is offline   Reply With Quote
Old 11th September 2002, 02:04   #27
sweetxpchunsa88
Junior Member
 
Join Date: Jul 2001
Posts: 13
Won't anybody please help me?

HELP~!
MY STUPID WINDOWS ME IS WIERD...
WHAT SHOULD I DO?
DOES ANYONE KNOW?
HOW COME ALL OF YOU GUYS' WINAMP WAS FIXED?
WAS ALL OF YOUR GUYS' COMPUTER A XP?
HELP~! SOC (SAVE OUR COMPUTER)
sweetxpchunsa88 is offline   Reply With Quote
Old 11th September 2002, 23:22   #28
dezarray
Junior Member
 
Join Date: Sep 2002
Posts: 11
Re: Won't anybody please help me?

Quote:
Originally posted by sweetxpchunsa88
HELP~!

WHAT SHOULD I DO?
DOES ANYONE KNOW?
HOW COME ALL OF YOU GUYS' WINAMP WAS FIXED?
WAS ALL OF YOUR GUYS' COMPUTER A XP?
HELP~! SOC (SAVE OUR COMPUTER)
what exactly was the problem.....was it the same as ours?
trying to download some skins?
mine is a ME.
what version of winamp r u presently using and did u try the link in my post above, for the "classic skins"?????????
dezarray is offline   Reply With Quote
Old 12th September 2002, 01:16   #29
sweetxpchunsa88
Junior Member
 
Join Date: Jul 2001
Posts: 13
Your Message

As far as I can tell, it is.
And my computer is a ME, and yes I did try the classics site...
I think my problem is something deeper because I cannot even uninstall my Winamp, and my version of it is 2.81. Please tell me if this was what happened to you...
sweetxpchunsa88 is offline   Reply With Quote
Old 12th September 2002, 09:06   #30
dezarray
Junior Member
 
Join Date: Sep 2002
Posts: 11
Re: Your Message

Quote:
Originally posted by sweetxpchunsa88
As far as I can tell, it is.
And my computer is a ME, and yes I did try the classics site...
I think my problem is something deeper because I cannot even uninstall my Winamp, and my version of it is 2.81. Please tell me if this was what happened to you...
well, sweetie....no. i did not have that problem.
and if the problem is deeper......then i cannot help u.
but i can ask a few more questions, which may help someone else.......help u.
when u say that u can't uninstall winamp......do u mean u don't have the uninstall .exe?
i can assume u have already tried start/settings/add/remove programs?
if u do a search on winamp.......does anything come up??
if so, did u delete?
if u have done all these things......and still have winamp....then i would agree with u that the problem, does indeed lie deeper and i am sorry that i cannot help u.
be patient and someone will come along, i'm sure!
dezarray is offline   Reply With Quote
Old 13th September 2002, 01:29   #31
sweetxpchunsa88
Junior Member
 
Join Date: Jul 2001
Posts: 13
Uninstalling

I do have a uninstall.exe but there's an error, and when I search for it, yes there's winamp stuff that comes up. And I have deleted them and reinstall it... BTW~ I tried another music player and I can't use skins on it either...
sweetxpchunsa88 is offline   Reply With Quote
Old 14th September 2002, 20:29   #32
plexdude
Junior Member
 
Join Date: Aug 2002
Posts: 27
Downloaded Skins Still Won't Load Automatically

Attn: DJ Egg or anybody that is experienced with skin loading problems,

I'm using Windows 2K and when I try to download Winamp skins, I always get prompted for saving the file and the files always have the .sz extention instead of .wsz like they're supposed to. I know that your site went through a major change when Winamp3 came out and broke the way skins are downloaded but I also know that the site has been fixed since then because I've been able to download skins normally with other Windows 2K machines recently. There is something obviously messed up with my computer and I can't get the skins to work correctly again. I've tried uninstalling and reinstalling Winamp several times and it doesn't fix the problem. I've also gotten rid of my skins and plugins when removing Winamp.

I'm looking (hoping) for a solution to this problem and not just a workaround. This is very annoying.

System Specs:

Intel Wolfdale Core 2 Duo E8400 @ 3.6GHz 1600MHz FSB
Gigabyte GA-EP45-UD3R rev 1.1
G.Skill 4GB DDR2 RAM: F2-6400CL4D-4GBPI-B
Creative X-Fi Titanium
eVGA GeForce 260 GTX
Klipsch 4.1 THX speakers
Windows 7 Ultimate 64-Bit
plexdude is offline   Reply With Quote
Old 17th September 2002, 19:32   #33
ArthurWeasley
Junior Member
 
Join Date: Sep 2002
Posts: 3
Send a message via AIM to ArthurWeasley
Another person with skins problems...

I have Winamp 2.62 and Windows 2000. Winamp works well, but I can't change skins. Downloading works, and I've successfully changed the extension on the new skins to .wsz, which then show up in the skins directory in Winamp. However, when I highlight the skin I want to use and hit the "close" button, I still get the default skin. What's wrong with me (that a few extra brain cells won't cure)?
ArthurWeasley is offline   Reply With Quote
Old 20th September 2002, 21:58   #34
sstalling
Junior Member
 
Join Date: Sep 2002
Posts: 2
Still not working

I followed your instructions and winamp still isnt recognizing the files.....what do i do now?
sstalling is offline   Reply With Quote
Old 22nd September 2002, 17:14   #35
sweetxpchunsa88
Junior Member
 
Join Date: Jul 2001
Posts: 13
me 2

Why won't it recognize??? So frustrating...
sweetxpchunsa88 is offline   Reply With Quote
Old 22nd September 2002, 21:49   #36
jc97
Junior Member
 
Join Date: Sep 2002
Posts: 2
Send a message via Yahoo to jc97
I did everything listed and I still can't get my skin to install
jc97 is offline   Reply With Quote
Old 25th September 2002, 15:34   #37
ArthurWeasley
Junior Member
 
Join Date: Sep 2002
Posts: 3
Send a message via AIM to ArthurWeasley
A new twist...

With some tinkering, I have discovered one skin which -- mercy knows why -- works [Rhino(1).wsz]. If I select this one, it comes up; any of the others, and it reverts to the default skin. If I set Winamp to randomly change skins on play, then shut my laptop for a while (15-20 minutes), it changes to Rhino. Then, if I hit "b" to jump to the next song, it reverts to the default skin. Apparently, "b" is treated like "play" as far the randomizer is concerned.
ArthurWeasley is offline   Reply With Quote
Old 26th September 2002, 20:00   #38
ArthurWeasley
Junior Member
 
Join Date: Sep 2002
Posts: 3
Send a message via AIM to ArthurWeasley
I figured it out...

Although I was led to believe that changing the .wal extension of Winamp 3 skins to .wsz would enable Winamp 2x to use them, it didn't work for me. I saw the icon in the upper right corner of the website that (essentially) said "Get Winamp 2" here. I discovered that the skins at that location were the ones compatible with my version. Alas, these skins are -- although artistically interesting -- limited in physical variety compared to those available for Winamp 3. As my company's IT department has forbidden us to download media players (Winamp 2.62 came with Netscape, although they don't seem to realize that), I'm stuck with this old version for now.
ArthurWeasley is offline   Reply With Quote
Old 29th September 2002, 21:07   #39
askodude
Junior Member
 
Join Date: Sep 2002
Location: Florida
Posts: 3
Help loading .wal and .wsz files

Quote:
Originally posted by DJEgg
The winamp.com site is currently being re-optimized & redesigned due to the switcharound with wa2 and wa3 components etc. All problems should be fixed very soon.

At the moment, all WA2 skins from http://classic.winamp.com/skins/ are downloading as WA3 skins with the .WAL extension

First, make sure "hide extensions for known filetypes" isn't checkmarked in Windows "Folder Options -> View" tab, then goto the dir where the skin files are (usually the ...\Winamp\Skins dir), rt click the skin file, select "rename", and change the extension from .wal to .wsz (in some weird cases, this will be .sz or .wz to .wsz)

For those asking "how?", basically, you type it in manually, so that filename.wal or filename.sz or filename.wz becomes filename.wsz


If the problems persist, tell me what your Windows OS is...


WinME/2k instructions:
Control Panel -> Folder Options -> File Types tab
Scroll down for WSZ (winamp extension installation file) -> Advanced
Default action should be: Install
App used command line = "C:\Program Files\Winamp\winamp.exe" "%1"

Win9x Folder Options accessible via:
My Computer/Windows Explorer -> View or Tools Menu (can't remember which)
or via: Start -> Settings -> Folder Options

__________________________________________________________


Advanced help:

For people who have both WA2 and WA3 installed:

Note: This is a temporary measure and can be UNDONE once the winamp site is fixed.

Folder Options -> File Types tab
Scroll down for & hi-lite WAL (Winamp3 Skin file)
Click "Advanced" (WinME/2k) or Edit (Win9x) or whatever it is in WinXP
Checkmark: Confirm open after download
Okay everything

Now when you try to download a skin, you'll be prompted to open/save the file first.

For WA3 skins, save to the Winamp3\Skins dir
No further action is required except to open WA3 and select the skin via the GUI.
Or, you can select "open from current location" and the process will be automated.

For WA2 skins, save to the Winamp\Skins dir
Then repeat the "rename" action as outlined above (*.WAL to *.WSZ)
Alternatively, in the "Save to Disk" dialog, change the filetype to "all files" from the drop-down menu, and manually change & type in the correct finename/extension, eg. filename.wsz
__________________________________________________________

Now, for those who are getting these weird .wz or .sz extensions, you'll need to try this little workaround.
In Folder Options -> File Types
Click "New"
Type in the following:
Extension = wz
(or if you're getting *.sz files, Extension = sz)
For WinME/2k, click "Okay" (I don't know if it's the same for WinXP)

Depending on your Windows OS, you'll then need to edit the properties for this new (temporary) filetype.
In Win9x, this is all done in the same "New" screen
For Win2k/ME, back in the original "File Types", you'll now see your new filetype is hi-lighted in the Extensions list.
Click "Advanced"
Checkmark: confirm open after download
Checkmark: Always show extension

If you want, you can also type in a description (the cursor will already be in this box, ie. the one next to "Change Icon")
If you want, you can type in something like:
Borked Winamp Skin

You can also change the icon if you wish, but this is not relevant to the problem/solution.
(eg. click "change icon", then "browse" to say winamp.exe and select one of the icons. I suggest using a different icon to the one used for .WSZ files, to help you distinguish between the two)

That's it!
Now when you download a skin, you should get the Open/Save Dialog.
Select "Save" and download it to the Winamp\Skins dir.

Now follow the instructions above to rename the file from *.WZ or *.SZ to *.WSZ

I don't think you'll even need to create a default "Action" (eg. Open) in Folder Options, because Winamp won't recognize the .WZ or .SZ extension anyway, that's why it's adding them to the playist and trying to play them instead.

__________________________________________________________

Note:
You can currently only download form the individual skin's "more info" page, the "download" links from the WA2 "browse" category sections are still borked.

Please be patient and everything will eventually return to normal.

Thank you for your kindness & understanding.

___________________________________________________________


ps. note that this post doesn't cover all skin-loading problems, only the current issue. For further tips/help regarding problems with downloading/installing skins, see here


pps. note to self:
I'm pretty certain this is due to a winamp.com fault, and nothing to do with the Windows Registry settings. I've checked the Registry and everything seems to be in order, but I'll dig even deeper just to make sure.
-------------------------------------------------------------------------------------------___________________________------------------------
I have win98 2nd edition - I'm using Winamp 2.80 - I followed your instructions exactly to no avail - the wsz skin files do go into the program files\winamp\skins folder, and are accessable from winamp thru the skin browser or skin column under visualizations in the main info tab but just won't load up. The folder options/file types was set correctly and I even tried redownloading the skins and chose "open this file from it's current location", all to no avail. I already have a whole bunch of skins that are already working including some that I made, but I would like to install some new ones including the 20 or so that are already downloaded on my harddrive. Please help. Thanks, Mike

askodude is offline   Reply With Quote
Old 29th September 2002, 21:44   #40
jc97
Junior Member
 
Join Date: Sep 2002
Posts: 2
Send a message via Yahoo to jc97
Did you try saving the skin to your skins folder and then when it's down downloading go to your skins folder, find your skin, right click on the file, go to properties and change the file extension at the end of the name to .wsz . Change it to a read only file rather then an archive, click on ok, wait a couple seconds then you should be able to install the skin. Thats what worked for me anyway.
jc97 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump