Old 8th December 2010, 14:41   #1
raparke
Junior Member
 
Join Date: Dec 2010
Posts: 4
run SNAS as a service

I am working with the Nullsoft SHOUTcast Server Monitor (GUI) DNAS on a Windows 2003 Server box. I want this program to run continually, even after a "log off" or "log on" or not even logged in (like a service would) of Windows accounts. I have tried everything I have found online including adding a start-up script, task scheduler, and a batch file made into a "service". All these things seem to start it fine, but then when the computer is logged on or off remotely, it closes down.

Is there a way to make this run as a service and function like Windows Media Services? Windows finally did something right, with their streaming management software stuff anyway, making it a service.

Is there a way to make it run as a service, so that a log off log on does not affect it in any way?

Thank you,
Richard.
raparke is offline   Reply With Quote
Old 8th December 2010, 14:52   #2
dotme
Moderator
 
dotme's Avatar
 
Join Date: Feb 2005
Location: USA
Posts: 4,024
DNAS 1.x - You need to run it as a scheduled task. But... first, create a NEW user on the box (not the same account you use for RDP). Just to be safe, you can also make the new user a member of the "Administrators" group so there are no permissions issues.

Once the user is created, create the task ("When My Computer Starts") and tell it to run as the user you created above.

Now you can log on and off as much as you like, and that task will keep running.

Don't forget to uncheck the box "Stop this task if still running after x hours" in the advanced settings of the task properties.
dotme is offline   Reply With Quote
Old 8th December 2010, 14:59   #3
raparke
Junior Member
 
Join Date: Dec 2010
Posts: 4
Thanks dotme. I did that exact thing, but maybe I missed something. The problem I had with this was it did start it when the computer started, but then when someone logged on, or off, it would close it. Is there something else going on here maybe related to 2003 Server? I appreciate your thoughts.

Edited: Oops, I just realized that you're suggesting I try it with a DIFFERENT user than what is used for RDC. Let me try that.

Last edited by raparke; 8th December 2010 at 15:08. Reason: reread post and realized what I missed
raparke is offline   Reply With Quote
Old 8th December 2010, 15:07   #4
dotme
Moderator
 
dotme's Avatar
 
Join Date: Feb 2005
Location: USA
Posts: 4,024
I'm running several instances of the DNAS on a 2003 Server. If you create a new user that nobody uses to log in as, you should be good.

My task user is "scast" for example. So I log in as Administrator, create the scheduled task using "When My Computer Starts" as the main schedule setting.

Once created, right-click the task - choose properties.

"Task" tab - Run As... Enter your user ("cast" in my case) and then click SET PASSWORD button to enter the password you used when creating your task user account.

"Settings" tab - uncheck all boxes on that tab.

Save. Right-click task, choose "Run" - Then after confirming that the DNAS is up and running, log off RDP - it should stay up. Good luck!
dotme is offline   Reply With Quote
Old 8th December 2010, 15:32   #5
raparke
Junior Member
 
Join Date: Dec 2010
Posts: 4
Thanks! This makes sense now, I'll give it a shot and see what happens.
raparke is offline   Reply With Quote
Old 9th December 2010, 15:23   #6
raparke
Junior Member
 
Join Date: Dec 2010
Posts: 4
So far so good. Thanks dotme!
raparke is offline   Reply With Quote
Old 9th December 2010, 18:19   #7
dotme
Moderator
 
dotme's Avatar
 
Join Date: Feb 2005
Location: USA
Posts: 4,024
Awesome! I love happy endings
dotme is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > SHOUTcast > SHOUTcast Technical Support

Tags
dnas, service, shoutcast

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump