Old 15th October 2011, 02:28   #1
bjc535
Member
 
Join Date: Oct 2011
Posts: 70
yp/resp/updatefreq missing

yp/resp/updatefreq missing

what does this even mean???
bjc535 is offline   Reply With Quote
Old 15th October 2011, 02:38   #2
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,138
Usually it means you need to turn debug logging on for yp connections and post the log results.

The last time I saw this message it was because I had a problem with an old auth-hash but it could be for a number of different issues I believe.
thinktink is offline   Reply With Quote
Old 15th October 2011, 02:54   #3
bjc535
Member
 
Join Date: Oct 2011
Posts: 70
your avatar..........That is me right now....

I still haven't gotten passed the last problem, but i went over the list of possible issues and i can't figure anything out with that....I have a strong feeling it is me messing up with the IPs somewhere along the line.

Right now in my config file i used my external IP as the IP, and dps the tool i have the outgoing address at 127.0.0.1 and the server comes alive and i don't get any errors til i register auth-hash....once i get the auth hash i get the error telling me that yp can't see my computer.

I was thinking that maybe this error (the one i made this post for) might be the cause of the not being able to see my computer???
bjc535 is offline   Reply With Quote
Old 15th October 2011, 04:26   #4
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,138
PM me the contents of your DNAS configuration file.
thinktink is offline   Reply With Quote
Old 15th October 2011, 22:40   #5
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,138
PM received:

In the Transcoder config you need to change the "streamtitle" parameter to something else other than Unnamed Server.
Also in the Transcoder config change the "inheritconfig" parameter to the same file name as the DNAS config file you're using.

After doing these if you already have auth hashes, delete them and make new ones.
thinktink is offline   Reply With Quote
Old 16th October 2011, 01:45   #6
bjc535
Member
 
Join Date: Oct 2011
Posts: 70
I watched a video you posted in another thread (it was a good video, I did learn some stuff, and even why my download button on the config builder wasn't working...lol) about the config builder, and i started over, and i now have a more detailed config file. In this new config that I made, those changes have been made. I did mess with the IPs again, and now i am getting the 480 error again, but this time i think it has to do with me changing the IP adresses.

My question now (and hopefully my last) is:
Is my understanding of these correct?

IP / Address of DNAS = Private IP (this is where the server is)

Source bind address = 127.0.0.1 (The source is on this machine)

Listeners bind address = External IP (where the listeners would need to be directed)
bjc535 is offline   Reply With Quote
Old 16th October 2011, 19:06   #7
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,138
Note to all others reading this thread:

Through a series of PMs it was found that the modem was actually a modem/router combo device. This means a double NAT situation.

In a multi-NAT environment the ports have to be forwarded through the chain of routers to the computer that hosts the DNAS.

Grats to bjc535 for getting the server working!!!
thinktink is offline   Reply With Quote
Old 17th October 2011, 16:50   #8
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally Posted by thinktink View Post
Usually it means you need to turn debug logging on for yp connections and post the log results.

The last time I saw this message it was because I had a problem with an old auth-hash but it could be for a number of different issues I believe.
as this all seems to be resolved now (at least from this thread), there is meant to be an explanatory message from the YP after the yp/resp/updatefreq missing log entry. however there's an issue in the current build of the v2 DNAS which can sometimes prevent it from appearing (mainly on updates) which is fixed for the next drop (along with hiding the yp/resp/updatefreq missing message as that seems to have caused more support issues then necessary).

-daz
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump