Old 29th January 2012, 05:49   #1
w4zzk73
Junior Member
 
Join Date: Jan 2012
Posts: 9
Intro Track on Stream

I have seen on some streams where, when someone connects to a stream, it will play an 'intro track', kind of welcoming you to the stream. Once the intro track plays, it will load the stream. How would one do this? I host a stream on a static IP, and it seems like the software could be fixed to where it would load and stream the intro file then load the stream.

Appreciate any info!

Thanks
Josh
W4ZZK73
w4zzk73 is offline   Reply With Quote
Old 29th January 2012, 06:42   #2
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,030
Send a message via Skype™ to thinktink
Depends on what version of the tools you are using and how you have them configured.
thinktink is offline   Reply With Quote
Old 29th January 2012, 06:49   #3
w4zzk73
Junior Member
 
Join Date: Jan 2012
Posts: 9
Using SHOUTcast Server v2.0.0.29 with the DSP Plugin. If it takes something different, let me know what it takes.
w4zzk73 is offline   Reply With Quote
Old 29th January 2012, 15:44   #4
w4zzk73
Junior Member
 
Join Date: Jan 2012
Posts: 9
Metadata in stream causing skipping

Has the bug in having metadata in a stream, when using a flash player, with an intro track been fixed? Can it be fixed?

W4ZZK73
w4zzk73 is offline   Reply With Quote
Old 29th January 2012, 23:17   #5
DrO
 
Join Date: Sep 2003
Posts: 27,873
'introfile' is the configuration option in the DNAS's config file which is used to specify a file to play. however, it is very crude (just loads and dumps the file into the stream) and will completely break most flash players i.e. it'll play the intro and then stop or play the rest of the stream as a stuttered output.

there is an alternative option of using sc_trans in v2 mode and it's 'serverintrofile' configuration option which will transcode the intro file so it's less likely to cause the issues (though it's still got the potential to fail as it's not always synchronised into the stream correctly).

as for the Source DSP, i've got it as a 'nice to have' option somewhere down the line when working in v2 mode (as that provides the means to transmit the intro file) but it's something that is really low on my list of things to work on as time allows at the moment.


[edit]
i didn't see the above post, which was in a separate thread until after my initial reply, so here's an additional response...

Quote:
Originally Posted by w4zzk73 View Post
Has the bug in having metadata in a stream, when using a flash player, with an intro track been fixed? Can it be fixed?
i have some changes which are already in-progress which improve some aspects of the issues seen. however, without the intro file being properly decoded to match the stream and synchronised into the output, there is going to be issues and this is something which affects both v1 and v2 DNAS when it comes to most flash players. as such, the next update will still most likely exhibit the issue and i cannot give an eta on a fix for this since it depends on source software and dnas changes to make it work correctly, then again it hasn't been deemed a big thing by the different people working on the tools over the last however many years...

-daz
DrO is offline   Reply With Quote
Old 2nd February 2012, 05:47   #6
w4zzk73
Junior Member
 
Join Date: Jan 2012
Posts: 9
I understand, Daz... and I will give your suggestions a try. Thanks alot. You've answered alot of questions, without me asking. Keep it up.
w4zzk73 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump