Old 3rd April 2011, 13:49   #1
Grandchild
Senior Member
 
Grandchild's Avatar
 
Join Date: Oct 2005
Location: Germany
Posts: 333
Downgraded - the good, the bad, the ugly

I just downloaded the new Winamp and saw that they downgraded AVS to v2.81da - cool!
Usually I'm all for new version but at least now all my presets are going to look fine for most people out there.

Unfortunately the new Winamp version doesn't seem to want to render any codeable components at all - SuperScope, Dynamic Movement, Triangle, Color Modifier, you name it - don't have any effect on the image. Movement is an exception, the standard examples work, however if you edit the code or write your own it stops to work.
Even Convolution Filter doesn't work.

Note that it really seems to be the new Winamp version since I tried other plugin versions as well. And it does still work in other players like XMPlay and (I suppose, haven't tested) Foobar2000.

Specs: Win7 Pro, Aero is on, Winamp 5.61, no other plugins except a few other AVS versions.

Will update this as I find out more...

PS:
I am kinda sad that you Winamp devs have such a hard time with AVS compatibility I fear you might be dropping support at some stage with all this hassle.
Attached Files
File Type: avs rendertest.avs (1.1 KB, 490 views)
Grandchild is offline   Reply With Quote
Old 3rd April 2011, 20:20   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
no one can get it to compile correctly (i've personally wasted far too much time as tweaking something fixes one preset and breaks everything else), as 2.81d was basically the last that was anywhere near close and tbh there's a lack of interest in working on the plug-in anymore (especially with the v2.9 branch that appeared) but what can you do when most of the issues are in the ape's where the source is lost so it's not possible to fix / update compatibility for them. ideally would be to have whatever changes were made in v2.9 (which seems to work ok with newer compilers instead of having to use MSVC6 as the last working AVS builds were made in) but that doesn't seem to be coming *shrugs*

personally, i'd prefer AVS was split off into its own installer and provided either as an option in the installer as is and is then remotely downloaded as appropriate or just left as a main site download only.

and probably the differences you're seeing are due to different permissions / settings in the loaded Winamp process compared to other players. which just backs up my own view on what to do with AVS.

-daz
DrO is offline   Reply With Quote
Old 3rd April 2011, 22:08   #3
Grandchild
Senior Member
 
Grandchild's Avatar
 
Join Date: Oct 2005
Location: Germany
Posts: 333
Yeah I think I can understand your frustration and your lack of interest by now.

Might be permissions I don't know.
I have my ways to get around the issue, so no real problem for me.

Oh well... We'll see what the future holds for the distribution of AVS.
For my part I like the idea of kids downloading it along with Winamp and perhaps sometime finding out the cool stuff you can do and the homework time you can waste with it.

Would an independently coded new AVS version have any chance to be included in an official Winamp release like now, provided that the source is available to you and you could modify it to fit your needs in terms of Winamp compatibility?
¬_¬
Grandchild is offline   Reply With Quote
Old 3rd April 2011, 22:23   #4
Yathosho
Forum King
 
Yathosho's Avatar
 
Join Date: Jan 2002
Location: AT-DE
Posts: 3,363
have you tried setting up a plugin directory in the user-space (%APPDATA%), would be good to know if that solves it. but then again i remember having different problems with 5.6 myself and my plugins are all running in user-space.

slight off-topic: i've posted a couple of older versions of avs (though these will not solve your problems with 5.6)
Yathosho is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Visualizations > AVS

Tags
2.81d, avs, bug, compatibility

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump