Old 14th May 2012, 23:40   #1
Myth024
Junior Member
 
Join Date: Mar 2005
Posts: 8
Shoutcast server config.. I'm so lost...

Ok two things first.
1. I don't need it to be listed on the shoutcast server
2. I don't intend on any mp3 streaming (probably live broadcasting with my mic)

I have it configured to the point where I can stream files through winamp locally. What I can't do is access the stream publicly.

I have a domain name that points to my own server that I have direct access to without the need of ftp or anything along those lines. What I want is people to be able to do is enter in my domain name (www.mydomain.org:2020) and be able to see the shoutcast DNAS index page. I'm also hoping that eventually I can also use this to open up the streaming station.
I've tried reading through the documentation but for the life of me I can't figure out where in the sc_serv.conf file I should put my domain url. I know I've got to be missing something simple, I just have no idea what.
Extra Info: Just to check, I started a tomcat server on port 2020 and I could access it by typing in www.mydomain.com:2020 so I know I have the right port forwarding etc.

Last edited by Myth024; 15th May 2012 at 01:37. Reason: Extra information
Myth024 is offline   Reply With Quote
Old 14th May 2012, 23:50   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
you need to have 'mydomain.org' associated with the IP address of the machine which used to then run the DNAS on (as sounds like you have done).

then in the DNAS config you'd need to ensure portbase is set as portbase=2020 or to whatever port you want to use and then accessing mydomain.org:2020 should provide the DNAS server's index.html page as long as what has been set for portbase is 'open' so the external network traffic can get through to the DNAS to be able to respond.

since if it's working ok locally, then it is most likely a lack of the required port being opened to allow the traffic through.

-daz
DrO is offline   Reply With Quote
Old 15th May 2012, 00:57   #3
Myth024
Junior Member
 
Join Date: Mar 2005
Posts: 8
Yea, I checked my port forwarding and even put my computer in the DMZ for a bit. I can access other things on my domain through the firewall and I have the portbase set but I'm still not getting the right page. I even tried entering in the IP. I can get the page if I use localhost but nothing else.
So if I do localhost:2020 I get the Shoutcast DNAS summary page. If I put in 72.xxx.xxx.xxx:2020 (the public IP) I get page can not be found. I can put in the public IP or my domain and get straight to my web pages on port 80.I made sure my apache server isn't listeing to the same port as the shoutcast server. I'm just wondering if there someplace inside the config file that I have to put in my domain name.
Myth024 is offline   Reply With Quote
Old 15th May 2012, 04:16   #4
Myth024
Junior Member
 
Join Date: Mar 2005
Posts: 8
What am I missing?

Ok, I'm trying to essentially run a shoutcast server but I don't need it publicly listed and I won't be using the mp3 format.
I have made sure the correct port is open and even temporarily put another type of server on that port to make sure I could get to it.
To be doubly sure, I even put the computer the shoutcast server is running on in the DMZ zone.
Now when I type localhost:2020 (yes, I did remember to change the baseport) I get the shoutcast dnas summary screen. If I type in my public IP (xxx.xxx.xxx.xxx:2020) I get page can not be displayed. I do have port forwarding enabled and like I said, I know I can get to that port on my public IP. So lets assume that firewall/router is not the issue.
I'm sure there is something I'm missing in my serv_conf.conf file. I'm pasting an example of what I think the file should look like.

Quote:
<----begin file------>
; NOTE: for any relative paths specified are relative to
; sc_serv and not to where the conf file is being stored

; here we will setup where the log and other related files
; will be stored. make sure that these folders exist else
; sc_serv will throw an error and will close itself down.
; we will make the logs save to the sc_serv2 directory
logfile=logs\sc_serv.log
w3clog=logs\sc_w3c.log
banfile=control\sc_serv.ban
ripfile=control\sc_serv.rip


; for testing we will make the server only work locally
; (i.e. localhost / 127.0.0.1) though if this is left out
; or set to publicserver=always then we attempt to make a
; connection to the YP for listing - do not forget to add
; in a 'streamauthhash' value for any public streams made
;publicserver=always


; if you're wanting to use a different port to use for any
; connections then you can use this option e.g. to use 80
; otherwise port 8000 is used as the default to listen on.
portbase=2020

; password used by sc_trans or the Winamp dsp plug-in
; NOTE: remember to change this to something else
password=testing


; password used for accessing the administation pages
; NOTE: remember to change this to something else
adminpassword=changeme


; now we will specify the details of the stream we're going
; to serve which can be done as follows

streamid=1
streampath=/test.aac

; or

; it can be done like this which is how it needs to be done
; if you are going to provide multiple streams from sc_serv
;streamid_1=1
;streampath_1=/test.aac
;streamid_2=2
;streampath_2=/test2.aac
<-----End File----->
So what am I missing, or what should I change. I've looked at all the examples, tried the configurator and looked through as many forum articles as I could find and still haven't found a solution. I will be doing live streaming using winamp DSP and my mic to talk.
Myth024 is offline   Reply With Quote
Old 17th May 2012, 12:52   #5
DrO
 
Join Date: Sep 2003
Posts: 27,873
other than seeing if setting destip=72.xxx.xxx.xxx from the public IP helps (72.xxx.xxx.xxx:2020) you've mentioned), there's nothing else i can think off as to why you are not getting a response if it's working via localhost:2020 as i can only assume that it's not responding since it's just not getting the responses through from being bound to the wrong IP on the host.

and disable / remove the streampath=/test.aac line from the config - unless your stream would be an AAC stream, having that will cause a lot of clients to fail to play the stream (once the public issue has been resolved).

-daz
DrO is offline   Reply With Quote
Old 28th June 2012, 11:10   #6
sgolemanski
Junior Member
 
Join Date: Dec 2011
Posts: 6
Try this

Myth024,

Try to set "publicserver=never" in the config file.

Also you can try to set the Firewall to ask for every connection. Then start the Shoutcast server and Winamp and click "Allow".

Another thing - if your port forwarding on the router is properly configured, you don't need the DMZ zone enabled. Check here:

http://www.radiotoolbox.com/online_t...ntheygetin.php
sgolemanski is offline   Reply With Quote
Old 11th July 2013, 03:09   #7
Myth024
Junior Member
 
Join Date: Mar 2005
Posts: 8
And almost a year later I'm back to trying.....

I figured out that some of the issue is that I was attempting to use the transcoder instead of the DNAS server. I'm now using SAM Broadcaster and I can connect to a localhost encoder but not one listed at a domain name. I run Apache Web server on my windows machine and have a domain name pointed to it. I know other shoutcast hosting companies are able to use domain names and ports I'm just trying to figure out how to do the same thing.
Myth024 is offline   Reply With Quote
Old 11th July 2013, 10:25   #8
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,290
trying to connect to a local server using a public IP from the local network will never work unless you have a router that can "loopback" such requests - as long as you have port forwarding set up correctly on the router, don't worry that you can't connect to the public IP from within the LAN ... get someone ELSE to test that you are indeed broadcasting publicly

"If you don't like DNAS, write your own damn system"

So I did
jaromanda is offline   Reply With Quote
Old 25th August 2013, 09:29   #9
Humphrey1989
Junior Member
 
Join Date: Aug 2013
Posts: 4
Sigh... This software has changed since v1.

I am attempting to setup a shoutcast on a server but couldn't get it to work so I attempted to get it to work locally and still wouldn't function.

What I have done is:

Install WinAmp.
Install DSP plugin
Create shortcut: "C:\Program Files\SHOUTcast\sc_serv.exe" sc_serv_basic.conf

Contents of sc_serv_basic.conf without the lines starting with ;
code:

logfile=logs\sc_serv.log
w3clog=logs\sc_w3c.log
banfile=control\sc_serv.ban
ripfile=control\sc_serv.rip

publicserver=always

;portbase=80

password=testing

adminpassword=changeme




DSP Plugin Config
code:

Server Address: localhost
Port: 8000
Stream: 1
DJ/USER ID: blank
Password: testing
Make stream public: Checked
Encoder: MP3



When I run the shortut it opens CMD and shows:

Loaded sc_serv_basic.conf
Listing for connection on port 8000
Listing for connection on port 8001
Shoucast 2 source connection
Password accepted.
Got complete metadata msg type 3902 and so on.
The song that i am playing.


But when I try to connect and listen using VLC network stream localhost:8000 or 127.0.0.1:8000 i get: Your input can't be opened.

Nor can I open the web page.

I am on Windows 8 x64.
Humphrey1989 is offline   Reply With Quote
Old 25th August 2013, 11:41   #10
DrO
 
Join Date: Sep 2003
Posts: 27,873
yes the software has changed but if you had a working v1 based config file, it can still be used with the v2 DNAS - you just have to make one addition to things as it improves the handling of Directory listings over the v1 way of not doing much.


from what you've posted, you've not followed all of the instructions as you need an authhash for a public listing to be able to work and allow clients to connect -> http://wiki.winamp.com/wiki/SHOUTcas...ash_Management


if you don't want it publically listed, change to use publicserver=never and ignore the authhash link.
DrO is offline   Reply With Quote
Old 25th August 2013, 18:15   #11
Humphrey1989
Junior Member
 
Join Date: Aug 2013
Posts: 4
Thank you for your help.

I had v1 so long ago and have formatted/changed computers since then :/

Before I posted here, I had played with the options in the conf file. Setting different values for some of them. I have set as publicserver as ;publicserver, publicserver=never, publicserver=always - and still will not allow me to connect to the stream wither either setting.

I read this from conf file:
Quote:
; for testing we will make the server only work locally
which is default and how I tested it originally. (;publicserver=never)

And from the link you gave me:
Quote:
Private - If you do not want your station to be listed e.g. an internal company station

If you want the station to be public then you will need an authorisation key, otherwise it is not needed for private stations.

If you want to run the DNAS privately then you can change the appropriate setting in the stream source being used.
So I assumed that for local private listening just for configuring it or at least trying to set it up- the goal being figruing this out so it can be switched over to a server for which I believe then I would require the authhash as I would want it to be listed to by the public.
Humphrey1989 is offline   Reply With Quote
Old 25th August 2013, 18:31   #12
DrO
 
Join Date: Sep 2003
Posts: 27,873
the default of the DNAS (irrespective of version) is to be listed, not to be private - that's why there's that note in the example config relating to testing.

really whenever there is an issue then the log will help to indicate what's going on and looking at errors reported in it i.e. it will give a message as to why the client was not allowed to connect (though i admit with the current build it may not be as obvious as it should be).
DrO is offline   Reply With Quote
Old 26th August 2013, 02:54   #13
Humphrey1989
Junior Member
 
Join Date: Aug 2013
Posts: 4
Here is a fresh log, as in I deleted the others because they're quite long.

I started Winamp, opened dsp, set it to connect (auto)
Navigated to the SHOUTcast folder and ran my shortcut.
Here is the log from that run.
It ends because I pressed Ctrl+C to stop the operation.

code:

2013-08-25 21:50:24 I msg:<***> Logger startup
2013-08-25 21:50:24 I msg:<***> version 2.0.0.29
2013-08-25 21:50:24 D msg:<***>
2013-08-25 21:50:24 I msg:***************************************************************
2013-08-25 21:50:24 I msg:** SHOUTcast Distributed Network Audio Server (DNAS)
2013-08-25 21:50:24 I msg:** Copyright (C) 1999-2011 Nullsoft, Inc. All Rights Reserved.
2013-08-25 21:50:24 I msg:** Use "sc_serv filename.conf" to specify a config file.
2013-08-25 21:50:24 I msg:***************************************************************
2013-08-25 21:50:24 I msg:[SHOUTcast] DNAS/win64 v2.0.0.29 (Jul 31 2011) starting up...
2013-08-25 21:50:24 I msg:[MAIN] PID: 57436
2013-08-25 21:50:24 I msg:[MAIN] Loaded config from sc_serv_basic.conf
2013-08-25 21:50:24 I msg:[MAIN] Calculated CPU count is 4
2013-08-25 21:50:24 I msg:[MAIN] Starting 4 network threads
2013-08-25 21:50:24 I msg:[MICROSERVER] Listening for connection on port 8000
2013-08-25 21:50:24 I msg:[MICROSERVER] Listening for connection on port 8001
2013-08-25 21:50:28 I msg:[SRC 127.0.0.1:17548] SHOUTcast 2 source connection.
2013-08-25 21:50:28 I msg:[SRC 127.0.0.1:17548] Password accepted. Stream id is 1
2013-08-25 21:50:29 I msg:[SRC 127.0.0.1:17548 sid=1] stream configuration complete. [
type=SHOUTcast 2
mimeType=audio/mpeg
maxPayloadSize=16377
avgBitrate=80000
maxBitrate=80000
desiredBufferSize=200
minimumBufferSize=0
icyName=Humphrey
icyGenre=Misc
icyURL=
icyPub=1
]
2013-08-25 21:50:29 I msg:[SRC 127.0.0.1:17548 sid=1] Got complete metadata message type=3902 [432 bytes] id=2 span=1 content=
<?xml version="1.0" encoding="UTF-8" ?>
<metadata><TIT2></TIT2><TPE1>Excision, Downlink, Space Laces </TPE1><TYER>2012</TYER><TENC>SHOUTcast Source DSP v2.3.2.190</TENC><TRSN>Humphrey</TRSN><WORS>http://www.shoutcast.com</WORS><extension><title seq="1"></title><title seq="2">Excision, Downlink, Space Laces - Destroid 2. Wasteland</title><soon>Excision, Downlink, Space Laces - Destroid 2. Wasteland</soon></extension></metadata>
2013-08-25 21:50:57 I msg:[MAIN] Exiting loop
2013-08-25 21:50:57 I msg:[MAIN] Terminating sources (may take up to 10 seconds if required)
2013-08-25 21:50:57 I msg:[MAIN] Runner shutdown
2013-08-25 21:50:57 I msg:<***> Logger shutdown

Humphrey1989 is offline   Reply With Quote
Old 6th January 2016, 19:21   #14
qulixx
Junior Member
 
Join Date: Dec 2015
Posts: 3
i was just dealing with this problem and finally discovered a resolution to it. when you configure the port forwarding on your router you must select TCP and UDP or else externally accessing your DNAS will not work.
qulixx is offline   Reply With Quote
Old 7th January 2016, 23:41   #15
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,290
Quote:
Originally Posted by qulixx View Post
you must select TCP and UDP or else externally accessing your DNAS will not work.
DNAS doesn't use UDP - you probably have a crap router - or no idea what you're talking about

"If you don't like DNAS, write your own damn system"

So I did
jaromanda is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Discussions

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump