Old 22nd February 2012, 23:01   #1
Zba
Junior Member
 
Join Date: Feb 2012
Posts: 1
Winamp crash when opening my plugin's configuration window

Hello,

I'm trying to make a Sound to Serial visualization plugin,
Everything is working as intended excepted for the configuration window.

1- When I try yo open my configuration window and the plugin is not started => Winamp crashes

2- When I quit winamp with my configuration window opened => Winamp crashes

3- WIN32 question : When it opens correctly (if you activate the plugin before opening the configuration window), one of the progressbars I use on the window behave strangely, Do I need to wait or to do something before sending messages to controls ?

Sources : vis_SoundLED1.0.zip

The plugin doesn't do anything on screen, it is used to drive some extenal LED connected to an arduino.

Any help would be appreciated
Zba is offline   Reply With Quote
Old 28th February 2012, 20:33   #2
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,009
Send a message via Skype™ to thinktink
Try the attached version of vis_SoundLED.cpp


No guarantees.
Attached Files
File Type: zip vis_SoundLED.zip (2.3 KB, 241 views)
thinktink is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Developer Center > Winamp Development

Tags
configuration, crash, development, plugin, serial

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump