Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Reply
Thread Tools Search this Thread Display Modes
Old 27th July 2006, 14:46   #41
RejZoR
Senior Member
 
RejZoR's Avatar
 
Join Date: Jun 2006
Location: Europe/Slovenia/Ljubljana
Posts: 148
Nope, none of these two plugins (pmp_p4s or pmp_ipod).

However i can give you all the resident programs running in my tray. It might help.

XFMC - http://www.freewebs.com/spectra9/xfmc.html
Daemon Tools - http://www.daemon-tools.cc
NOD32 - http://www.eset.com
NVIDIA Tray control (part of ForceWare drivers for graphic card)

These 4 programs are running all the time and were also present back then. Still, i never ever got such freezes with 5.22 (i mean EVER). I've been using it for like month and never got this freezing. As soon as i tried 5.25 got the freeze in hour or two...
There was something changed in builds after the 5.22.
I don't know what but something was changed. It's up to WA devs to find out what. All i can is to report the problem.
RejZoR is offline   Reply With Quote
Old 27th July 2006, 17:30   #42
pkerwien
Junior Member
 
Join Date: Jan 2001
Posts: 4
I tested with Winamp 5.25 Beta Build 787 and the second time I tried to quit via the systray winamp freezed => the problem is not fixed.
pkerwien is offline   Reply With Quote
Old 27th July 2006, 18:05   #43
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,823
Damn! What the hell is causing it? And how comes some people can reproduce it so easily, whereas others (like me and benski) can't - as I said, I managed to reproduce it once out of about 20 attempts, but that was when my zen micro was docked at the time (whereas RejZoR says it still happens with no pmp_*.dll plugins present).
Most strange...
DJ Egg is offline   Reply With Quote
Old 27th July 2006, 18:17   #44
tnovak
Junior Member
 
Join Date: Dec 2004
Location: Prague, Czech Republic
Posts: 4
Same here. I can always reproduce it. Start Winamp, start playing some song (MP3 via PL), minimize Winamp, right click - exit - freeze...

Win XP SP2, NOD32, Winamp 5.25 build 787, no pmp_p4s or pmp_ipod
tnovak is offline   Reply With Quote
Old 27th July 2006, 18:25   #45
WildcatRay
Junior Member
 
Join Date: Jun 2006
Location: Columbus, OH
Posts: 22
Send a message via AIM to WildcatRay
FYI-I provide all the required information from my system on this issue either earlier in this thread or elsewhere in the forums. It seems very repeatable on my system.

Windoze 2000, Minefield (Trunk), Firefox 2.0.0.x, Thunderbird 2.0.0.x, avast Antivirus, Sygate Personal Firewall
WildcatRay is offline   Reply With Quote
Old 29th July 2006, 00:33   #46
pkerwien
Junior Member
 
Join Date: Jan 2001
Posts: 4
This is how I can reproduce it:

1. Have Winamp agent running
2. Click on a MP3 file
3. When Winamp starts playing minimize it
4. Right click on the Winamp Agent trayicon and select Exit => Winamp freezes

I think selecting the Winamp Agent icon is the key to the problem.
pkerwien is offline   Reply With Quote
Old 29th July 2006, 09:51   #47
RejZoR
Senior Member
 
RejZoR's Avatar
 
Join Date: Jun 2006
Location: Europe/Slovenia/Ljubljana
Posts: 148
I'm not even using WA Agent...

WinAMP Preferences\General Preferences

Show WinAMP in:

and i have just System Tray checked.
RejZoR is offline   Reply With Quote
Old 29th July 2006, 11:31   #48
WildcatRay
Junior Member
 
Join Date: Jun 2006
Location: Columbus, OH
Posts: 22
Send a message via AIM to WildcatRay
[QUOTE]Originally posted by WildcatRay
Quote:
:Originally posted by WildcatRay
Issue: Winamp 5.24 (Full) freezes on Exit using System Tray Icon menu. It does this regardless of JTFE patch installation to correct exit on hibernate issue. Currently, have a fresh install (Full) without patch or other add-ins/plug-ins installed and still have problem.


Please include all relevant system specs, including:
-PC = Dell 4300
-CPU = 1.6 GHz Pentium IV
-RAM = 512 KB
-Sound card or chip = SoundMAXIntegrated Digital Audio
-Videocard = 16MB ATI Rage 128 Ultra
-Windows OS = Win2K SP4 with ALL updates
-DirectX version = DirectX 9.0c (4.09.0000.0409)
-Winamp version = 5.24
-Confirmation of the Winamp installation type = Full
-Multi-user = Shared, though, not a multiple user PC


Here is some additional information. I had my preferences set to only show Winamp in the System Tray, i.e., when showing Winamp on the Desktop, there was no corresponding Taskbar item/icon, only the System Tray icon. When I checked to also show Winamp in the Taskbar and tried to exit when minimized and Winamp not showing in the Taskbar and only in the System Tray, it exited as expected. Winamp also exits normally with it open on the Desktop and using the System Tray icon menu.
Here is my original post on this issue.

Windoze 2000, Minefield (Trunk), Firefox 2.0.0.x, Thunderbird 2.0.0.x, avast Antivirus, Sygate Personal Firewall
WildcatRay is offline   Reply With Quote
Old 31st July 2006, 10:14   #49
CraigF
Passionately Apathetic
Administrator
 
CraigF's Avatar
 
Join Date: May 2000
Location: Hell
Posts: 5,435
yeah, its fixed for 5.25

CraigF is offline   Reply With Quote
Old 1st August 2006, 11:31   #50
RejZoR
Senior Member
 
RejZoR's Avatar
 
Join Date: Jun 2006
Location: Europe/Slovenia/Ljubljana
Posts: 148
It's not. At least not in this public beta. Don't know for internal versions though but i'd like to test it first before it goes live as 5.25 Final...
RejZoR is offline   Reply With Quote
Old 1st August 2006, 11:58   #51
CraigF
Passionately Apathetic
Administrator
 
CraigF's Avatar
 
Join Date: May 2000
Location: Hell
Posts: 5,435
mkay then

CraigF is offline   Reply With Quote
Old 1st August 2006, 12:08   #52
DrO
 
Join Date: Sep 2003
Posts: 27,873
the fixes we thought would do it are in the public beta so it's got to be something else but since no one can seem to track it down i don't know how things can be fixed and if Egg can only reproduce it sparodically it's even trickier.

i'm in a rush but has anyone tried seeing what happens with just a winamp.exe run with no plugins of any type installed at all and then re-adding things in until the issue happens (assuming it didn't happen with just the winamp.exe on it's own)

-daz
DrO is offline   Reply With Quote
Old 1st August 2006, 14:07   #53
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,823
Yes, I was going to suggest something along those lines.

Move all DLL files out of the Winamp\Plugins folder except for in_mp3.dll, out_wave.dll & out_ds.dll

Note, you can leave these files in the Plugins dir, because they're only used when the relevant plugin is present & calls them:

lame_enc.dll (used by enc_lame)
libmp4v2.dll (used by: in_mp4 / enc_aacplus)
nscrt.dll (used by winamp.exe w/ gen_ff)
nsvdec_vp5/6.dll (used by in_nsv)
read_file.dll (used by in_midi / in_mod)
vms_desktop.dll (used by vis_milk)

Now reopen winamp, play an mp3, minimize to systray, exit.
Does it still freeze?
(try with both DirectSound & WaveOut Output)

If yes, then the problem is most likely in the core...

If no, then start adding plugins back one at a time, closing & reopening winamp inbetween until the problem reoccurs.

Note, CDDBControlWinamp.dll & CDDBUIWinamp.dll (Gracenote CDDB libraries) go with in_cdda.dll (Audio CD support).

A full list of all plugin filenames can be found here & here.

Let us know which plugin causes the problem.

Please also confirm that the Winamp Agent isn't enabled & running
(or temporarily move winampa.exe out of the Winamp root dir).
DJ Egg is offline   Reply With Quote
Old 1st August 2006, 18:24   #54
RejZoR
Senior Member
 
RejZoR's Avatar
 
Join Date: Jun 2006
Location: Europe/Slovenia/Ljubljana
Posts: 148
Ok, i'll torture the WA as you suggested. I'll report asap.
RejZoR is offline   Reply With Quote
Old 1st August 2006, 20:28   #55
RejZoR
Senior Member
 
RejZoR's Avatar
 
Join Date: Jun 2006
Location: Europe/Slovenia/Ljubljana
Posts: 148
Ok, i think i managed to find the problem. Can you just tell me what files exactly are required for Modern Skin and what files are reqired for Media Library.

Well it stopped freezing when all i left in Plugins folder was:
read_file.dll
out_wave.dll
in_mp3.dll

Just these 3 files, nothing else (at all). I just can't make it freeze anymore.
It also kept freezing while there was Moderin Skin enabled and few gen_ml.dll files (thats why i'm asking which ones are for modern skin and which for media library).
Anyway, was there any change in Media Library or Modern Skin since WinAMP version 5.22 ? Because it appears that this is it.

EDIT:
Ok, looks like the problem lies in Modern Skin. I've installed WA without it and it appears to work so far.
Can those with same freezing problem do the same? Remove Modern Skin support and use WA as you usually do before it freezes. Or just remove WA completelly and install it without Modern Skin support.

Last edited by RejZoR; 1st August 2006 at 20:46.
RejZoR is offline   Reply With Quote
Old 1st August 2006, 21:22   #56
CraigF
Passionately Apathetic
Administrator
 
CraigF's Avatar
 
Join Date: May 2000
Location: Hell
Posts: 5,435
removing gen_ff.dll will stop modern skins.

gen_ml.dll is the media library, it loads ml_*.dll plugins though.

If you installed portable support (ml_pmp.dll) that loads pmp_*.dll plugins.

so basically, in ascii.

code:

winamp.exe -> gen_ml.dll -> ml_pmp.dll -> pmp_*.dll
in_*.dll ml_*.dll
out_*.dll
vis_*.dll
dsp_*.dll


CraigF is offline   Reply With Quote
Old 1st August 2006, 22:26   #57
Benski
Ben Allison
Former Winamp Developer
 
Benski's Avatar
 
Join Date: Jan 2005
Location: Brooklyn, NY
Posts: 1,057
Try removing ml_disc.

I've had some weird freeze-up-on-close issues with it in some recent testing.
Benski is offline   Reply With Quote
Old 1st August 2006, 23:38   #58
WildcatRay
Junior Member
 
Join Date: Jun 2006
Location: Columbus, OH
Posts: 22
Send a message via AIM to WildcatRay
I switched from Modern to Classic skin and at least for the first two times I tried exiting via the system tray icon menu, Winamp did, in fact, completely close. I'll let you know if it hangs on me while using the Classic skin.

Windoze 2000, Minefield (Trunk), Firefox 2.0.0.x, Thunderbird 2.0.0.x, avast Antivirus, Sygate Personal Firewall
WildcatRay is offline   Reply With Quote
Old 2nd August 2006, 00:07   #59
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,823
Quote:
Originally posted by RejZoR
Can you just tell me what files exactly are required for Modern Skin and what files are reqired for Media Library.
Quote:
Originally posted by DJ Egg
A full list of all plugin filenames can be found here & here.

@WildcatRay
Hmm, strange. Yes, please let us know if it only happens with the Winamp Modern skin, and not the Classic skin (assuming you weren't using some 3rd-party modern skin previously).
DJ Egg is offline   Reply With Quote
Old 2nd August 2006, 08:35   #60
RejZoR
Senior Member
 
RejZoR's Avatar
 
Join Date: Jun 2006
Location: Europe/Slovenia/Ljubljana
Posts: 148
@Benski
Removing ml_disc.dll doesn't help. WA freezed again on second attempt.

However after i removed gen_ff.dll it stopped freezing. At least it looks that way. I played several files and none caused any problems so far.

Those with frezing problem, just remove gen_ff.dll from Plugins folder to some other location and test. I think i found the evil module.
RejZoR is offline   Reply With Quote
Old 2nd August 2006, 15:58   #61
WildcatRay
Junior Member
 
Join Date: Jun 2006
Location: Columbus, OH
Posts: 22
Send a message via AIM to WildcatRay
Quote:
Originally posted by DJ Egg
@WildcatRay
Hmm, strange. Yes, please let us know if it only happens with the Winamp Modern skin, and not the Classic skin (assuming you weren't using some 3rd-party modern skin previously).
I only use the skins provided by Winamp. The default is Modern and what I had been using until this became known. So far, I have the problem with Modern and do not with Classic.

I'll let you know if anything changes.

Windoze 2000, Minefield (Trunk), Firefox 2.0.0.x, Thunderbird 2.0.0.x, avast Antivirus, Sygate Personal Firewall
WildcatRay is offline   Reply With Quote
Old 2nd August 2006, 16:26   #62
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,823
Ok, thanks for the info. Although I still can't reproduce it (and I only ever use the Winamp Modern skin), Benski says he's got a few ideas... so we shall see.
DJ Egg is offline   Reply With Quote
Old 2nd August 2006, 19:16   #63
RejZoR
Senior Member
 
RejZoR's Avatar
 
Join Date: Jun 2006
Location: Europe/Slovenia/Ljubljana
Posts: 148
It's certanly a modern skin problem. I was using classic one (no gen_ff.dll plugin) and it worked all the time.
As soon as i switched to Modern, it freezed in 4th attempt.
I hope you'll be able to fix it and make sure you guys give us the fixed beta so we can test it thorughly.
RejZoR is offline   Reply With Quote
Old 4th August 2006, 19:03   #64
RejZoR
Senior Member
 
RejZoR's Avatar
 
Join Date: Jun 2006
Location: Europe/Slovenia/Ljubljana
Posts: 148
Using Classic skin for 2 days without a single freeze.
Wish WA team a good hunting for this bugger
RejZoR is offline   Reply With Quote
Old 4th August 2006, 20:04   #65
WildcatRay
Junior Member
 
Join Date: Jun 2006
Location: Columbus, OH
Posts: 22
Send a message via AIM to WildcatRay
Quote:
Originally posted by RejZoR
Using Classic skin for 2 days without a single freeze.
Wish WA team a good hunting for this bugger
I can add the same info (no freezes for at least 2 days now using the Classic skin).

Windoze 2000, Minefield (Trunk), Firefox 2.0.0.x, Thunderbird 2.0.0.x, avast Antivirus, Sygate Personal Firewall
WildcatRay is offline   Reply With Quote
Old 5th August 2006, 00:44   #66
BugMaster
Member
 
Join Date: Jun 2006
Location: Russia
Posts: 63
I also have this problem with Winamp 5.24 but it was fixed in 5.25 Beta (I can't reproduce it in this version). As I understand it was bug in Winamp.exe (Core Module), because when I replace it and files from Winamp\System directory with new one this bug was eliminated (but some of 5.25 Beta bugs appeared, for example crash when executing "Winamp.exe /UNREG" which used in uninstaller). And yes this bug appeared in 5.24 version only with Modern Skin's.

P.S. RejZoR wrote that Winamp 5.25 Beta also has this problem but for me it helps.
BugMaster is offline   Reply With Quote
Old 7th August 2006, 19:06   #67
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,823
Can anyone here please confirm whether the problem still exists after a clean install of 5.25 beta build 801 (just released today).
DJ Egg is offline   Reply With Quote
Old 7th August 2006, 19:55   #68
WildcatRay
Junior Member
 
Join Date: Jun 2006
Location: Columbus, OH
Posts: 22
Send a message via AIM to WildcatRay
Quote:
Originally posted by DJ Egg
Can anyone here please confirm whether the problem still exists after a clean install of 5.25 beta build 801
I just tried it and still had the problem using the 5.25 Full Beta and Modern skin.

I have provided my info, previously here. I did notice that if I did not start playing something, I could exit via the system tray icon. However, as soon as I started playing music (Internet radio, Drone Zone from SomaFM) and tried to exit via the system tray icon, Winamp hung.

Things appear fine using the Classic skin.

Windoze 2000, Minefield (Trunk), Firefox 2.0.0.x, Thunderbird 2.0.0.x, avast Antivirus, Sygate Personal Firewall
WildcatRay is offline   Reply With Quote
Old 7th August 2006, 21:37   #69
GhostMouse
Junior Member
 
Join Date: Oct 2005
Posts: 6
Quote:
Originally posted by WildcatRay
I just tried it and still had the problem using the 5.25 Full Beta and Modern skin.

I have provided my info, previously here. I did notice that if I did not start playing something, I could exit via the system tray icon. However, as soon as I started playing music (Internet radio, Drone Zone from SomaFM) and tried to exit via the system tray icon, Winamp hung.

Things appear fine using the Classic skin.
Heve the same problem :X


(in clean install)
GhostMouse is offline   Reply With Quote
Old 7th August 2006, 21:47   #70
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,823
Ok, we think we've found the problem and got it fixed now.
Unless there's another public beta released, the fix will be in 5.25 Final.
DJ Egg is offline   Reply With Quote
Old 7th August 2006, 23:21   #71
Benski
Ben Allison
Former Winamp Developer
 
Benski's Avatar
 
Join Date: Jan 2005
Location: Brooklyn, NY
Posts: 1,057
If you're already using Winamp 5.25 (beta build 787 or 801), then you can unzip this file into your winamp directory. Please let me know if this fixes the problem (or if it doesn't!)
Benski is offline   Reply With Quote
Old 8th August 2006, 17:12   #72
WildcatRay
Junior Member
 
Join Date: Jun 2006
Location: Columbus, OH
Posts: 22
Send a message via AIM to WildcatRay
Quote:
Originally posted by Benski
If you're already using Winamp 5.25 (beta build 787 or 801), then you can unzip this file into your winamp directory. Please let me know if this fixes the problem (or if it doesn't!)
So far it appears to. I have tried it several times (Modern skin, system tray only, exit using system tray menu) and it worked fine (did not freeze on exit).

Windoze 2000, Minefield (Trunk), Firefox 2.0.0.x, Thunderbird 2.0.0.x, avast Antivirus, Sygate Personal Firewall
WildcatRay is offline   Reply With Quote
Old 8th August 2006, 17:56   #73
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,823
Yay! :-)
DJ Egg is offline   Reply With Quote
Old 8th August 2006, 19:10   #74
tnovak
Junior Member
 
Join Date: Dec 2004
Location: Prague, Czech Republic
Posts: 4
Quote:
Originally posted by WildcatRay
So far it appears to. I have tried it several times (Modern skin, system tray only, exit using system tray menu) and it worked fine (did not freeze on exit).
Same here - no freeze! Good work!
tnovak is offline   Reply With Quote
Old 9th August 2006, 11:28   #75
RejZoR
Senior Member
 
RejZoR's Avatar
 
Join Date: Jun 2006
Location: Europe/Slovenia/Ljubljana
Posts: 148
Still testing, need some time...
RejZoR is offline   Reply With Quote
Old 12th August 2006, 14:51   #76
RejZoR
Senior Member
 
RejZoR's Avatar
 
Join Date: Jun 2006
Location: Europe/Slovenia/Ljubljana
Posts: 148
Ok, i think it's ok now. Haven't encountered any freeze so far. Thats a good sign
RejZoR is offline   Reply With Quote
Old 12th August 2006, 16:43   #77
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,823
Yup, it's definitely fixed now :-)
DJ Egg is offline   Reply With Quote
Old 12th August 2006, 16:58   #78
Bubba Smith
Major Dude
 
Bubba Smith's Avatar
 
Join Date: Apr 2006
Location: Bubbaville, USA
Posts: 599
@ Egg or Benski...

Is the fix that Benski linked to above now present in the lastest 812 build? I ask because a few posts above it only mentions Winamp 5.25 (beta build 787 or 801).

Has it already been incorporated into 5.25 beta build 812? Or do we still need to download the fix after installing build 812?
Bubba Smith is offline   Reply With Quote
Old 12th August 2006, 17:02   #79
DrO
 
Join Date: Sep 2003
Posts: 27,873
i believe b812 should have that fix in it (since it was mentioned in the changelog as well)

-daz
DrO is offline   Reply With Quote
Old 12th August 2006, 17:17   #80
Bubba Smith
Major Dude
 
Bubba Smith's Avatar
 
Join Date: Apr 2006
Location: Bubbaville, USA
Posts: 599
Okay. Thanx!
Bubba Smith is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump