Old 4th June 2007, 08:34   #1
eremos
Junior Member
 
Join Date: Jun 2007
Posts: 4
Winamp forgets to be always on top

When Winamp is set not to appear in the taskbar and I press Win+D (show desktop), Winamp appears below other windows, even though Winamp is supposed to be "Always on top".

OS: Windows XP Pro SP2

To reproduce:
Set Winamp to not appear in the taskbar
(bug appears regardless of system tray icon setting)
Set Winamp to be always on top
Confirm that Winamp will stay on top of another window
Press Win+D
Restore a window
Winamp no longer stays on top, even though Always on top remains set
Unset and set Always on top
Winamp again stays on top of other windows

Additional observations:
If you click on the winamp tray icon before restoring any other windows, Winamp does stay on top. But clicking on the tray icon AFTER restoring another window doesn't make it go back on top.
eremos is offline   Reply With Quote
Old 4th June 2007, 13:44   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,823
We can't reproduce the problem.

Is "Disable 'Always on top' while fullscreen apps are focused" checkmarked in: Winamp > Prefs (Ctrl+P) > General Preferences?

If yes, then uncheck it.

('Show Desktop' is equivalent to/classed as a fullscreen app)


If not, then are there any other apps running which have an 'always on top' feature?

Are you using any Shell Enhancement or Desktop Management type software?
DJ Egg is offline   Reply With Quote
Old 4th June 2007, 13:59   #3
eremos
Junior Member
 
Join Date: Jun 2007
Posts: 4
Ah, it was checked, and behaves as expected with that disabled.

I had not realised that about Show Desktop and thus hadn't looked at that option before.

Thanks
eremos is offline   Reply With Quote
Old 20th July 2007, 01:24   #4
Vatigu
Junior Member
 
Join Date: Nov 2006
Location: Canada
Posts: 3
I have this problem in docked mode. I have tried with the "disable always on top when full screen application is focused" option on or off. Regardless of this option always on top disables and stays disabled.

The option remains checked (in the docked toolbar settings) but it is still not always on top.

Which results in having to unckeck it renavigate to it and check it again to cause the player to stay on top of other windows.

In the screenshot Both always on top options (one in the options and one in the docked toolbar settings) are checked and the "disable always on top when full screen applications are focused" is disabled
Attached Images
File Type: jpg winamp.jpg (65.8 KB, 1127 views)
Vatigu is offline   Reply With Quote
Old 9th October 2007, 11:10   #5
BastiG
Junior Member
 
Join Date: Oct 2007
Posts: 1
I have this problem, too. When I am in docked mode winamp sometimes looses its always on top. "disable always on top when full screen application is focused" is disabled. I noticed that the problem occurs when I work with the Eclipse IDE for some time (in full screen mode).
BastiG is offline   Reply With Quote
Old 15th October 2007, 08:42   #6
postertag
Junior Member
 
Join Date: Mar 2006
Posts: 8
I have the same problem. Just after Winamp start focus any window. For example Firefox. Windows stops to be on top. When you focus Winamp and toggle off/on "always on top" (Ctrl+A), everything works fine. Firefox can't be set to be always on top, so it does not depend on "Disable 'Always on top' while fullscreen apps are focused" functionality. I do not know exactly when this bug occurred for the first time, but I guess Winamp 5.3.
postertag is offline   Reply With Quote
Old 16th October 2007, 21:05   #7
kefka900
Junior Member
 
Join Date: Oct 2007
Posts: 25
I have the same problem. Seems random to me, I'll tap the top of the screen and it pops down behind other windows. Either i have to exit winamp and reload or uncheck/recheck stay always on top. This is on vista. I don't have any other full screen apps playing. Usually just World of warcraft in window mode, maximized. This seemed to appear in 5.5 for me.
kefka900 is offline   Reply With Quote
Old 19th October 2007, 14:22   #8
kefka900
Junior Member
 
Join Date: Oct 2007
Posts: 25
Quote:
Originally posted by DJ Egg
We can't reproduce the problem.

Is "Disable 'Always on top' while fullscreen apps are focused" checkmarked in: Winamp > Prefs (Ctrl+P) > General Preferences?


If yes, then uncheck it.


('Show Desktop' is equivalent to/classed as a fullscreen app)



If not, then are there any other apps running which have an 'always on top' feature?


Are you using any Shell Enhancement or Desktop Management type software?
Have you been able to reproduce this? It happens several times a day. I don't run any full screen apps. Any other info you want?
kefka900 is offline   Reply With Quote
Old 5th November 2007, 23:00   #9
benny_burny
Junior Member
 
Join Date: Nov 2007
Posts: 5
I have the same problem - any solution?
benny_burny is offline   Reply With Quote
Old 6th November 2007, 19:11   #10
Easyman
Junior Member
 
Join Date: Jan 2003
Posts: 21
Similar problem here..

I have WinAmp running in Windowshade Mode and would like to have it always on top so I activated this option. After activating it, WinAmp is on top for some time but after a while it isn't anymore (but the option is still active). I couldn't figure out what causes WinAmp to forget about being always on top. I'm not running any fullscreen software, just working in Windows.
Easyman is offline   Reply With Quote
Old 6th November 2007, 20:16   #11
kefka900
Junior Member
 
Join Date: Oct 2007
Posts: 25
1100 hits on this thread. Can we get some feedback?
kefka900 is offline   Reply With Quote
Old 14th November 2007, 23:26   #12
kefka900
Junior Member
 
Join Date: Oct 2007
Posts: 25
Any news?
kefka900 is offline   Reply With Quote
Old 14th November 2007, 23:36   #13
postertag
Junior Member
 
Join Date: Mar 2006
Posts: 8
at least "we are examining this"...
postertag is offline   Reply With Quote
Old 19th November 2007, 20:51   #14
Easyman
Junior Member
 
Join Date: Jan 2003
Posts: 21
Quote:
Originally posted by Easyman
I'm not running any fullscreen software, just working in Windows. [/B]
I forgot that my Windows Screensaver was active, which is an fullscreen application. After the Screensaver was running, Winamp is not on top anymore, but the option is still active. Disabling the "disable always on top while fullscreen applications are focused" setting solves the problem, but that can't be it. It should also work if that option is enabled.
Easyman is offline   Reply With Quote
Old 2nd December 2007, 09:59   #15
lordicarus
Member
 
Join Date: Jul 2000
Location: Mahopac,Ny
Posts: 81
Send a message via ICQ to lordicarus
I have the same problem. To elaborate further...


Windows Vista, Windows XP SP2, Windows Vista SP1 Beta
Winamp 5.5 - Bento


When I have "Disable when running fullscreen apps" checked on, winamp stays on top until i hit Win+D or Win+Tab and then it disappears. It then refuses to stay on top of anything until I change skin, check and uncheck stay on top, maximize then minimize the skin, or restart winamp.

This is quite annoying, and easily reproducable on multiple computers of my own.
lordicarus is offline   Reply With Quote
Old 12th December 2007, 22:57   #16
Themer
Junior Member
 
Join Date: Dec 2007
Location: Germany
Posts: 2
Same problem here, but for me it *only* happens when using Classic or Bento Skin.
("Disable always on top while fullscreen applications are focused" is *disabled* (not checkmarked))


Classic / Bento Skin ("always on top" is activated):

- starting winamp.exe directly = Winamp starts, Winamp is on top, "always on top" working like it should

- starting .mp3 = Winamp starts, but minimized, "always on top" is activated but *not working* (Ctrl+A twice ("always on top" activated/deactivated)) = Winamp stays on top (working like it should).


Modern Skin (always on top" is activated):

- starting winamp.exe directly = Winamp starts, Winamp is on top, "always on top" working like it should

- starting .mp3 = Winamp starts on top, "always on top" is activated *and* is working like it should

System: Windows Vista 32bit
Winamp: v5.51 build 1741 Beta

This issue is very nasty, would be nice to see that fixed... :-)
Themer is offline   Reply With Quote
Old 21st December 2007, 17:26   #17
postertag
Junior Member
 
Join Date: Mar 2006
Posts: 8
It seems it works

I have just installed Winamp 5.51 and it stays on top as it should. Seems to be fixed.
postertag is offline   Reply With Quote
Old 18th January 2008, 14:52   #18
Themer
Junior Member
 
Join Date: Dec 2007
Location: Germany
Posts: 2
Sorry for getting back late to the issue...

The issue is not fixed with v5.51 and v5.52 Final.

I can reproduce that this bug is still existing with exactly the same behavior as mentioned by me in this thread before.

- *only* happens when using Classic or Bento Skin (in other words: this is not happening when using modern skin)
- Operating System: Windows Vista 32bit (I do not know if this is bug is existing in other Operating System environments)

Due to the fact that this is not happening with modern skin I do think that this is really a bug of Classic and Bento Skin.
Themer is offline   Reply With Quote
Old 19th January 2008, 03:03   #19
kabutar
Junior Member
 
Join Date: Sep 2005
Posts: 18
I've got the same thing happening. I tried a different skin (SimpleX)and it works perfectly... seems to be a skin bug?

Win Vista, Winamp 5.52, Bento/Big Bento, Always On Top/Auto Hide on, docked top in regular mode.

My problems occur with Firefox and/or Windows Explorer, etc. Seems random - sometimes, with Winamp docked at the top, when focusing Firefox, Winamp slides back up like it should and in those cases it remains on top. However other times it just disappears (as another application would when losing focus) and then I have to click the systray icon to bring it back on top. This happens whether or not I focus Winamp after bringing it down from autohide mode and really seems entirely random.
kabutar is offline   Reply With Quote
Old 5th February 2008, 12:33   #20
eturfboer
Junior Member
 
Join Date: May 2004
Posts: 21
I can confirm that the 'always on top' function is ignored if one would use the alt + tab combination; restoring always on top functionality is back after disabling (ctrl+a) and enabling (ctrl+a) it.

Here, the windows+tab does not let the always on top function to be ignored. Although this is not Vista, but XP.

My 'disable with other full screen apps' option is enabled.

For me it seems independent from the program I use that winamp ignores the always on top function. Furthermore I cannot confirm that the bug depends on the skin (Bento, Bento large, Modern and Classic), they all have the same issue.

I think the issue is cause in the option not to show up in the taskbar, but in the systemtray. Or at least has partially to do with it. If taskbar is enabled, the windows+d goes and ignores the always on top. Letting winamp re-appear (wether by taskbar, alt+tab or system tray). The only difference is that showing with the systemtray does not re-set the always on top.

The rest (randomly disapearing winamp) seems to be an other bug.

I am on:
Windows XP Professional
using:
Winamp 5.52 Bento.
eturfboer is offline   Reply With Quote
Old 23rd February 2008, 02:34   #21
imperia
Junior Member
 
Join Date: Sep 2007
Posts: 9
Send a message via ICQ to imperia
I have similar issue. I like to drag and drop mp3 links from firefox to winamp so I listen them without downloading. I have noticed that very often it loses its "stay on top" functionality.
imperia is offline   Reply With Quote
Old 24th February 2008, 08:59   #22
MADH
Junior Member
 
Join Date: Feb 2008
Posts: 1
When Winamp is in docked mode and "Always on top" and "Disable always on top while fullscreen applications are focused" are enabled, Winamp's docked window loses it's WS_EX_TOPMOST style bit when some fullscreen "always on top" window (for example Media Player Classic) is created.

In normal mode WS_EX_TOPMOST bit is correctly restored when fullscreen window is closed, but in docked mode the bit somehow disappears.

For me, it seems that the error is not reproducible when "Disable always on top while fullscreen applications are focused" is disabled.
MADH is offline   Reply With Quote
Old 25th February 2008, 19:28   #23
j_jorgensen
Junior Member
 
Join Date: Feb 2008
Location: Denmark
Posts: 2
I have the same problem. On Vista 32 bit, with Winamp v. 5.52...please do something :-)
j_jorgensen is offline   Reply With Quote
Old 5th March 2008, 21:58   #24
Ponzio
Junior Member
 
Join Date: Mar 2008
Location: Philly
Posts: 7
used the Global Hotkey feature until they get a fix and who knows? maybe the registry will integrate the function after a couple of restarts [stranger things have happened].

lets face it, winamp [god love them] since 5.1 has been a bit buggy.

still the best though.
Ponzio is offline   Reply With Quote
Old 5th March 2008, 22:09   #25
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,823
We still can't reproduce the problem.
At a guess, some other app is running concurrently which also has an 'always on top' feature (eg. ObjectDock, as in this case).
Or maybe you've installed some 3rd-party Winamp plugin which is messing things up...?
Please confirm a clean install, or at least attach your List of Plugins.
DJ Egg is offline   Reply With Quote
Old 6th March 2008, 09:28   #26
eturfboer
Junior Member
 
Join Date: May 2004
Posts: 21
Quote:
Originally posted by DJ Egg
We still can't reproduce the problem.
At a guess, some other app is running concurrently which also has an 'always on top' feature
That is weird. I happens very often. As far as I know I have two programs running that uses this always on top feature, that is Trillian and KMPlayer. However, when I close these program it still occurs. I will post a full list of my plug-ins when I get home, then we can compare.
eturfboer is offline   Reply With Quote
Old 7th March 2008, 00:23   #27
Ponzio
Junior Member
 
Join Date: Mar 2008
Location: Philly
Posts: 7
FWIW

feature now works, without the HotKey function,24/7 after above said changes and 2 restarts ... go figure!
Ponzio is offline   Reply With Quote
Old 9th October 2009, 18:40   #28
nedharding
Junior Member
 
Join Date: Oct 2009
Posts: 2
I can replicate this every time with remote desktop. Put winamp always on top.

Maximize & Restore Remote desktop 3 times. On the 3rd time winamp will fall behind the remote desktop session.

I am using ver. 5.56
nedharding is offline   Reply With Quote
Old 18th March 2010, 19:57   #29
j_jorgensen
Junior Member
 
Join Date: Feb 2008
Location: Denmark
Posts: 2
Still happens... pleeeeeeeeeeeeeease do something about this!
j_jorgensen is offline   Reply With Quote
Old 17th April 2010, 21:06   #30
bbr
Junior Member
 
bbr's Avatar
 
Join Date: Aug 2002
Posts: 16
Anyhow... This problem still persists in Winamp version 5.572 (latest version)
According to the changelog some attempts to fix this have been made.
"- Misc: Further attempts to fix reported elevation/registration issues on Vista & Win7"
However, they've not helped at all.
It's been an issue for the past 3 years, and yes it's quite frustrating anytime it happens.


The most common cause, is when you alt-tab back and forth with a fullscreen application, such as a game. Perhaps a workaround could be invented if the bug itself can not be found/resolved?
It's not exactly critical or life threatening, but a longstanding, very annoying bug like this... Would be nice to see it finally fixed.


I'm running: Windows Vista 64, no winamp agent.
Showing taskbar icon or not has no relevance to the issue. Unlike what another user reported.
I'm not running any winamp plugins other than those installed by winamp itself. So I doubt those have any effect either.
Custom skin: Winamp Modern
Only have the main window active, in it's minimized form.
I generally play an internet stream from di.fm , doubt that's got any effect, but you never know.


Instant, and easy to reproduce steps:
1: Start winamp (duh)
2: Set winamp to "always on top"
3: Start firefox or whatever (you probably got that done as well since you're reading this)
4: Start a fullscreen game. In my case, I just start world of warcraft, or Torchlight through Steam. Anything works really, I guess.
5: Alt-tab back to firefox.

And presto! Winamp is suddenly behind Firefox, and will remain there until you tell it to remain on top again. Hopefully this helps in reproducing the issue, and thus making it easier to fix for the next version.

Last edited by bbr; 17th April 2010 at 21:25. Reason: steps to reproduce
bbr is offline   Reply With Quote
Old 17th April 2010, 22:35   #31
vero216
Banned
 
Join Date: Apr 2010
Location: London
Posts: 9
I run the same version of winamp(version 5.572) with no problems os(xp sp3).
vero216 is offline   Reply With Quote
Old 28th April 2010, 18:06   #32
laurent22300
Junior Member
 
Join Date: Apr 2009
Posts: 30
Quote:
We can't reproduce the problem.
This is very surprising. I always had this problem with Winamp - under Win 98, XP and now Windows 7. It usually happens very soon after having started Winamp and I'm not running any other "Always on top" application.

Pressing CTRL + A twice makes the windows reappear on top though (but it always go back below after some time) so perhaps an idea would be to programmatically disable and re-enable the "always on top" feature every x seconds?
laurent22300 is offline   Reply With Quote
Old 6th May 2010, 13:20   #33
nkarafo
Junior Member
 
Join Date: May 2010
Posts: 2
Hey Winamp editors / moderators / programmers is there any solution to this? A lot of people have this issue. Can you please fix it?

Thank you!!!!!!!!
nkarafo is offline   Reply With Quote
Old 10th July 2010, 14:28   #34
bbr
Junior Member
 
bbr's Avatar
 
Join Date: Aug 2002
Posts: 16
I just watched a few videos in the windows media player, fullscreen.
When I came back, winamp was in the background again.
However.. The playlist was still on top (as the winamp main screen should have been).

Clicking the playlist did not bring it back on top, clicking the winamp icon from the taskbar did.
Ctrl+A, followed by Ctrl+A to toggle off + on the always stay on top flag puts it back to the top..


This bug is weird, but seems mostly related to other processes taking up the fullscreen mode. Surely this should be reproduceable?


Please don't forget about this issue guys ^_^
bbr is offline   Reply With Quote
Old 15th January 2011, 13:34   #35
bbr
Junior Member
 
bbr's Avatar
 
Join Date: Aug 2002
Posts: 16
Issue still persists, half a year later.

Over 3 years since it's initial report. :|
bbr is offline   Reply With Quote
Old 28th February 2011, 17:59   #36
bbr
Junior Member
 
bbr's Avatar
 
Join Date: Aug 2002
Posts: 16
Perhaps this will help in reproducing, and solving the issue.

http://www.youtube.com/watch?v=0ONJf...rec_grec_index

Any youtube video, in firefox, when you click the fullscreen mode button pushes winamp to the background. Once you close the fullscreen mode in youtube (esc), winamp stays in the background.
bbr is offline   Reply With Quote
Old 3rd August 2011, 03:35   #37
CBI Elite
Junior Member
 
Join Date: Aug 2011
Posts: 1
Come ON people, I've been having this same issue for years. Since my first personal desktop back in 2006, and there still is no resolution. I don't get it!

Just updated to the newest version a week ago (5.621) and the issue still remains; randomly after clicking the "go to desktop" shortcut in Windows 7 x64, Alt-Tab'ing and at other times, AOT fails in Winamp.

I *love* this player, and if I meet anyone from Nullsoft I'd buy them a Canadian beer, but this is silly folks! Hopefully a solution is found soon, cheers.
CBI Elite is offline   Reply With Quote
Old 3rd August 2011, 04:54   #38
KitD17
Junior Member
 
Join Date: Aug 2011
Posts: 3
I made 2 posts on how to fix this 1 is waiting to be reviewed by moderators for some crazy reason, made on on this thread that didn;t go through I'm done sorry.
KitD17 is offline   Reply With Quote
Old 6th September 2011, 18:33   #39
bbr
Junior Member
 
bbr's Avatar
 
Join Date: Aug 2002
Posts: 16
Start debugger, set watchpoint on the variable that determines always on top.

Start youtube fullscreen, go afk for an age, try some other fullscreen things like the windows slideshow, play some halflife, quake, alien breed, heck - any game that goes fullscreen.

And see when the watchpoint is triggered.

This problem still persists, many users have the issue, we can even reproduce it in a semi reliable fashion.
Please put some time into finding this bug guys... It's very frustrating.

Not as important as actual crashes, but still - this bug has been around for YEARS now. :/
bbr is offline   Reply With Quote
Old 11th September 2011, 06:09   #40
CSR
Junior Member
 
Join Date: Sep 2011
Posts: 1
Hi!
I have the same problem! But I have this problem after I install this plugin: http://www.winamp.com/plugin/winampac3/221648
When I uninstall plugin the AOT is work right again!
CSR is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump