Old 23rd March 2010, 16:29   #1
MrNobodyWTB
Junior Member
 
Join Date: Mar 2010
Location: USA-Nevada
Posts: 2
Send a message via AIM to MrNobodyWTB Send a message via MSN to MrNobodyWTB Send a message via Yahoo to MrNobodyWTB
Error compiling ps_2_0 warp shader

My problem:

I can't even get Milkdrop to run (running latest winamp version)

error:

Error compiling ps_2_0 warp shader:

Your hardware says that it supports shader model 3.0 [PSVersion=0x300],
but it doesn't seem to do it properly -
maybe your display driver is just buggy.

You might want to try updating your display driver
to the latest WHQL driver from the chipset manufacturer
(Nvidia, ATI, etc.)

***

I've updated to latest graphics drivers etc and I still get the same error, any help would be greatly appreciated (updated to latest from ASUS, ATI tells me to go to the maker of the laptop for updated graphics)

I have an ASUS K52Jr (also advertised as an A52Jr)

ATI M Radeon 5470 1GB
Intel Core i5 430m
4GB DDR3
Windows 7 Home Premium


again, thank you for any help
MrNobodyWTB is offline   Reply With Quote
Old 23rd March 2010, 18:34   #2
Nitorami
Major Dude
 
Join Date: Mar 2008
Location: Erlangen
Posts: 848
Try to override the automatic detection by forcing pixel shader to model 2 or 1 under visualisation/configure plug-in/more settings. That should at least make it run, but be aware that then you won't get to see most of the newer presets.
Nitorami is offline   Reply With Quote
Old 23rd March 2010, 21:12   #3
MrNobodyWTB
Junior Member
 
Join Date: Mar 2010
Location: USA-Nevada
Posts: 2
Send a message via AIM to MrNobodyWTB Send a message via MSN to MrNobodyWTB Send a message via Yahoo to MrNobodyWTB
that did not work, but I did disable pixel shading altogether and it worked.

good for a quick fix to get it working (I'm trying to use MD for VJing), so I'm going to look for different drivers for the ATI card, I heard about special 3rd party drivers that have been released that makes ATI chips function better, idk. but I'll look into it. Thanks for the help, and I'm still open for any tips or tricks you guys might have
MrNobodyWTB is offline   Reply With Quote
Old 25th April 2010, 18:34   #4
blandrys
Junior Member
 
Join Date: Apr 2010
Posts: 1
I had the same problem and came upon this page since it came first on my google search. updating the graphics driver alone didn't help me, but downloading the latest version of directX did. so try that :
http://www.microsoft.com/downloads/e...D-85FC422D1388
blandrys is offline   Reply With Quote
Old 8th October 2010, 06:22   #5
Bue11er
Junior Member
 
Join Date: Oct 2010
Posts: 2
I have Winamp 5.581, and Milkdrop wouldn't work. "Warp shader" wouldn't go. For those of you who have Vista 64 (like I do) or Win 7, you probably have DirectX 11, which is not backward compatible. Visit <http://www.dasmirnov.net/blog/sometimes-you-need-to-install-directx> for a clear explanation of what Microsoft has done with DirectX. To fix it, I downloaded a redistribution of DirectX 9.0c - mine was called "directx_Jun2010_redist." You don't have to uninstall DirectX 11 - it will install alongside DirectX 11. Now, Milkdrop works well!
Bue11er is offline   Reply With Quote
Old 24th February 2011, 21:41   #6
stuhlkontakt
Junior Member
 
Join Date: Feb 2011
Posts: 1
got it

hi, for those who got the prob with milkdrop in the german winamp version: I installed the us/eng version and see, it works well.
stuhlkontakt is offline   Reply With Quote
Old 4th March 2011, 01:03   #7
Alphasee
Junior Member
 
Join Date: Feb 2004
Location: Somewhere Deep Inside a Script
Posts: 5
Another Solution

Although tedious, upgrading all the presets to pixel shader v4 seems to work -very- well.
Alphasee is offline   Reply With Quote
Old 26th September 2011, 03:03   #8
Clancy
Junior Member
 
Join Date: Oct 2007
Posts: 34
Quote:
Originally Posted by Alphasee View Post
Although tedious, upgrading all the presets to pixel shader v4 seems to work -very- well.
You could use an app such as notepad ++ or wingrep that automates find-and-replace in multiple files.
Clancy is offline   Reply With Quote
Old 15th May 2012, 09:46   #9
cheng
Junior Member
 
Join Date: May 2012
Posts: 1
effective

well effective ung link na ito para makita mo na ang visualization...
http://www.microsoft.com/en-us/downl...ion.aspx?id=35
cheng is offline   Reply With Quote
Old 6th May 2016, 10:50   #10
Cet Turl Xtreme
Junior Member
 
Join Date: Feb 2016
Posts: 27
Again... i have a problem again...
Cet Turl Xtreme is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Visualizations > MilkDrop > MilkDrop Troubleshooting Forum

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump