Prev Previous Post   Next Post Next
Old 8th February 2012, 21:35   #11
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,658
Hi DrO,

If you read this when you get back, I hope you enjoyed your break. I don't expect you to get deeply involved in this issue. You already do enough on your own dime. I'm hoping someone who knows the code or knows a work-around would respond.

For rebuilding a library or doing a Gracenote scan of a large collection (several thousands), the work-around is to monitor memory usage and stop and restart WA (and the scan) as needed. For scrolling through a lot of art, there is no work-around, the user must have enough available RAM to support the memory needed to avoid a crash. Using a file storage scheme that requires less art and/or using small size art only increases the time before available RAM becomes inadequate to support the app.

In my case, I use a classic skin and plug-in that displays only the image for the selected track when I start WA. Memory usage (around 37 MB) is small and consistent with the other plug-ins I use. It stays around 40 MB if I never open a panel that displays multiple art images. When I open my library panel that displays multiple art images, my art cache file (art_120.dat 225 MB) is loaded and memory usage rises to around 290 MB, consistent with the size of my cache.

If I scroll through all of my album art (only 6,186 files and a few hundred images), there is very little or no delay in displaying the images and memory rises to around 544 MB. This leads me to assume that all my art is not cached and direct reading and rendering is fast on my system (4 core CPU 3 GHz, 460GTX GPU, & 4 GB RAM). If I then close the library panel memory usage drops to around 300 MB, consistent with the art cache remaining in memory and the extra memory for the art not in the cache being released.

I can understand reasons for keeping the art cache in memory for several minutes, but after more than a half hour, with the library panel still closed, the art cache is still not released. After more than a hour, memory usage is still around 300 MB. This leads me to assume that once the art cache is loaded, it is never released.

For me this is not yet a problem. However, for those with large collections who use skins (or keep panels open) that display multiple art images, allowing memory usage related to album art to rise unchecked could be a problem. If this is by design, the WA system requirements for RAM (256 MB minimum - 500 MB or more recommended) need to be changed. Maybe 500 MB minimum and 1 GB or more recommended.

Winamp Pro v5.666.3516 fully-patched - Komodo X Touchscreen v1.0 by Victhor skin
Windows 10 Home 64-bit v1809 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
 
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump