Old 17th February 2002, 23:40   #1
krayzie
Junior Member
 
Join Date: Feb 2002
Posts: 8
Winamp freezes when i try to add a song to my list

How come my winamp freezes when i try to add a song to my playlist. i had 2.77 and it did dat and then when i upgraded to 2.78. can anyone help me plz
krayzie is offline   Reply With Quote
Old 17th February 2002, 23:43   #2
Sawg
Guest
 
Posts: n/a
Sound like a bad plug. Delete any third party plug-ins and completely un-install and re-install Winamp.

Uninstall -> Reinstall procedure:
http://forums.winamp.com/showthread.php?threadid=50818

Troubleshooter Guides:
http://forums.winamp.com/showthread....827#post275827
http://forums.winamp.com/showthread....166#post308166
  Reply With Quote
Old 17th February 2002, 23:44   #3
henry3k56
Forum King
 
henry3k56's Avatar
 
Join Date: Sep 2001
Location: The Internet Posts: 3 Trillion
Posts: 4,241
Have you tried to add songs at all to the Playlist before?

henry3k56 | Summer is here.
My Flickr Page & Frontierra | Posting Since September 2001.
henry3k56 is offline   Reply With Quote
Old 17th February 2002, 23:54   #4
krayzie
Junior Member
 
Join Date: Feb 2002
Posts: 8
i reinstalled. i could add a songs, but once i loaded my playlist the same problem happened again. meanin i couldn't load any songs to my playlist
krayzie is offline   Reply With Quote
Old 18th February 2002, 00:08   #5
Sawg
Guest
 
Posts: n/a
make sure it is a COMPLETE re-install.

Run scandisk
run a virus scanner
  Reply With Quote
Old 18th February 2002, 00:12   #6
krayzie
Junior Member
 
Join Date: Feb 2002
Posts: 8
did all dat already
krayzie is offline   Reply With Quote
Old 18th February 2002, 00:16   #7
krayzie
Junior Member
 
Join Date: Feb 2002
Posts: 8
would it big a problem if my folder i am tryin to add from is a couple gigs big?
krayzie is offline   Reply With Quote
Old 18th February 2002, 00:16   #8
Sawg
Guest
 
Posts: n/a
What version of Windows?
Define "freeze"
How do you add song? Right click? Drag and drop? open dialog?

TSGH > Offical Winamp2 Buglist


Latest updates : 07/10/01 +

Win2k/XP random shutdown problems - v2.77 / 2.78 only
(with drag+drop files from Open Files Dialog)

http://forums.winamp.com/showthread.php?threadid=73596
http://forums.winamp.com/showthread.php?threadid=61560
http://forums.winamp.com/showthread.php?threadid=61748
http://forums.winamp.com/showthread.php?threadid=61833
http://forums.winamp.com/showthread.php?threadid=61863
http://forums.winamp.com/showthread.php?threadid=61955
http://forums.winamp.com/showthread.php?threadid=67283

Similar problem using Rt click -> Enqueue in Open Files dialog
http://forums.winamp.com/showthread.php?threadid=62127
  Reply With Quote
Old 18th February 2002, 00:18   #9
krayzie
Junior Member
 
Join Date: Feb 2002
Posts: 8
i have windows ME
freeze meaning my winamp isn't responding... thus i have to ctrl atl del to end task it. i add songs by using the bottom left button
krayzie is offline   Reply With Quote
Old 18th February 2002, 00:18   #10
Sawg
Guest
 
Posts: n/a
Quote:
Originally posted by krayzie
would it big a problem if my folder i am tryin to add from is a couple gigs big?
Ahh ha

Preferences (Ctrl-P) > Options > "Read titles on" > Play

When Winamp is reading a couple gigs of ID3 tags it will look like it's frozen. If you give it time it should come back.
  Reply With Quote
Old 18th February 2002, 00:25   #11
krayzie
Junior Member
 
Join Date: Feb 2002
Posts: 8
the drag and drop wroks... it gave it like 5 misn and it still didn't work. when i ctrl alt del it says the program is [not responding]
krayzie is offline   Reply With Quote
Old 18th February 2002, 00:28   #12
henry3k56
Forum King
 
henry3k56's Avatar
 
Join Date: Sep 2001
Location: The Internet Posts: 3 Trillion
Posts: 4,241
Re-download Winamp, that the next step to see if Winamp doesn't crash.

henry3k56 | Summer is here.
My Flickr Page & Frontierra | Posting Since September 2001.
henry3k56 is offline   Reply With Quote
Old 18th February 2002, 00:30   #13
krayzie
Junior Member
 
Join Date: Feb 2002
Posts: 8
before i even posted i already reinstalled 3 times and downloaded 2.78 a couple of times too
krayzie is offline   Reply With Quote
Old 18th February 2002, 00:30   #14
Sawg
Guest
 
Posts: n/a
Quote:
Originally posted by sawg

Preferences (Ctrl-P) > Options > "Read titles on" > Play
  Reply With Quote
Old 18th February 2002, 00:34   #15
krayzie
Junior Member
 
Join Date: Feb 2002
Posts: 8
i did that already
krayzie is offline   Reply With Quote
Old 18th February 2002, 16:08   #16
ironlung
Junior Member
 
Join Date: Feb 2002
Location: pittsburgh, pa
Posts: 3
The exact same thing is happening to me...it just started when i downloaded the 2.78 version...My folders are also really big (13 gigs)...It was only doing it with my morpheus shared folder and i could still open some of them...so i tried moving all my files to the folder that worked and now it doesn't work...just wondering if you anyone knows the problem.
ironlung is offline   Reply With Quote
Old 18th February 2002, 21:25   #17
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
A few possible reasons for why this is happening....

1) Are ALL the files in this folder MP3's, or are there any formats in there which Winamp doesn't natively support, eg. ZIP, EXE, TEMP, MPG, JPG, etc?

If so, try moving all files out of the dir that don't have the .MP3 extension.

(naturally, if there's any other formats in there which are natively supported, then it should be ok to keep them, eg. WAV, MID, MOD, WMA, etc)

However, if there are any playlist files in this dir (M3U, PLS) then I recommend moving these as well (even though they will become useless if moved, because the paths will no longer be relative, but it's worth moving them just for troubleshooting purposes.)

2) Have you installed any extra Winamp input plugins?
eg. a replacement MP3 input plugin such as in_mp3pro.dll or in_mad.dll ?
If so, try disabling them so that only the default plugin (in_mp3.dll) is active.

Or, maybe you've installed a few more input plugins, in which case you should follow the instructions in this troubleshooter to try disassociate some extensions from within the individual input plugin's configs.
Maybe Winamp/Windows Open Files Dialog is getting clogged up trying to decide which files to read/not read?
http://forums.winamp.com/showthread....029#post440029

3) Have you installed (knowingly or not) any General Purpose plugins?
ie. are there any gen_*.dll files in your Winamp\Plugins dir?
If so, try disabling them.
Maybe one of these are buggy?

4) Maybe some of your MP3's are damaged or corrupted?
Check the dir with MP3Utility

5) Run ScanDisk and an up-to-date virus scanner ASAP.
Maybe also try running System File Checker (Win98)
(or OS equivalent, eg . msconfig -> tools / System Restore)


Can't think of much else, especially if you've followed the uninstall->reinstall procedure EXACTLY (as linked to in the above posts).
DJ Egg is offline   Reply With Quote
Old 18th February 2002, 23:51   #18
ironlung
Junior Member
 
Join Date: Feb 2002
Location: pittsburgh, pa
Posts: 3
None of that stuff worked that i tried...i didn't get through the whole list...i found an old file from 2.76 and reinstalled that instead of the new 2.78...and now everything works again...so krayzie, get the old version and you should be fine.
ironlung is offline   Reply With Quote
Old 19th February 2002, 01:52   #19
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Oh, right! Maybe I just shouldn't bother trying to answer any questions at all in future eh? Somehow, I don't see the point!

Maybe your system is under spec'ed for v2.78?
Maybe some drivers need updating in order to properly support the new features?
Lord knows!
Then again, you never provided any proper sys specs in the first place, so it's always going to be difficult for us to provide you with any decent/precise (FREE) tech support in the first place.

btw, did you try the official Winamp 2.78 Update patch?

Updates both out_wave & out_ds plugins to peter's new versions, also updates in_mod.dll, in_midi.dll & in_wave.dll to new pre v2.79 / 2.80 versions. Also includes optional Experimental DS Output, extra Gapless WaveOut & in_vorbis.dll

Further details: (READ THIS FIRST)
http://forums.winamp.com/showthread.php?threadid=68811
http://forums.winamp.com/showthread.php?threadid=70181


Or, then again, you could just stick with v2.76 ?
DJ Egg is offline   Reply With Quote
Old 20th February 2002, 19:58   #20
ironlung
Junior Member
 
Join Date: Feb 2002
Location: pittsburgh, pa
Posts: 3
you don't have to get all mad about it...i'm not the smartest person when it comes to computers and i had no clue what the hell you were talking about when you were telling me what to do in the previous post...i really do appreciate it though...sorry if i offended you man...later
ironlung is offline   Reply With Quote
Old 23rd February 2002, 03:46   #21
zeblith
Junior Member
 
Join Date: Feb 2002
Posts: 1
Had the same problem here.

I had the exact same problem! Anytime I tried to open the directory with a certain file in it it would freeze, and you'd have to manually shut it down! I found it was an incomplete file in my folder, only 200 MB total in 64 files, it's "System F. Feat. Marc Almond - (a1) s.o.s. (the hacker rmx).mp3" I don't know if that makes a difference at all but once I got rid of it it worked fine. If anyone else has thsi problem, try finding a specfic file responsible and see if there's anything in common. The file for me was 174 Kilobytes, barely started to download it. I was using audiogalaxy to download it. Maybe it's something in the filesize or in the file itself? It's not the name, I tried longer names, names with simsilar properties, and renaming a file to that one, and it worked fine. Open to any suggestions of the problem It seems to only be affecting the file browser that sllows a single file selection, like when you press the load/eject button or the add/+ button on the playlist.
zeblith is offline   Reply With Quote
Old 23rd February 2002, 05:21   #22
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Quote:
4) Maybe some of your MP3's are damaged or corrupted?
Yeah, add "and/or incomplete" to that sentence
DJ Egg is offline   Reply With Quote
Old 25th February 2002, 00:00   #23
Merlin
¯¯¯¯¯¯¯
(Forum King)
 
Merlin's Avatar
 
Join Date: Nov 2001
Location: Manchester
Posts: 4,209
For reference I had the exact same problem, also with version 2.78 and Windows ME. I removed the Space plug-in. Problem solved, for me. Definitely follow DJEgg's advice - remove any non-Nullsoft plugins to (maybe) sort the prob out.


as he faced the sun, he cast no shadow
Merlin is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump