Old 1st July 2004, 05:20   #1
Xfernet
Junior Member
 
Join Date: Jul 2004
Posts: 6
Help!

Im kinda new to this and I need some help..

I read the guide here: http://www.undergroundsalad.com/?7

and now I have Nullsoft SHOUTcast server monitor up and i get this

code:
*******************************************************************************
** SHOUTcast Distributed Network Audio Server
** Copyright (C) 1998-2004 Nullsoft, Inc. All Rights Reserved.
** Use "sc_serv filename.ini" to specify an ini file.
*******************************************************************************
<06/30/04@23:18:15> [SHOUTcast] DNAS/win32 v1.9.4 (Mar 17 2004) starting up...
<06/30/04@23:18:15> [main] loaded config from C:\Program Files\SHOUTcast\sc_serv.ini
<06/30/04@23:18:15> [main] initializing (usermax:20 portbase:80)...
<06/30/04@23:18:15> [main] No ban file found (0)
<06/30/04@23:18:15> [main] No rip file found (sc_serv.rip)
<06/30/04@23:18:15> [main] opening source socket
<06/30/04@23:18:15> [main] source thread starting
<06/30/04@23:18:15> [main] opening client socket
<06/30/04@23:18:15> [main] Client Stream thread [0] starting
<06/30/04@23:18:15> [main] client main thread starting
<06/30/04@23:18:15> [main] dns thread starting
<06/30/04@23:18:15> [source] listening for connection on port 81



and then I start NSV Live capture and it seems to work..
but i dont understand how to get my server to show up on winamp list or how to let others view it..
Xfernet is offline   Reply With Quote
Old 1st July 2004, 05:21   #2
drewbar
Sawg 2.0
Major Dude
 
Join Date: Mar 2004
Posts: 5,916
Your souce hasn't connected to the server yet. Make sure your soruce is properly configured.

Count with us!
Jan 1st, 12AM (PST, GMT -8) 2010 - 282,246
drewbar is offline   Reply With Quote
Old 1st July 2004, 05:37   #3
Xfernet
Junior Member
 
Join Date: Jul 2004
Posts: 6
How do I correctly config it?
Xfernet is offline   Reply With Quote
Old 1st July 2004, 05:45   #4
drewbar
Sawg 2.0
Major Dude
 
Join Date: Mar 2004
Posts: 5,916
http://www.scvi.net/liveenc.htm

Count with us!
Jan 1st, 12AM (PST, GMT -8) 2010 - 282,246
drewbar is offline   Reply With Quote
Old 1st July 2004, 06:06   #5
Xfernet
Junior Member
 
Join Date: Jul 2004
Posts: 6
okay.. i did all of that and it says
Quote:
Your Shoutcast server should display
something like this:

[source] listening
for connection on port 8001
[source] connected from 127.0.0.1
[source] icy-name:My-TV ; icy-genre:My-TV
[source] icy-pub:1 ; icy-br:128 ; icy-url:http://www.shoutcast.com
[source] icy-irc:N/A ; icy-icq:N/A ; icy-aim:N/A
[dest: 205.188.234.74] starting stream (UID: 0)[L: 1]{A: SHOUTcast Directory Tester}(P: 0)
[dest:205.188.234.74] connection closed (0 seconds) (UID: 0)[L: 0]{Bytes: 8192}(P: 0)
and mine does

Quote:
*******************************************************************************
** SHOUTcast Distributed Network Audio Server
** Copyright (C) 1998-2004 Nullsoft, Inc. All Rights Reserved.
** Use "sc_serv filename.ini" to specify an ini file.
*******************************************************************************
<07/01/04@00:14:12> [SHOUTcast] DNAS/win32 v1.9.4 (Mar 17 2004) starting up...
<07/01/04@00:14:12> [main] loaded config from C:\Program Files\SHOUTcast\sc_serv.ini
<07/01/04@00:14:12> [main] initializing (usermax:4 portbase:80)...
<07/01/04@00:14:12> [main] No ban file found ()
<07/01/04@00:14:12> [main] No rip file found (sc_serv.rip)
<07/01/04@00:14:12> [main] opening source socket
<07/01/04@00:14:12> [main] source thread starting
<07/01/04@00:14:12> [main] opening client socket
<07/01/04@00:14:12> [main] Client Stream thread [0] starting
<07/01/04@00:14:12> [main] client main thread starting
<07/01/04@00:14:12> [source] listening for connection on port 81
<07/01/04@00:14:12> [main] dns thread starting
How do you set up the source?
Xfernet is offline   Reply With Quote
Old 1st July 2004, 06:12   #6
Xfernet
Junior Member
 
Join Date: Jul 2004
Posts: 6
Now It seemed to work but I get

Quote:
*******************************************************************************
** SHOUTcast Distributed Network Audio Server
** Copyright (C) 1998-2004 Nullsoft, Inc. All Rights Reserved.
** Use "sc_serv filename.ini" to specify an ini file.
*******************************************************************************

Event log:
<07/01/04@00:22:27> [SHOUTcast] DNAS/win32 v1.9.4 (Mar 17 2004) starting up...
<07/01/04@00:22:27> [main] loaded config from C:\Program Files\SHOUTcast\sc_serv.ini
<07/01/04@00:22:27> [main] initializing (usermax:6 portbase:8000)...
<07/01/04@00:22:27> [main] No ban file found (sc_serv.ban)
<07/01/04@00:22:27> [main] No rip file found (sc_serv.rip)
<07/01/04@00:22:27> [main] opening source socket
<07/01/04@00:22:27> [main] source thread starting
<07/01/04@00:22:27> [main] opening client socket
<07/01/04@00:22:27> [main] Client Stream thread [0] starting
<07/01/04@00:22:27> [main] client main thread starting
<07/01/04@00:22:27> [source] listening for connection on port 8001
<07/01/04@00:22:28> [source] connected from 127.0.0.1
<07/01/04@00:22:29> [source] icy-name:Beer and Ship land ; icy-genre:webcam
<07/01/04@00:22:29> [source] icy-pub:1 ; icy-br:128 ; icy-url:http://jerproductions.tk
<07/01/04@00:22:29> [source] icy-irc:N/A ; icy-icq:N/A ; icy-aim:N/A
<07/01/04@00:22:40> [yp_add] yp.shoutcast.com gave error (nak)
<07/01/04@00:22:40> [yp_add] yp.shoutcast.com gave extended error (Cannot see your station/computer (IP: 24.158.27.66:8000) from the Internet, disable Internet Sharing/NAT/firewall/ISP cache (Connection timed out))
??
I am on this router if that might be a prob: http://www.netgear.com/products/prod...odID=131&view=

edit: sry bout double post..

Last edited by Xfernet; 1st July 2004 at 06:29.
Xfernet is offline   Reply With Quote
Old 1st July 2004, 11:06   #7
sankt
Moderator
 
sankt's Avatar
 
Join Date: Apr 2003
Location: www.ScenicTelevision.com
Posts: 2,976
Information at your service

Network Router Configuration
www.scvi.net/router.htm

Scenic Television is your ambient window to the world - - www.ScenicTelevision.com
sankt is offline   Reply With Quote
Old 1st July 2004, 17:37   #8
Xfernet
Junior Member
 
Join Date: Jul 2004
Posts: 6
Thanks

But when I run 'telnet 192.168.0.1'
It starts loading then just closes.. is this a virus? Same thing happens when I press CTRL+ALT+DEL the box just closes..
Xfernet is offline   Reply With Quote
Old 1st July 2004, 17:51   #9
ken52787
Major Dude
 
ken52787's Avatar
 
Join Date: Aug 2003
Posts: 1,297
Send a message via AIM to ken52787
http://portforward.com/routers.htm

go there and it will give you directions for your specific router.

NSV downloads
An in-depth step by step guide for newbies, coming soon.
ken52787 is offline   Reply With Quote
Old 1st July 2004, 18:01   #10
Xfernet
Junior Member
 
Join Date: Jul 2004
Posts: 6
Yeah i got to the page for my specific router and i can get up to where i gotta have static-ip's and to do that you gotta run command prompt and that closes after a few seconds automatically... im gonna go do a virus scan
Xfernet is offline   Reply With Quote
Old 1st July 2004, 23:04   #11
Inedible Bulk
Forum King
 
Inedible Bulk's Avatar
 
Join Date: Apr 2004
Location: You're the man now dog
Posts: 2,303
lol

go to start, and its either network connections or connect to>. click that, right click your connection and click properties, then choose the tcp/ip connection and hit properties.

from there you can set up static ips for your lan, but you also must set the dns servers ips. usually you can get those from your router, or even set your router as the dns server (it redirects and works for me, because i had talked to the ISP guy and he suggested i do that, i like having static ip in my network)

Originally posted by yeshuawatso :
...get Nullsoft to [accept] new moderators? ... election? ... If Inedible Bulk is the candidate, then I give my vote.
Inedible Bulk is offline   Reply With Quote
Old 2nd July 2004, 04:53   #12
Jeeper One
Major Dude
 
Jeeper One's Avatar
 
Join Date: May 2003
Location: Denver, Colorado
Posts: 1,055
Re: Help!

Quote:
Originally posted by Xfernet
Im kinda new to this and I need some help..

I read the guide here: http://www.undergroundsalad.com/?7

and now I have Nullsoft SHOUTcast server monitor up and i get this

code:
*******************************************************************************
** SHOUTcast Distributed Network Audio Server
** Copyright (C) 1998-2004 Nullsoft, Inc. All Rights Reserved.
** Use "sc_serv filename.ini" to specify an ini file.
*******************************************************************************
<06/30/04@23:18:15> [SHOUTcast] DNAS/win32 v1.9.4 (Mar 17 2004) starting up...
<06/30/04@23:18:15> [main] loaded config from C:\Program Files\SHOUTcast\sc_serv.ini
<06/30/04@23:18:15> [main] initializing (usermax:20 portbase:80)...
<06/30/04@23:18:15> [main] No ban file found (0)
<06/30/04@23:18:15> [main] No rip file found (sc_serv.rip)
<06/30/04@23:18:15> [main] opening source socket
<06/30/04@23:18:15> [main] source thread starting
<06/30/04@23:18:15> [main] opening client socket
<06/30/04@23:18:15> [main] Client Stream thread [0] starting
<06/30/04@23:18:15> [main] client main thread starting
<06/30/04@23:18:15> [main] dns thread starting
<06/30/04@23:18:15> [source] listening for connection on port 81

WHY are you attempting to stream on Port 80 ? That's a universal port for WEB SERVERS. Your ISP probably has this port blocked from incoming traffic that's not consistent with a web browser connecting to a website.

Change the port to something OTHER than Port 80, 21 and ports set aside for email (I don't know them offhand) and try again.
Quote:
and then I start NSV Live capture and it seems to work..
but i dont understand how to get my server to show up on winamp list or how to let others view it..
See above.

Cheers for now

Pat Cook
Englewood, CO
Jeeper One is offline   Reply With Quote
Old 2nd July 2004, 05:19   #13
Inedible Bulk
Forum King
 
Inedible Bulk's Avatar
 
Join Date: Apr 2004
Location: You're the man now dog
Posts: 2,303
25 and 110 are the ones for email, thats smtp and pop3, respectively.

Originally posted by yeshuawatso :
...get Nullsoft to [accept] new moderators? ... election? ... If Inedible Bulk is the candidate, then I give my vote.
Inedible Bulk is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast TV / Nullsoft Video

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump