Old 25th January 2008, 14:43   #1
kurtzn
Junior Member
 
Join Date: Jan 2008
Posts: 4
Audible file management with iPod

I have just installed latest release of Winamp Pro, and the latest update to ml_iPod.

My problem is this, with the plug in configured, I can see my iPod and I can see and play audible files already on the iPod.

However, Winamp puts the audible files under the video heading in the media library. Worse than that, I cannot transfer the files to the iPod. They also won't play from the PC either.

I don't really need to listen to the audible files from the PC, although that would be nice occasionally, but I really want to manage the files on the PC and most importantly, to be able to move the files back and forth between the PC and the iPod.

FYI, music files work and transfer properly, no problems there.

Any help setting up the plug in or Winamp would be appreciated.

Thanks
kurtzn is offline   Reply With Quote
Old 25th January 2008, 15:17   #2
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
You are talkin 'bout files with the *.aa extension, right?

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 26th January 2008, 00:29   #3
kurtzn
Junior Member
 
Join Date: Jan 2008
Posts: 4
Yes
kurtzn is offline   Reply With Quote
Old 26th January 2008, 08:57   #4
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
I'm not sure if I completely understand. You can play audible files that are on the iPod, inside Winamp? I don't think that's possible. Playing on the PC inside Winamp shouldn't be possible at all, only in the audible player or iTunes or WMP.

What happens if you want to transfer one to the iPod?
To me it seems you can't even add them to the ML with the latest Winamp...

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 26th January 2008, 14:27   #5
kurtzn
Junior Member
 
Join Date: Jan 2008
Posts: 4
I'm sorry, hopefully I can clear up the issue. All I want to do is to have Winamp allow me to transfer audible, .aa files, to my iPod.

They show up in Winamp, although there appear under the video category, but if i try to transfer them to the iPod, it doesn't work.

I realize now that audible files are strictly limited to the players they work on, but I was really hoping I could at least use Winamp to transfer the files back and forth.

Also note, I don't buy my audible files from iTunes, only through an audible.com subscription.

So, the .aa files show up in winamp, I just need to be able to transfer them to iPod.

Thanks
kurtzn is offline   Reply With Quote
Old 26th January 2008, 18:36   #6
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Well, I can't reproduce your behaviour, it's completely different here. BUT: The audible file handling is definitely broken with the newest Winamp. I just tried it, everything works fine with WA 5.35, but with 5.52 it's completely broken:
When I add an *aa file to the ML via drag'n drop, it shows up, but only with the filename, no artist, title, length etc. It does show up in the music section for me. Obviously the metadata reading function in ml_ipod is not called any more by Winamp.
I can transfer these tracks to my iPod, and they show up there and play. But they always show a length of 0 sec, so you can't navigate in the file. And it shows up with empty artist, too.

So, for now, all I can say is go back to 5.35 (which, probably, will render your current ML database unusable). Don't know what broke it, but it's not in ml_iPod as even the newest patch handles audible books fine with the older Winamp version.

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 26th January 2008, 19:28   #7
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Update: I found a workaround for WA 5.52:
Don't add your audible files to the ML. If they are listed there already, remove them from the ML.
Then, having the iPod view active, drag and drop the files directly from explorer into the iPod view (see here in the Wiki)
That way, the old process is used internally and the metadata is read correctly. The book gets transfered to the iPod and shown correctly. Even cover art works again.

Not as nice as it used to be with 5.35, but an ok solution...

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp iPod Plugin Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump