Old 16th July 2011, 17:14   #1
Samuelv
Junior Member
 
Join Date: Jul 2011
Posts: 9
Invalid Authorization Hash

I am getting error. please help me
I am using windows7 32 bit, verizon wireless router.

2011-07-16 12:10:33 I msg:[YP2] Connecting to yp.shoutcast.com
2011-07-16 12:10:33 E msg:[YP2] /yp/resp/updatefreq missing
2011-07-16 12:10:33 E msg:[YP2] Connection attempt failed. YP2 error code is 470 (Invalid authorization hash)

I have too many sc_serv_***. conf and sc_trans_***.conf in shoutcast dir
also I have shoutcast basic broadcater license key. please help
Attached Files
File Type: log sc_serv.log (6.3 KB, 201 views)
Samuelv is offline   Reply With Quote
Old 16th July 2011, 17:24   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
see http://forums.winamp.com/showpost.ph...0&postcount=46 for what you need to pm me with (as it sounds like you've not got an authhash to start with unless you registered one via the old my-stations page and it was one of the ones which got wiped due to a db error).

Quote:
I have too many sc_serv_***. conf and sc_trans_***.conf in shoutcast dir
all of the files are clearly described in the final section of the main document files and they're named to indicate what they are trying to show.

-daz
DrO is offline   Reply With Quote
Old 16th July 2011, 17:49   #3
Samuelv
Junior Member
 
Join Date: Jul 2011
Posts: 9
<removed authhash request details - moderation>

I bought unlock code yesterday and I paid $5.00

How can I send PM?
Samuelv is offline   Reply With Quote
Old 16th July 2011, 18:02   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
it doesn't matter about sending a pm now as i've created an authhash from the details you provided and have pm'd it to you (should appear as a notice in the top right of the forum just below 'Welcome Samuelv'.

an unlock ket for the transcoder is not the same as the authhash for stream registration (first is paid for as you've done, the second is free and is just to ensure no one can claim to be your station in the SHOUTcast Directory listings).

-daz
DrO is offline   Reply With Quote
Old 16th July 2011, 18:16   #5
Samuelv
Junior Member
 
Join Date: Jul 2011
Posts: 9
Thank you for sending code. I added authhash code in sc_serv_public.conf. But still showing same error. I have to wait?
Samuelv is offline   Reply With Quote
Old 16th July 2011, 18:38   #6
DrO
 
Join Date: Sep 2003
Posts: 27,873
ensure you've got the following in your config file:
Quote:
streamid_1=1
streamauthhash_1=authhash_provided
-daz
DrO is offline   Reply With Quote
Old 16th July 2011, 19:21   #7
Samuelv
Junior Member
 
Join Date: Jul 2011
Posts: 9
Still not working. I added that code in sc_serv_public.conf

; make sure that you completely replace the string
; <enter_your_auth_key_here> with the authorisation key you
; obtained when registering the stream for the SHOUTcast YP
; e.g. if you auth hash key is 12345 then the line would be
; streamauthhash=12345
streamid_1=1
streamauthhash_1=myauthhashcode
Samuelv is offline   Reply With Quote
Old 17th July 2011, 21:01   #8
DrO
 
Join Date: Sep 2003
Posts: 27,873
I've just tried it and the authhash is working with a minimal test setup. Is it still the 470 error code you're getting?

-daz
DrO is offline   Reply With Quote
Old 18th July 2011, 13:59   #9
Samuelv
Junior Member
 
Join Date: Jul 2011
Posts: 9
still i am getting same error. Is it router problem? I am using Verizon wireless roulter with 4 ports and 3 PC connected wired. my ip showing 192.168.1.3. I forwarded all shoutcast 8000 port to 192.168.1.3. or it is antivirus problem? I am using Avast! antivirus software.
Samuelv is offline   Reply With Quote
Old 18th July 2011, 14:05   #10
DrO
 
Join Date: Sep 2003
Posts: 27,873
enable yp2debug=1 in your configuration file and pm me a copy of the log created. also pm a copy of you configuration file as there's 2 errors being reported by the DNAS when it's reading it.

from the log you pasted (which got filtered by the forum software for some reason), it looks like you've set portbase=8225 which would mean forwarding to port 8000 won't help.

-daz
DrO is offline   Reply With Quote
Old 18th July 2011, 14:41   #11
DrO
 
Join Date: Sep 2003
Posts: 27,873
just looked through the pm's received and i tihnk you're using the wrong config file as you've got the authhash in one file (the other one has it but it's got a ; in front indicating its been commented out).

the log didn't have any YP2 debug output in it which leads me onto the next thing...

the log is showing sc_serv.ini being used to run the DNAS but you provided copies of the *.conf files. if you're using sc_serv.ini, then add the authhash options into that file (which probably explains the error lines on conflg reading which the next build of the v2 DNAS should resolve).

-daz
DrO is offline   Reply With Quote
Old 18th July 2011, 15:31   #12
Samuelv
Junior Member
 
Join Date: Jul 2011
Posts: 9
still i can't figure it out. I am not a programmer. Can you send me ini and conf file. i can erase all ini and conf file and copy one you send.
Samuelv is offline   Reply With Quote
Old 18th July 2011, 15:40   #13
DrO
 
Join Date: Sep 2003
Posts: 27,873
you're editing the wrong file is all i can tell is going on as what you've pm'd indicated the files were otherwise ok (i can't make sense of your last pm). having said you were upgrading from a v1 DNAS to a v2 DNAS would have saved the both of us a lot of time.

so ignore all of the .conf files, and just edit the sc_serv.ini file which is in your DNAS folder and make sure you add
Quote:
streamid_1=1
streamauthhash_1=authhash_provided
other than that, i cannot send you a working file as i don't believe i've seen the file that you're actually running the DNAS with.

-daz
DrO is offline   Reply With Quote
Old 18th July 2011, 17:10   #14
Samuelv
Junior Member
 
Join Date: Jul 2011
Posts: 9
I erase all conf files and reinstall DNAS and added
streamid_1=1
streamauthhash_1=authhash_provided

when i run Shoutcast DNAS it close immediately.
Samuelv is offline   Reply With Quote
Old 18th July 2011, 17:17   #15
DrO
 
Join Date: Sep 2003
Posts: 27,873
i just don't understand how you're making this so complicated - all that was needed was 2 lines being added to the existing sc_serv.ini (as finally came out as being the config file being used) and that should have resolved it *bangs head*

added them into which file?

which file are you specifying for the DNAS to use as the configuration file?

what is the log file showing?

and please use the DNAS from http://forums.winamp.com/showthread.php?t=332575 so at least the same version is being used. though you'd probably be better off just getting the DNAS running and re-create the authhash on your own via the details from http://wiki.winamp.com/wiki/SHOUTcas...ash_Management

-daz
DrO is offline   Reply With Quote
Old 18th July 2011, 17:23   #16
Samuelv
Junior Member
 
Join Date: Jul 2011
Posts: 9
i didn't choose any conf file. as you said ignore all conf file. i don't know where and how to choose right conf file

i added in sc_serv.ini file below
PublicServer=always
streamid_1=1
streamauthhash_1=
Samuelv is offline   Reply With Quote
Old 18th July 2011, 17:34   #17
DrO
 
Join Date: Sep 2003
Posts: 27,873
it sounds like you're just double-clicking sc_serv.exe

if so you either need to enter sc_serv.exe sc_serv.ini from the command line in the folder sc_serv.exe is in (assuming sc_serv.ini still exists).

or just rename sc_serv.ini to sc_serv.conf and then the DNAS will be able to find it and show a prompt to use that file.

-daz
DrO is offline   Reply With Quote
Old 18th July 2011, 18:12   #18
Samuelv
Junior Member
 
Join Date: Jul 2011
Posts: 9
Thank you. It is working now. I renamed sc_serv.ini file to sc_serv.conf. Run the file from Start -> Programs -> SHOUTcast DNAS.
After open from SHOUTcast DNAS I choose the conf by typing 3 for public server on command window.
Samuelv is offline   Reply With Quote
Old 18th July 2011, 18:19   #19
DrO
 
Join Date: Sep 2003
Posts: 27,873
/me adds something else to the todo list for v1 to v2 migration improvements.

-daz
DrO is offline   Reply With Quote
Old 15th September 2011, 00:07   #20
dres_
Junior Member
 
Join Date: Sep 2011
Posts: 14
Go into the "sc_serv" file you want to use. Where you see "; make sure that you completely replace the string
; <enter_your_auth_key_here> with the authorisation key you
; obtained when registering the stream for the SHOUTcast YP
; e.g. if you auth hash key is 12345 then the line would be
; streamauthhash=12345
streamauthhash= <enter_your_auth_key_here>" delete the part that says " <enter_your_auth_key_here>" leave it blank so it looks like this "streamauthhash=" save it(replace it) to the directory that it is in which is "C:\Program Files\SHOUTcast". Now go to the "SHOUTcast Authhash Management" web interface which you get there by typing "http://127.0.0.1:8000/admin.cgi". Now create a "AuthHash". Wait 10 minutes for the "AuthHash" and that's all. If you go back and open the "sc_serv" file you will see the "AuthHash" in there. That's all. Good luck.
dres_ is offline   Reply With Quote
Old 15th September 2011, 09:08   #21
DrO
 
Join Date: Sep 2003
Posts: 27,873
dres_: yes that works but the DNAS will do that for you without having to manually go into the config file in most cases. though the next build to come out resolves some quirks which lead to some failures or the authhash not being recognised despite being in the file.

-daz
DrO is offline   Reply With Quote
Old 21st September 2011, 20:57   #22
dres_
Junior Member
 
Join Date: Sep 2011
Posts: 14
Ok DrO. Good looks man. Thanks.
dres_ is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump