Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Reply
Thread Tools Search this Thread Display Modes
Old 4th December 2005, 19:22   #281
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Yeah, there's something weird going on there.

The asx playlist links to an .asp file, which is actually a wrongly named .asx playlist, which is why you get the 'error syncing to mpeg' error when you try to load the .asp link (in_wm.dll nor playlist_loader support .asp, so in_mp3 tries to load it instead, and fails).

So, it's either an error on behalf of the webmaster, or he's just trying to be clever to make it so you can only get the link to play in WMP ;-)

The freeze is actually being caused by this entry in the playlist:
http://196.35.64.36/5fm_22?WMThinning=0
pl_loader is downloading that as an .asx which contains the same url, and therefore it enters an endless loop :/


The actual url for the stream is:

mms://196.35.64.36/5fm_22?WMThinning=0&ext=.wma

or just

mms://196.35.64.36/5fm_22?ext=.wma

which plays fine for me
DJ Egg is offline   Reply With Quote
Old 4th December 2005, 19:39   #282
DrO
 
Join Date: Sep 2003
Posts: 27,873
and the .asp that's downloaded, when renamed to .asx then it will cause pl_loader to lock up when trying to parse the last entry in the file since it detects it as being extensionless and so will attempt to download it as an asx (since that's often the case). however that url gives a valid url which is essentially the same as itself and so it enters a loop causing winamp to lock up. i'll be looking to fix this along with making pl_loader attempt to parse asp files that it detects in the extract asx files.

so really it's the site's fault for naming the file incorrectly and an oversight on my part for the handling of such situations (will try to fix this as soon as i can)

-daz
DrO is offline   Reply With Quote
Old 4th December 2005, 20:28   #283
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
So I just deleted a long and involved post about the site sending a file that references itself and suggesting what DrO has already discovered

@ Shakey803 - for future reference(should the addresses change) - look for the following section at http://www.5fm.co.za/listenlive.asp#

I get a "source file could not be loaded", or "...cannot play the file." error message!!
The link file pointing to the streams may be having difficulty reaching your player - click here to download a zip file containing this asx file. Unzip and save it to your computer, and open it in your Windows Media Player application.

Or you can open the unzipped .asx file in Notepad and extract one of the URLs. See Eggs post.

mms links can be added as they are.
http links will require you to add '/.wma'

UJ
ujay is offline   Reply With Quote
Old 4th December 2005, 21:22   #284
Shakey803
Junior Member
 
Join Date: Dec 2005
Location: UK
Posts: 12
Guys,

Many thanks for your help. I'm extremely grateful. I put the mms link into Winamp, and it works just fine. Once again, thanks. I'll now try to get the Shoutcast -> Twonkyvision thing working.

How did you guys find out the mms link address from the asx?

I'm pretty certain you're correct in thinking the Webmaster has done this on purpose to make listeners use WMP.

Cheers,
Shakey.
Shakey803 is offline   Reply With Quote
Old 4th December 2005, 21:35   #285
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
When you save the asx to the hard drive and open it in Notepad, you'll see this entry:

<Ref href = "http://www.antfarm.co.za/clients/5fm/silversands/asxGenPop.asp" />

When you open that url in your browser it opens as html
(because the webmaster wrongly gave it an .asp extension instead of .asx)

If you then view the source for that page, you will then see the contents of the actual asx in all its glory, and that's where I/we got the actual stream url's from.
DJ Egg is offline   Reply With Quote
Old 4th December 2005, 21:40   #286
Shakey803
Junior Member
 
Join Date: Dec 2005
Location: UK
Posts: 12
Aaah, it all comes clear.

Thanks, you guys are great.

Shakey.
Shakey803 is offline   Reply With Quote
Old 4th December 2005, 21:55   #287
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
Quote:
Originally posted by ujay
@ Shakey803 - for future reference(should the addresses change) - look for the following section at http://www.5fm.co.za/listenlive.asp#

I get a "source file could not be loaded", or "...cannot play the file." error message!!
The link file pointing to the streams may be having difficulty reaching your player - click here to download a zip file containing this asx file. Unzip and save it to your computer, and open it in your Windows Media Player application.


Or you can open the unzipped .asx file in Notepad and extract one of the URLs. See Eggs post.

mms links can be added as they are.
http links will require you to add '/.wma'
Did you find that section and download the zip file ???

UJ
ujay is offline   Reply With Quote
Old 4th December 2005, 22:01   #288
Shakey803
Junior Member
 
Join Date: Dec 2005
Location: UK
Posts: 12
ujay,

Got it, thanks - I see the mms and http links in there. It works fine now thanks.

Much appreciate the quick responses from you guys.
Cheers,

Shakey.
Shakey803 is offline   Reply With Quote
Old 5th December 2005, 20:39   #289
Shakey803
Junior Member
 
Join Date: Dec 2005
Location: UK
Posts: 12
Gents,

Another night, another problem, the station plays in Winamp just fine - however, I can't get Shoutcast to connect. Are there any discussions to do with this (as well as getting Twonkyvision to work). All this to listen to radio.

Thanks,
Shakey
Shakey803 is offline   Reply With Quote
Old 5th December 2005, 21:48   #290
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Please start a new thread if it's not related to the Playlist Loader plugin (or revive your already existing thread, if you started one previously for said topic).
DJ Egg is offline   Reply With Quote
Old 6th December 2005, 00:36   #291
Shakey803
Junior Member
 
Join Date: Dec 2005
Location: UK
Posts: 12
My apologies.
Shakey803 is offline   Reply With Quote
Old 6th December 2005, 00:54   #292
Shakey803
Junior Member
 
Join Date: Dec 2005
Location: UK
Posts: 12
Let me redefine my reply as it's relevant to this thread and what's come above to do with the mms stream you found for me.

Everything works now - in that if I play a default station in Winamp from the Media Library, I get the output successfuly into the Shoutcast source (led's light up etc.) and it even get's to MP101 fine).

However, although the mms link (mms://196.35.64.36/5fm_22?ext=.wma) plays fine in Winamp (and PC speakers), it doesn't register as input to Shoutcast source, so times it out. Is there something I'm missing, or a plugin I need to install?

Seems so very close to working now. Thanks.
Shakey.
Shakey803 is offline   Reply With Quote
Old 6th December 2005, 01:50   #293
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Hmm... I'm not sure what it is you're trying to do exactly, but afaik, you can't stream wma with shoutcast.
DJ Egg is offline   Reply With Quote
Old 6th December 2005, 02:16   #294
DrO
 
Join Date: Sep 2003
Posts: 27,873
Playlist Loader v0.9.9.8f (formerly known as B4S Playlist Loader)
  • Fixed a crash with some SHBrowseForFolder(..) calls that the plugin was trapping
  • Fixed handling of asx playlists which refer back onto themselves (why o why people make things like that is beyond me!)
  • Altered the plugin's handling of mms, mmsu and mmst streams when using Winamp 5.12 (will still append /.wma on pre 5.12 installs to work with the old in_wm)
get v0.9.9.8f

late, need sleep yada yada yada but this fixes 2 public bugs and implements some future proofing support...

-daz
DrO is offline   Reply With Quote
Old 6th December 2005, 07:11   #295
Shakey803
Junior Member
 
Join Date: Dec 2005
Location: UK
Posts: 12
Thanks DrO,

The link above gives the dreaded 404.

Cheers,
S.
Shakey803 is offline   Reply With Quote
Old 6th December 2005, 09:51   #296
DrO
 
Join Date: Sep 2003
Posts: 27,873
fixed the link (had ballsed up the upload last night.. will teach me to do things at 02:15)

-daz
DrO is offline   Reply With Quote
Old 6th December 2005, 12:00   #297
Shakey803
Junior Member
 
Join Date: Dec 2005
Location: UK
Posts: 12
DrO,

Top job - the asx link itself works a treat in Winamp now.

Unfortunately, as DJEgg says, it appears that it's all futile as Shoutcast is having none of it. It doesn't recognise the input.

I've seen elsewhere people say they successfully stream non-mp3 Internet Radio this way, but none of them elaborate on how.

If there's no plugin to bridge the gap between Winamp and Shoutcast for asx or wma, then I'm on a loser here sadly.

Many thanks for the help so far all.
Regards,
S.
Shakey803 is offline   Reply With Quote
Old 6th December 2005, 13:09   #298
DrO
 
Join Date: Sep 2003
Posts: 27,873
unless you pass line out back into line in and then have the SC dsp pick it up that way but that's a bit convoluted really. alas it's the crap you get when using most forms of WMA audio.

at least the plugin handles that dodgy asx now. the reason for the mis-handling was that the 6th entry in the asx gives a link to an asx with :80 on it's end and that then refs back to itself and the plugin ended up in a recurring download loop

-daz
DrO is offline   Reply With Quote
Old 24th December 2005, 02:21   #299
AllOrZero
Junior Member
 
Join Date: Dec 2005
Location: Florida
Posts: 2
Send a message via AIM to AllOrZero
Awesome plugin. I wish I'd heard about this sooner, but better late than never, eh?

I'm having trouble playing the following stream:

mms://rx-wes-sea145.rbn.com/farm/*/airam/airam/wmlive/livea.asf

I'm not sure why. All the streams I listen to besides that one will play. I tried a few of the things you suggested here, but nothing has worked so far, so I throw myself to your superior knowledge of the plugin in hopes of solving my problem.

Thanks in advance.
AllOrZero is offline   Reply With Quote
Old 24th December 2005, 02:32   #300
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Plays fine here.
Requires Winamp 5.12 with new in_wm.dll v3.0, and Windows Media v9.1 Codecs.
Doesn't require Playlist Loader plugin, since it's a direct link to a stream and not a asx-based playlist... ie. whatever the problem is, it's got nothing to do with the Playlist Loader plugin, heh.
DJ Egg is offline   Reply With Quote
Old 24th December 2005, 04:35   #301
AllOrZero
Junior Member
 
Join Date: Dec 2005
Location: Florida
Posts: 2
Send a message via AIM to AllOrZero
Woah, WTF. That's interesting. I don't know what changed from 5.111 to 5.12, but it's working fine now. *l* Go figure. Thanks anyway.
AllOrZero is offline   Reply With Quote
Old 24th December 2005, 05:06   #302
drewbar
Sawg 2.0
Major Dude
 
Join Date: Mar 2004
Posts: 5,916
A lot. There was a new WMA/WMV decoder. Works better with streaming, now.

Count with us!
Jan 1st, 12AM (PST, GMT -8) 2010 - 282,246
drewbar is offline   Reply With Quote
Old 28th December 2005, 13:14   #303
DrO
 
Join Date: Sep 2003
Posts: 27,873
since a number of the apparent issues with the plugin are due to not having the latest WMA codecs installed, i've now added a bit of info about it to the plugin's webpage and made some references to use 5.12+ when dealing with WMA based formats. and the 0.9.9.8f changelog is (finally, heh) up now

-daz
DrO is offline   Reply With Quote
Old 11th January 2006, 19:51   #304
xQuarkDS9x
Junior Member
 
Join Date: Jan 2006
Location: Section 31
Posts: 4
After installing this plugin today it seems for some reason Winamp doesn't like it and crashes. I'm using Winamp 5.12 and for some reason it crashes trying to play any Windows Media Audio stream. This is on an WIN98 machine as well.

What happen's is that I'll go play a ASX link such as this

http://www.jr-digital.com/asx/ckwx.asx

Winamp will try to load it for about 5 seconds, then it crsahes with this error message.

code:

WINAMP caused an invalid page fault in
module WMVCORE.DLL at 0177:4f51e628.
Registers:
EAX=00000000 CS=0177 EIP=4f51e628 EFLGS=00210246
EBX=66640c90 SS=017f ESP=007553bc EBP=007553e8
ECX=00000000 DS=017f ESI=00991990 FS=420f
EDX=007553d8 ES=017f EDI=00755430 GS=0000
Bytes at CS:EIP:
8b 08 ff 51 44 85 c0 89 45 10 0f 8c 9e 04 00 00
Stack dump:
00000000 007553d8 004878a0 004874c0 00000000 00000030 00000038 00000000
00000000 0074f000 00000000 00755408 6661e41f 00991990 0075542c 00000000



Right after this is shown a few seconds later I hear the audio stream playing just fine through winamp, but once I click the ok to close the error msg then it stop's. I also noticed that a window to the effect of "Open URL" is initially hidden below the error msg as well.

I have downloaded the latest WMA/WMV codes from microsoft Right here for Win98, so I'm rather puzzles as to why it's crashing in WMVCORE.DLL, especially since that same stream plays perfectly fine in the Windows Media player from MS.
xQuarkDS9x is offline   Reply With Quote
Old 12th January 2006, 13:24   #305
DrO
 
Join Date: Sep 2003
Posts: 27,873
i tried that stream on my Win2k box (with 0.9.9.8f and also my interim dev build which isn't publically available) and also my XP machine (just 0.9.9.8f) at work and i don't experience any issues with the stream.

however since it's a crash in WMVCORE.DLL that is very unlikely to be related to this plugin and is more likely to be down to in_wm.dll and it's interaction with the WMA codecs.

-daz
DrO is offline   Reply With Quote
Old 12th January 2006, 15:26   #306
xQuarkDS9x
Junior Member
 
Join Date: Jan 2006
Location: Section 31
Posts: 4
Ok then I've confirmed it's definetly the wmvcore.dll file. The one that came with the latest codec downloads for WIN98/ME is dated May 9th 2001, and this causes the winamp plugin to crash.

So, I downloaded a newer wmvcore.dll off the net (apparantly one from XP SP2) and while it didn't make Winamp crash, it instead made Winamp say "Error syncing to mpeg". I even took a screenshot showing the two different version numbers side by side.

http://sloan.polarpages.com/windowsmedia.png.

Last edited by xQuarkDS9x; 12th January 2006 at 15:47.
xQuarkDS9x is offline   Reply With Quote
Old 12th January 2006, 15:47   #307
DrO
 
Join Date: Sep 2003
Posts: 27,873
if the devs can reproduce it then it might be able to be fixed but older OS support isn't too high on the list of things in all honesty. i'm not sure why it'd crash when playing that stream though

-daz
DrO is offline   Reply With Quote
Old 20th January 2006, 01:21   #308
Vampik
Junior Member
 
Join Date: Jan 2006
Location: Moscow, Russia
Posts: 6
Send a message via ICQ to Vampik
Playlist Loader adds /.wma at the end of a http-link without extension, but that trick doesn't work with all servers. For example, http://stream.fluendo.com:8845 & http://stream.fluendo.com:8846. http://stream.fluendo.com:8845/.wma produces 404 error while http://stream.fluendo.com:8845/?.wma works. I often need to manually change /.wma to /?.wma :-(
Vampik is offline   Reply With Quote
Old 10th February 2006, 02:20   #309
JW
Senior Member
 
Join Date: Nov 2004
Location: Valencia, CA
Posts: 304
DrO hits another home run!

I just installed this plugin this morning, and spent much of the day tracking down stream URL's for all my local radio stations I get marginal FM reception and NO AM reception at all, but that doesn't matter anymore. Winamp just became infinitely more useful.
JW is offline   Reply With Quote
Old 11th February 2006, 00:35   #310
xQuarkDS9x
Junior Member
 
Join Date: Jan 2006
Location: Section 31
Posts: 4
This topic doesn't really matter much now anyway as I just recently upgraded to an XP machine, and that same link work's fine now.
xQuarkDS9x is offline   Reply With Quote
Old 18th February 2006, 18:42   #311
JW
Senior Member
 
Join Date: Nov 2004
Location: Valencia, CA
Posts: 304
I've discovered an interesting issue. When I have the Winamp Modern skin loaded (or most other modern skins), and listen to certain .asx streams, Winamp crashes (usually with a fatal guru error from the skinning engine). But it doesn't do it when I use the modern skin I designed for my own use. Try any of these out with the Winamp Modern skin and see if they crash Winamp...

http://a814.l1977144512.c19771.g.lm....tor:44512/.wma

mms://c9l.earthcache.net/wlc-04.media.globix.net/COMP006822BCT1_knac_wm9.wmv?.wma

http://bdcast-infinity-kroq-fm.wm.ll...MExt=.asf/.wma

If you'd like a copy of my skin for testing, let me know.
JW is offline   Reply With Quote
Old 18th February 2006, 19:04   #312
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Nope, they all play perfectly fine here, no crash.
Note, as from Winamp 5.2 / in_wm 3.0 and later, you don't need to add the /.wma or ?.wma to the end of the url if the url already specifies wmv or asf at the end... ie. you can just use these url's:

mms://c9l.earthcache.net/wlc-04.media.globix.net/COMP006822BCT1_knac_wm9.wmv
http://bdcast-infinity-kroq-fm.wm.llnwd.net/bdcast_infinity_kroq-fm?MSWMExt=.asf

There's an option in Prefs > File Types > Extra Options to disable processing (ie. select all extensions there, including ASF, WMV, WMA)
DJ Egg is offline   Reply With Quote
Old 4th March 2006, 23:01   #313
machinmon
Junior Member
 
Join Date: Mar 2006
Posts: 1
hey you guys, ive always wondered about playing wm files on winamp. i'm having a problem though on playing this stream http://www.rds.it/player/rds.asx which contains the info:
code:

<ASX version = "3.0" previewmode = "no" BannerBar = "AUTO">
<Entry>
<Title>RDS LIVE STREAMING</Title>
<Abstract>WWW.RDS.IT</abstract>
<Author>RDS</Author>
<Copyright>© RDS Radio Dimensione Suono</Copyright>
<Ref href="http://217.169.108.45:8000/live24h" />
<Ref href="http://217.169.108.45/wmtencoder/27341690.wmv" />
</Entry>
<Entry>
<Title>RDS LIVE STREAMING</Title>
<Abstract>WWW.RDS.IT</abstract>
<Author>RDS</Author>
<Copyright>© RDS Radio Dimensione Suono</Copyright>
<Ref href="http://217.169.108.44:8000/live24h" />
<Ref href="http://217.169.108.44/wmtencoder/27341690.wmv" />
</Entry>
</ASX>


and the hrefs as well as the .asx give 404 errors with or without the /.wma, and sometimes it freezes the player. so i just want to see if others can get it to work. thanks.
machinmon is offline   Reply With Quote
Old 22nd May 2006, 09:34   #314
yokotaashi
Junior Member
 
Join Date: May 2006
Location: Colorado
Posts: 19
Quote:
Playlist Loader v0.9.2.1 (formerly known as B4S Playlist Loader)

Added basic wpl playlist support - one for Egg
If you get a crash then please let me know the exact crash report, what you were doing, system specs, etc and if possible the playlist file you were trying to load (since it helps me at least try to fix things)
I got a crash upon attempting to open a wpl playlist. I did have to select the 'playlists' catagory from the 'file-types' dropdown menu when browsing my music folder just to see the wpl files (btw i'm moving from wmp to winamp) then when I click open, winamp crashes.
system specs: winWP pro, 3gig intel processer, SB live! audio card, 80gig sata HD, gigibyte MB, Nvidia 6600 256mb graphics card.

hope you guys can help I know this is kinda random
yokotaashi is offline   Reply With Quote
Old 23rd May 2006, 01:07   #315
DrO
 
Join Date: Sep 2003
Posts: 27,873
i'm sorry to say but i'm no longer maintaining this project and will not be looking into any issues related with it. i'll be leaving the current versions up but that's it as things stand now which is a shame since i'd have really liked to have reached the 1.0 that i'd been aiming for but things have changed which have caused this decision to stop the project.

-daz
DrO is offline   Reply With Quote
Old 23rd May 2006, 01:21   #316
yokotaashi
Junior Member
 
Join Date: May 2006
Location: Colorado
Posts: 19
ok

Well thank you for telling me anyways, do you ane any plugins in mind that will allow me to import wpl files?
Thanx again
yokotaashi is offline   Reply With Quote
Old 25th May 2006, 01:21   #317
Benski
Ben Allison
Former Winamp Developer
 
Benski's Avatar
 
Join Date: Jan 2005
Location: Brooklyn, NY
Posts: 1,057
Wait for Winamp 5.22
Benski is offline   Reply With Quote
Old 25th May 2006, 02:14   #318
DrO
 
Join Date: Sep 2003
Posts: 27,873
since benski's now let it out of the bag we can let this thread die it's death since there is native support for asx, etc.

the implementation in 5.22 has nothing to do with the playlist loader project which is a shame but due to personal and work related issues (hence my absence for a few months around here recently) i wasn't able to make the commitment that was needed otherwise i could have done a will on the feature.

thanks to all who helped with testing and suggestions with this one over the few years that it had evolved to where it had gotten to. despite the grief at times, it was quite satisfying implementing this but such has come it's time.

-daz
DrO is offline   Reply With Quote
Old 25th May 2006, 15:02   #319
ujay
Forum King
 
ujay's Avatar
 
Join Date: Jul 2001
Location: London
Posts: 6,072
Thanks for all your efforts on this DrO

This is one of those add ons that transforms a program, as far as I'm concerned it made Winamp about the only choice for listening to net radio

UJ
ujay is offline   Reply With Quote
Old 26th May 2006, 16:26   #320
yokotaashi
Junior Member
 
Join Date: May 2006
Location: Colorado
Posts: 19
Fixed

In response to my earlier problem, I discovered that when the wpl was imported, it was the file paths that confused Winamp...simple fix was to move Winamp from program files and put in 'my music' (or wherever the music files are stored) so that the paths work. after that, the wpls could be 'import playlist' which would add an m3u version of the playlist yo the winamp folder. I am asuming that the winamp folder could then be moved back to program files, but I havnt tested this yet...
yokotaashi is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump