Old 12th December 2003, 16:32   #81
shuzz
Member
 
shuzz's Avatar
 
Join Date: Dec 2003
Location: Costa Rica
Posts: 50
Re: question

Quote:
Originally posted by SailorMax
And in Classic-mode docking work much better, than in Modern-mode...
Try dock it to taskbar, if taskbar bottom , and dblclick on winamp.
Did you check: config drawer->options->winshade [within the modern skin]
Try Unlink Position and Width
That way you can set the size and position of the winshade and the main window separately

That might work [i hope it does...]
shuzz is offline  
Old 12th December 2003, 17:28   #82
QuietBritishJim
Member
 
QuietBritishJim's Avatar
 
Join Date: Dec 2000
Location: London
Posts: 65
Send a message via Yahoo to QuietBritishJim
Quote:
Originally posted by DJ Egg
Can't reproduce the 'main window disappearing' problem.
Here's my version of events:
1) Switch to a classic skin.
2) Turn taskbar entry OFF and systray entry ON
3) Bring the main window to the front, and show the playlist editor but not the equaliser (leave this hidden).
4) Minimise the main window (obviously the playlist editor window will minimise too).
5) Exit winamp by right-clicking the systray and choosing "exit".
This next step is vital:
6) Forget that winamp was minimised when you exited it
7) Start winamp again.

The main window will still be minimised (correctly) but the playlist editor will come into view (real bug). So if you've followed step 6 right it looks like the main window disappeared on startup. If you skip it, then the bug is the playlist editor forgetting to stay minimised.

Of course it's possible that I'm talking about a totally different bug (or "feature" ).
QuietBritishJim is offline  
Old 12th December 2003, 17:49   #83
thecow
Junior Member
 
Join Date: Dec 2003
Posts: 2
I would love to see just TWO THINGS
added to the modern skin.

* fix the windowshade docking problem when
docking to the bottom of the screen.

* When opening a drawer, leave a button on
the main section, so you can easily open and
close the drawer without moving the mouse

These two features would definitely
increase the ease of use.
thecow is offline  
Old 12th December 2003, 17:54   #84
thecow
Junior Member
 
Join Date: Dec 2003
Posts: 2
(if the above post should be in a different section of the forum...I apologize, first time posting and it seemed somewhat appropriate)

And if someone can find a better solution to the docking problem with the modern skin other than selecting "unlock position and width", please let me know.
thecow is offline  
Old 12th December 2003, 18:00   #85
SailorMax
Junior Member
 
Join Date: Dec 2003
Location: Latvia
Posts: 21
Re: Re: question

Quote:
Try Unlink Position and Width
That way you can set the size and position of the winshade and the main window separately
That might work [i hope it does...] [/B]
it work!
but not logistical usual user...

May be can make something with opening "Config"-subwindow under main window in modern-mode in same position(docked with taskbar) ?
SailorMax is offline  
Old 12th December 2003, 18:11   #86
Rellik
Major Dude
 
Rellik's Avatar
 
Join Date: Oct 2003
Location: localhost
Posts: 1,099
My interpretation of RC666 is that Nullsoft is having a HELL of a time getting the DAMN thing released to the public
Rellik is offline  
Old 12th December 2003, 18:46   #87
DrO
 
Join Date: Sep 2003
Posts: 27,873
Run on a clean install (rc666) using the classic base skin (or anyother classic skin).

Resize the playlist window and then press 'F5'.
The playlist is resized to the default size and an unpainted window is show for the area where the playlist window was.

Moving the window or resizing it will clear the effect.

-daz
DrO is offline  
Old 12th December 2003, 18:52   #88
The Serminator
Senior Member
 
The Serminator's Avatar
 
Join Date: Nov 2003
Location: on the road to Elysium with my pockets full of diamonds
Posts: 132
The Apocalypse thing is happening again!

I just started Winamp (as described in my previous post, I have it set to begin with a completely random song and) and it picked...

you guessed it -- song number 666!

This really is getting creepy.


"Come with me, if you want to live."
The Serminator is offline  
Old 12th December 2003, 18:54   #89
shuzz
Member
 
shuzz's Avatar
 
Join Date: Dec 2003
Location: Costa Rica
Posts: 50
Quote:
Originally posted by QuietBritishJim
.......

The main window will still be minimised (correctly) but the playlist editor will come into view (real bug). So if you've followed step 6 right it looks like the main window disappeared on startup. If you skip it, then the bug is the playlist editor forgetting to stay minimised.

Of course it's possible that I'm talking about a totally different bug (or "feature" ).
it happend the same to me....
shuzz is offline  
Old 12th December 2003, 18:54   #90
StAnGeR04
Senior Member
 
StAnGeR04's Avatar
 
Join Date: Oct 2003
Location: Far East Coast
Posts: 196
Send a message via AIM to StAnGeR04 Send a message via Yahoo to StAnGeR04
if Brennan and Aus were fired and this is how AO*Hell treats their most capable and dedicated employees it makes me all the more happy that I didn't take the aol tech support job a few years ago

I hope ao*hell knows what it's doing firing them ...if that's what happened

just saying that seeing as that I don't know for sure myself
StAnGeR04 is offline  
Old 12th December 2003, 19:06   #91
WhiteRayven
Major Dude
 
WhiteRayven's Avatar
 
Join Date: Aug 2003
Posts: 682
I have had a bunch of weird things happen with rc666 so I went back to rc10. I cant explain what it was, but for some reason it would randomly close winamp and the agent

Why make something idiot proof?? Someone will only make a better idiot!
WhiteRayven is offline  
Old 12th December 2003, 19:40   #92
Gonzotek
Gunslinger
 
Gonzotek's Avatar
 
Join Date: May 2000
Location: Terminus
Posts: 4,693
Quote:
Originally posted by DrO
Run on a clean install (rc666) using the classic base skin (or anyother classic skin).

Resize the playlist window and then press 'F5'.
The playlist is resized to the default size and an unpainted window is show for the area where the playlist window was.

Moving the window or resizing it will clear the effect.

-daz
Reproduced, reporting to betalist. I haven't switched to the classic skin since the early alphas, hehe.

Thanks!

I was away for a while.
But I'm feeling much better now.
Gonzotek is offline  
Old 12th December 2003, 19:52   #93
Prorok
Junior Member
 
Join Date: Apr 2003
Posts: 39
666 kicks ass
Prorok is offline  
Old 12th December 2003, 20:00   #94
squall14716
Senior Member
 
Join Date: Oct 2002
Location: 127.0.0.1
Posts: 349
Send a message via ICQ to squall14716 Send a message via AIM to squall14716 Send a message via Yahoo to squall14716
Quote:
Originally posted by QuietBritishJim
Here's my version of events:
1) Switch to a classic skin.
2) Turn taskbar entry OFF and systray entry ON
3) Bring the main window to the front, and show the playlist editor but not the equaliser (leave this hidden).
4) Minimise the main window (obviously the playlist editor window will minimise too).
5) Exit winamp by right-clicking the systray and choosing "exit".
This next step is vital:
6) Forget that winamp was minimised when you exited it
7) Start winamp again.

The main window will still be minimised (correctly) but the playlist editor will come into view (real bug). So if you've followed step 6 right it looks like the main window disappeared on startup. If you skip it, then the bug is the playlist editor forgetting to stay minimised.

Of course it's possible that I'm talking about a totally different bug (or "feature" ).
The main window has disappeared on me before without closing/opening Winamp. It just... disappeared. I ended up fixing it by switching to a modern skin and then back to the classic skin I was using.
squall14716 is offline  
Old 12th December 2003, 20:24   #95
shuzz
Member
 
shuzz's Avatar
 
Join Date: Dec 2003
Location: Costa Rica
Posts: 50
Quote:
Originally posted by squall14716
The main window has disappeared on me before without closing/opening Winamp. It just... disappeared. I ended up fixing it by switching to a modern skin and then back to the classic skin I was using.
can you explain how were you getting the "missing window"??
shuzz is offline  
Old 12th December 2003, 20:56   #96
CyberHawk
Junior Member
 
Join Date: Jan 2001
Location: Scotland
Posts: 22
Send a message via ICQ to CyberHawk Send a message via AIM to CyberHawk
Yippeee!!!

Excellent to see Winamp 5 almost going Gold
CyberHawk is offline  
Old 12th December 2003, 20:58   #97
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Yup, I'm still waiting for steps to reproduce this 'missing main window' thing.

The issue referred to by QuietBritishJim above is a known / reported bug
(been reported many many times, but remains unfixed).
However, *that* has got nothing to do with the main window disappearing.
In this case, as QBJ rightfully states, the main window is correctly minimized (as it should be after closing winamp in a minimized state). The bug being that the playlist window (and video window too, if it was previously open) is maximized, when it should also be minimized.

Still waiting...
DJ Egg is offline  
Old 12th December 2003, 21:35   #98
shuzz
Member
 
shuzz's Avatar
 
Join Date: Dec 2003
Location: Costa Rica
Posts: 50
so, is there another 'missing main window'??? i thought it was the one QuietBritishJim was talking about.....
shuzz is offline  
Old 12th December 2003, 21:49   #99
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
http://forums.winamp.com/showthread....05#post1197005
http://forums.winamp.com/showthread....46#post1197246
...and the post straight after, by redbox

Yeah, they're probably referring to the minimize bug
which is why I keep asking for details about this mysterious disappearing window issue (which probably doesn't even exist, lol)

Well . . . ya know me, I do luv a good larrrff
DJ Egg is offline  
Old 12th December 2003, 21:54   #100
ChaosBlade
Senior Member
 
ChaosBlade's Avatar
 
Join Date: Nov 2003
Location: Israel
Posts: 115
Send a message via ICQ to ChaosBlade Send a message via AIM to ChaosBlade Send a message via Yahoo to ChaosBlade
I can confirm it too. Sometimes when i minimize winamp and restore it only the playlist window appears and the main window is missing .. though it happpend to me in earlier RC versions and havent happend yet in RC8\10\666 so im not sure if its fixed .

Thats all i can tell, nothing about reproducing it, sorry :\
ChaosBlade is offline  
Old 12th December 2003, 22:00   #101
shuzz
Member
 
shuzz's Avatar
 
Join Date: Dec 2003
Location: Costa Rica
Posts: 50
that mysterious disappearing window must be the same QuietBritishJim described, at least until somebody demonstrates the opposite!!!
shuzz is offline  
Old 12th December 2003, 22:04   #102
shuzz
Member
 
shuzz's Avatar
 
Join Date: Dec 2003
Location: Costa Rica
Posts: 50
Quote:
Originally posted by Angel Of The Fl
I can confirm it too. Sometimes when i minimize winamp and restore it only the playlist window appears and the main window is missing .. though it happpend to me in earlier RC versions and havent happend yet in RC8\10\666 so im not sure if its fixed .

Thats all i can tell, nothing about reproducing it, sorry :\
I just tested it in RC666, it does happens if you do it as QuietBritishJim said...
shuzz is offline  
Old 12th December 2003, 22:20   #103
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Oh ffs
so why are we even discussing a known bug that's been reported 10+ times?
DJ Egg is offline  
Old 12th December 2003, 22:46   #104
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally posted by Gonzotek
Reproduced, reporting to betalist. I haven't switched to the classic skin since the early alphas, hehe.

Thanks!
not a problem was the first thing i did when doing my rc666 jtfe tests

-daz
DrO is offline  
Old 12th December 2003, 23:11   #105
CraigF
Passionately Apathetic
Administrator
 
CraigF's Avatar
 
Join Date: May 2000
Location: Hell
Posts: 5,435
[leak]
* fixed classic skin refresh bug in gen_ff
[/leak]

CraigF is offline  
Old 12th December 2003, 23:33   #106
DrO
 
Join Date: Sep 2003
Posts: 27,873
yay
DrO is offline  
Old 12th December 2003, 23:46   #107
QuietBritishJim
Member
 
QuietBritishJim's Avatar
 
Join Date: Dec 2000
Location: London
Posts: 65
Send a message via Yahoo to QuietBritishJim
Quote:
Originally posted by CraigF
[leak]
* fixed classic skin refresh bug in gen_ff
[/leak]
Nice This is the only bug I've ever seen... if the main window disappears some other way I'll be sure to add a fuzzy bug report to this thread
QuietBritishJim is offline  
Old 13th December 2003, 01:51   #108
Carnicero
Member
 
Join Date: Oct 2002
Posts: 62
Can someone confirm something for me?

While using the default Modern skin, try placing the Playlist Editor underneath the main player window and open the config drawer. Does the drawer open over top of the PL window or does it push the window down with the drawer still snapped to the top? For me, the PL is snapping to the bottom edge of the drawer, not the the "chassis" of the main player.

I need to know if I'm the only one experiencing this so I can compile system specs for a potential bug report or try hacking the skin. This problem has always been present for me since beta2. The beta1 Winamp Modern skin drawer worked correctly.
Carnicero is offline  
Old 13th December 2003, 02:15   #109
Sawg
Guest
 
Posts: n/a
That's expected functionality.
(Read: It's susposed to do that, it's not a bug).
 
Old 13th December 2003, 02:28   #110
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
@ Carnicero

You asked this same question here
http://forums.winamp.com/showthread....62#post1174862
http://forums.winamp.com/showthread....76#post1172476
http://forums.winamp.com/showthread....93#post1170993
http://forums.winamp.com/showthread....94#post1170594

I'm sure you must've gotten a reply somewhere along the line?

Try the suggestions here:
http://forums.winamp.com/showthread.php?threadid=158745


[edit] And as Sawg says, yes, it was a bug/unimplemented feature which was fixed [/edit]
DJ Egg is offline  
Old 13th December 2003, 03:55   #111
Carnicero
Member
 
Join Date: Oct 2002
Posts: 62
I didn't get any serious replies except yours. That's why I asked a few times since beta2, because the threads kept changing and sinking down to the bottom.

The windows snaps correctly, it's just wierd as hell when the PL window gets pushed offscreen when positioned in the lower right of the desktop. I just thought it was a bug since the windows don't get pushed around when docking the PL window on top and opening the video/vis drawer from the top.

Anyways, I'll stop asking about it if it's not such a big deal to everyone.
Carnicero is offline  
Old 13th December 2003, 04:42   #112
Winner2
Member
 
Join Date: Jul 2002
Posts: 62
Quote:
Originally posted by QuietBritishJim
Here's my version of events:
1) Switch to a classic skin.
2) Turn taskbar entry OFF and systray entry ON
3) Bring the main window to the front, and show the playlist editor but not the equaliser (leave this hidden).
4) Minimise the main window (obviously the playlist editor window will minimise too).
5) Exit winamp by right-clicking the systray and choosing "exit".
This next step is vital:
6) Forget that winamp was minimised when you exited it
7) Start winamp again.

The main window will still be minimised (correctly) but the playlist editor will come into view (real bug). So if you've followed step 6 right it looks like the main window disappeared on startup. If you skip it, then the bug is the playlist editor forgetting to stay minimised.

Of course it's possible that I'm talking about a totally different bug (or "feature" ).
The known behavior described by QuietBritishJim is exactly the problem I was referring to (though I did not "forget" Winamp was minimized). Thus my wording "hasn't been fixed yet." My apologies for not being so specific on this, but I believed that this bug was so well known and documented there would be little question what I was referring to.

My experience though also includes this item:

8) Left-click of Winamp icon in taskbar does not consistently bring the main window on screen; the playlist window remains by itself (no, the main window is not hidden behind). Only a right-click and then left-click on Restore always brings it back.

In my current session, the left click on the icon sometimes does and sometimes does not bring the main window on screen after the sequence of events described by QuietBritishJim.

Because the main window does not return with a left click on the taskbar icon, I think it can understandably be interpreted and reported by users as a missing window.

I do happen to be running the Enhancer v. 0.17 plugin and title scrolling is enabled in General Preferences.
Winner2 is offline  
Old 13th December 2003, 04:57   #113
Bh420
Junior Member
 
Join Date: Nov 2003
Location: Idaho
Posts: 22
24.119.168.187 > finger Justin@landoleet.org
Login: justin Name: Justin
Directory: /home/deadbeef Shell: /usr/local/bin/tcsh
New mail received Thu Oct 9 15:07 2003 (PDT)
Unread since Mon Mar 10 12:28 2003 (PST)
Mail forwarded to:
"|IFS=' '&&exec /usr/local/bin/procmail -f-||exit 75 #deadbeef"
Plan:
December 12, 2003 @ 7:54pm
Ah relaxing in AZ. Missing my girl, had good dreams about kissing her last
night... It's been a very very good 4 years.

Monday (the 15th) we're gonna launch wa5. woot.



Sweeeeeeeeeeeeeeeeeeeeeeeet
Bh420 is offline  
Old 13th December 2003, 07:03   #114
iron2000
Senior Member
 
iron2000's Avatar
 
Join Date: Mar 2002
Location: Singapore
Posts: 391
I've witnessed the missing main window bug too.
Sometimes when I have it minimised to taskbar and then restore, no main window, only playlist.

Haven't seen it on 666 yet but seen it on the past RCs.

Thanx
iron2000 is offline  
Old 13th December 2003, 07:49   #115
WhiteRayven
Major Dude
 
WhiteRayven's Avatar
 
Join Date: Aug 2003
Posts: 682
Man, Justin says the 15th, I believe that when I see it.

Why make something idiot proof?? Someone will only make a better idiot!
WhiteRayven is offline  
Old 13th December 2003, 10:42   #116
Dextro
Senior Member
 
Dextro's Avatar
 
Join Date: May 2002
Location: Lisbon, Portugal
Posts: 293
w00t?!?!?! Still 2 days to go?!?!?! I don't think I can wait!!!!!!! :-P
I don't think I can wait for the new website that is, wa5 rc666 is the devil blowing out my ears if you know what I mean!

Dextro is offline  
Old 13th December 2003, 11:03   #117
Wish
Major Dude
 
Join Date: Oct 2000
Posts: 702
Winamp5 is final now, at least thats what I've seen.

Wish is offline  
Old 13th December 2003, 11:20   #118
Paparazzi
Senior Member
 
Join Date: Jan 2002
Posts: 358
Quote:
Originally posted by Wish
Winamp5 is final now, at least thats what I've seen.

Yeah... Guess its just a matter of whether one wants the stamp of the devil or not
Paparazzi is offline  
Old 13th December 2003, 12:03   #119
Wildrose-Wally
The Albertan
 
Wildrose-Wally's Avatar
 
Join Date: Mar 2001
Location: Sunny Southern Alberta
Posts: 6,133
The final will not have 666 on it, so not to worry.

Winamp 5.0rc666 is old anyway, should see what the beta tester got to play with now.

Wildrose-Wally is offline  
Old 13th December 2003, 15:25   #120
Gonzotek
Gunslinger
 
Gonzotek's Avatar
 
Join Date: May 2000
Location: Terminus
Posts: 4,693
Quote:
Originally posted by Wish
Winamp5 is final now, at least thats what I've seen.

About as Final as any Winamp build ever is . What are we on now, the third or fourth "final" build in under 24hrs?

I was away for a while.
But I'm feeling much better now.
Gonzotek is offline  
Closed Thread
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump